在线检测未来函数

通达信打酱油主图指标公式

来源:Internet,编辑:股旁网,2012-10-16

MA5:=MA(C,5);
MA10:=MA(C,10);
均线差:=MA5-MA10;
JC:=MA10-MA5;
绿柱面积:=IF (均线差<0,SUM(均线差*0.1,BARSLAST(JC<0)),0);
红柱面积:=IF (均线差>0,SUM(均线差*0.1,BARSLAST(JC>0)),0);
均线面积:=IF(均线差>0,红柱面积,绿柱面积),COLOR0000FF,LINETHICK0;
A881:=IF(均线差>0,1,-1);
A882:=REF(A881,1);
A8813:=A881*A882;
A884:=BARSLAST(A8813<0);
A885:=A884+1;
趋势平均力度:=(SUM(均线差,0)-REF(SUM(均线差,0),A885))/A885,COLORFF00FF;
DRAWNUMBER(REF(均线差,1)>0 AND 均线差<=0 ,HHV(H,8),REF(红柱面积,1)),COLORRED;
DRAWNUMBER(REF(均线差,1)>0 AND 均线差<=0 ,HHV(H,8),REF(趋势平均力度,1)),COLORFF00FF;
DRAWNUMBER(REF(均线差,1)<0 AND 均线差>=0 ,LLV(L,8),REF(ABS(绿柱面积),1)),COLORGREEN;
DRAWNUMBER(REF(均线差,1)<0 AND 均线差>=0 ,LLV(L,8),REF(ABS(趋势平均力度),1)),COLORGREEN;
{ Gupang.com 股-旁-网_通达信股票指标公式}
DRAWNUMBER(ISLASTBAR AND 均线差<0,LLV(L,5),ABS(绿柱面积));
DRAWNUMBER(ISLASTBAR AND 均线差<0,LLV(L,5),ABS(趋势平均力度));
DRAWNUMBER(ISLASTBAR AND 均线差>0,HHV(H,5),ABS(红柱面积));
DRAWNUMBER(ISLASTBAR AND 均线差>0,HHV(H,5),ABS(趋势平均力度));
油客:=REF(C,1);
打酱油:=SMA(MAX(C-油客,0),6,1)/SMA(ABS(C-油客),6,1)*100;
DRAWTEXT(CROSS(84,打酱油),H*1.01,'油客逃顶'),COLORYELLOW ;
DRAWICON(CROSS(82,打酱油),HIGH,2);

通达信打酱油主图指标公式

 

相关文章