在线检测未来函数

大智慧金银柱主图指标公式

来源:Internet,编辑:股旁网,2012-10-19

TODAY:="SV-ddx.ddx"=0;
主单买:=IF(TODAY,"DDEDATA@BIGORDER"(1,2),bigorder(1,2));
主单卖:=IF(TODAY,"DDEDATA@BIGORDER"(2,2),bigorder(2,2));
特单买:=IF(TODAY,"DDEDATA@BIGORDER"(1,3),bigorder(1,3));
特单卖:=IF(TODAY,"DDEDATA@BIGORDER"(2,3),bigorder(2,3));
大单买:=IF(TODAY,("DDEDATA@BIGORDER"(1,2)-"DDEDATA@BIGORDER"(1,3)),(bigorder(1,2)-bigorder(1,3)));
大单卖:=IF(TODAY,("DDEDATA@BIGORDER"(2,2)-"DDEDATA@BIGORDER"(2,3)),(bigorder(2,2)-bigorder(2,3)));
中单买:=IF(TODAY,("DDEDATA@BIGORDER"(1,1)-"DDEDATA@BIGORDER"(1,2)),(bigorder(1,1)-bigorder(1,2)));
中单卖:=IF(TODAY,("DDEDATA@BIGORDER"(2,1)-"DDEDATA@BIGORDER"(2,2)),(bigorder(2,1)-bigorder(2,2)));
小单买:=IF(TODAY,1-("DDEDATA@BIGORDER"(1,1)),1-(bigorder(1,1)));
小单卖:=IF(TODAY,1-("DDEDATA@BIGORDER"(2,1)),1-(bigorder(2,1)));
HS:=vol/capital;
CD:=特单买-特单卖;
超大:=HS*CD*100;
超持:= 25+Sum(超大,0);
DD:=大单买-大单卖;
大户:=HS*DD*100;
大持:=25+Sum(大户,0);
ZD:=中单买-中单卖;
中户:=HS*ZD*100;
中持:= 25+Sum(中户,0);
XD:=小单买-小单卖;
散户:=HS*XD*100;
散持:= 25+Sum(散户,0);
主力:=(超大+大户);
主持:=(超持+大持);
TT:=散持+中持;
TG:=(TT-REF(TT,1));
T4:=(主持-REF(主持,1));
GR:=(TG-REF(TG,1));
CD:=(T4-REF(T4,1));
TG1:=(TG-REF(TG,1))*capital*c;
T41:=(T4-REF(T4,1))*capital*c;
CDCG:=FINANCE2(37)*10000*CD/100;
GRCG:=FINANCE2(37)*10000*GR/100;
主力成本:EMA(CLOSE,17),linethick1,COLORRED,PRECIS2;
个人成本:EMA(CLOSE,33),linethick1,COLORGREEN,PRECIS2;
平均成本:EMA(CLOSE,24),linethick1,color33FFFF,PRECIS2;
partline(平均成本,平均成本>=ref(平均成本,1),rgb(250,0,250),平均成本<ref(平均成本,1),rgb(0,255,255)),linethick1;
主力持仓:超持+大持,linethick0,COLORRED,PRECIS1;
个人持仓:中持+散持,linethick0,COLORGREEN,PRECIS1;
{ Gupang.com 股-旁-网_大智慧股票指标公式}
A1:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,3)+EMA((OPEN+HIGH+LOW+CLOSE)/4,6)+EMA((OPEN+HIGH+LOW+CLOSE)/4,9))/3;
A2:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,5)+EMA((OPEN+HIGH+LOW+CLOSE)/4,10)+EMA((OPEN+HIGH+LOW+CLOSE)/4,20))/3;
A3:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,7)+EMA((OPEN+HIGH+LOW+CLOSE)/4,14)+EMA((OPEN+HIGH+LOW+CLOSE)/4,28))/3;
A4:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,9)+EMA((OPEN+HIGH+LOW+CLOSE)/4,18)+EMA((OPEN+HIGH+LOW+CLOSE)/4,36))/3;
A5:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,11)+EMA((OPEN+HIGH+LOW+CLOSE)/4,22)+EMA((OPEN+HIGH+LOW+CLOSE)/4,44))/3;
A6:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,13)+EMA((OPEN+HIGH+LOW+CLOSE)/4,26)+EMA((OPEN+HIGH+LOW+CLOSE)/4,52))/3;
A7:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,21)+EMA((OPEN+HIGH+LOW+CLOSE)/4,34)+EMA((OPEN+HIGH+LOW+CLOSE)/4,68))/3;
TOWERC:=FORCAST(EMA((3*CLOSE+2*OPEN+HIGH+LOW)/7,3),6);
DIRECTIONMAX:=MAX(REF(TOWERC,1),REF(TOWERC,1));
DIRECTIONMIN:=MIN(REF(TOWERC,1),REF(TOWERC,1));
{银柱}
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,15,0),COLOR333333;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,13,0),COLOR333333;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,11,0),COLOR333333;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,10,0),COLOR333333;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,7,0),COLOR444444;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,6,0),COLOR555555;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,5,0),COLOR777777;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,4,0),COLOR999999;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,3,0),COLORbbbbbb;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,2,0),COLORdddddd;
STICKLINE(TOWERC<REF(TOWERC,1),TOWERC,DIRECTIONMIN,1,0),COLORffffff;
{金柱}
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,15,0),COLOR004444;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,13,0),COLOR004444;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,11,0),COLOR004444;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,10,0),COLOR004444;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,7,0),COLOR005555;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,6,0),COLOR006666;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,5,0),COLOR007777;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,4,0),COLOR009999;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,3,0),COLOR00bbbb;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,2,0),COLOR00dddd;
STICKLINE(TOWERC>=REF(TOWERC,1),TOWERC,DIRECTIONMAX,1,0),COLOR00ffff;

大智慧金银柱主图指标公式

 

相关文章