在线检测未来函数

通达信五彩乘与开方主图指标公式

来源:Internet,编辑:股旁网,2012-10-19

N:=9;M:=21;
今日保护价:(REF(C,1)+REF(C,2)+O)/3,NODRAW;
GD1:=HHV(HIGH,N);
DD1:=LLV(LOW,N);
XJ1:=GD1*DD1;
KF1:=SQRT(XJ1),COLORGREEN,LINETHICK3;
GD2:=HHV(HIGH,M);
DD2:=LLV(LOW,M);
XJ2:=GD2*DD2;
KF2:=SQRT(XJ2),COLORFFFF00,LINETHICK3;
QSX1:KF1,COLOR00FFFF,LINETHICK3;
QSX2:KF2,COLORFFFF00,LINETHICK3;
DRAWBAND(QSX1,RGB(208,50,90),QSX2,RGB(110,130,160));
AA:=QSX1>=QSX2 AND C>=QSX1;
BB:=QSX1>=QSX2 AND (C>=QSX2 AND C<QSX1);
DD:=QSX1>=QSX2 AND C<QSX2;
EE:=QSX1<QSX2 AND C>=QSX1;
FF:=QSX1<QSX2 AND C<QSX1;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,H,L,0,0),COLORFF00FF;
STICKLINE(DD,H,L,0,0),COLOR66CCFF;
STICKLINE(EE,H,L,0,0),COLORFFFF00;
STICKLINE(FF,H,L,0,0),COLORAFD788;
STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.6,0),COLOR0000AA;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE(AA,CLOSE,OPEN,1.3,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR990099;
STICKLINE(BB,CLOSE,OPEN,2.6,0),COLORAA00AA;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORBB00BB;
STICKLINE(BB,CLOSE,OPEN,1.8,0),COLORDD00DD;
STICKLINE(BB,CLOSE,OPEN,1.3,0),COLOREE00EE;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORFF00FF;
STICKLINE(DD,C,O,3.4,0),COLOR225588;
STICKLINE(DD,C,O,3.0,0),COLOR3377AA;
STICKLINE(DD,C,O,2.4,0),COLOR3388BB;
STICKLINE(DD,C,O,1.6,0),COLOR44AADD;
STICKLINE(DD,C,O,1.0,0),COLOR55BBEE;
STICKLINE(DD,C,O,0.6,0),COLOR66CCFF;
STICKLINE(EE,C,O,3.4,0),COLOR888800;
STICKLINE(EE,C,O,3.0,0),COLOR999900;
STICKLINE(EE,C,O,2.4,0),COLORAAAA00;
STICKLINE(EE,C,O,1.6,0),COLORCCCC00;
STICKLINE(EE,C,O,1.0,0),COLORDDDD00;
STICKLINE(EE,C,O,0.5,0),COLORFFFF00;
STICKLINE(FF,CLOSE,OPEN,3.4,0),COLOR367517;
STICKLINE(FF,CLOSE,OPEN,2.6,0),COLOR489620;
STICKLINE(FF,CLOSE,OPEN,2.2,0),COLOR50A625;
STICKLINE(FF,CLOSE,OPEN,1.8,0),COLOR5BBD2B;
STICKLINE(FF,CLOSE,OPEN,1.3,0),COLOR83C75D;
STICKLINE(FF,CLOSE,OPEN,0.5,0),COLORAFD788;
TYP:=(HIGH+LOW+CLOSE)/3;
{ Gupang.com 股-旁-网_通达信股票指标公式}
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCIA:=EMA(EMA(EMA(CCI,2),2),2);
CCIB:=EMA(EMA(EMA(CCI,3),2),2);
X:=(CROSS(CCIA,CCIB) OR (CCIA>=CCIB))
AND CCIA>=-101 AND CCIA>=REF(CCIA,1)
AND REF(CCIA,1)<-101 ;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K1:= EMA(EMA(EMA(K,2),2),2);
D1:= EMA(EMA(EMA(D,2),2),2);
J1:= EMA(EMA(EMA(J,2),2),2);
Y:= J1>REF(J1,1) ;
YJ:=X AND Y ;
DRAWICON(YJ,(LOW * 0.98),13);
DRAWTEXT(YJ,(LOW * 0.97),'买'),COLORYELLOW;
LC5:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC5,0),6,1)/SMA(ABS(CLOSE-LC5),6,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
DA:=SMA(CCC,3,1);
DRAWICON(CROSS(DA,RSI5),H*1.04,15);
DRAWTEXT(CROSS(DA,RSI5),H*1.05,'↙短逃');
DRAWICON(CROSS(80,RSI5),H*1.07,14);
DRAWTEXT(CROSS(80,RSI5),H*1.09,'↙短逃');
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
周15:=FILTER(CROSS(80,RSI1) AND RSI1<REF(RSI1,1),8);
DRAWICON(周15,H*1.12,35);
DRAWTEXT(CROSS(80,RSI5),H*1.11,'↙逃顶');

通达信五彩乘与开方主图指标公式

 

相关文章