在线检测未来函数

通达信倾家荡产买卖指标公式

来源:Internet,编辑:股旁网,2012-10-19

K2:=EMA(C,5),COLORFFFF00;
K3:=EMA(C,10),COLORFFFF00;
K5:=EMA(C,30),COLORFFFF00;
KK5:=EMA(INDEXC,30),COLORFFFF00;
A10:=EMA(C,10);
K6:=2*(K2-K5);K7:=2*(K2-K3);
K8:=2*(K7+K6),COLORRED;
VAR1:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR2:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR3:=(100-MA(((100*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6))),34));
{ Gupang.com 股-旁-网_通达信股票指标公式}
年:=MA(CLOSE,26),COLORGREEN,LINETHICK0;
箱底:LLV(MA((LOW),5),30),COLORGREEN,LINETHICK1;
长箱底:LLV(MA((LOW),5),60),LINETHICK1;
长长箱底:LLV(MA((LOW),5),100),COLORCYAN,LINETHICK1;
长长箱顶:HHV(MA((HIGH),6),120),LINETHICK1;
长箱顶:HHV(MA((HIGH),6),60),COLORRED,LINETHICK1;
箱顶:HHV(MA((HIGH),6),30),COLOR00AAFF,LINETHICK1;
中间:(箱顶+箱底)/2,COLORFF00FF,LINETHICK3;
启动线:EMA(C,2),COLOR00FF00,LINETHICK2;
WX:EMA(C,5),COLORWHITE,LINETHICK2;
STICKLINE(CROSS(WX,中间),中间-0.8,中间+0.8,8,0) ,COLORWHITE;
STICKLINE(CROSS(WX,长箱顶),长箱顶-0.8,长箱顶+0.8,10,0) ,COLORYELLOW,LINETHICK2;
STICKLINE(CROSS(WX,箱顶),箱顶-0.5,箱顶+0.5,10,0) ,COLORGREEN;
STICKLINE(WX>中间,中间,WX,0,-1),COLORFF00FF;
STICKLINE(中间>WX,WX,中间,0,-1),COLORLIGREEN;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,5,0),COLORCYAN;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,5,0),COLORRED;VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);
BH:=((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;
BL:=((((-1))*(EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))+0.01)*(38)),COLOR339999,LINESTICK;
VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
桥:(EMA(VAR66,1)),COLOR007700,LINETHICK1;
跨:(REVERSE(桥)),COLORFFFFFF,LINETHICK1;
{(0),COLORFFFF00,LINETHICK3;}
趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))
/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
底部:=5;
{底:DRAWTEXT((CROSS(趋势,底部)),0,'◥◤'),COLOR00FFFF;}
DRAWTEXT(CROSS((趋势),底部),15,'◢◣'),COLOR00FFFF;
{DRAWTEXT(CROSS(趋势,底部),0,'★'),COLORRED;
DRAWTEXT(CROSS(趋势,底部),20,'●'),COLORGREEN;}
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))
AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))
AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),1);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND (OPEN<MA(CLOSE,20));
VARA1 AND (VARA6),COLORFF0000;
STICKLINE(VARA1 AND (VARA6),-40,40,10,1),COLOR2894FF;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
探底:IF((趋势<=5),58,0),COLORFF00FF;
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
STICKLINE((美化),-20,20,15,1),COLORFFFF00;
{ Gupang.com 股-旁-网_通达信股票指标公式}
MTM1:MA((CLOSE-REF(CLOSE,13))*31,5),LINETHICK1,COLOR7711EE;
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);
VARFC:=LOW;
VARFD:=REF(LOW,1);
VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);
VARF11:=HHV(VARFF,30);
绝佳买点:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200),COLORRED,LINETHICK2;
I:=IF(CLOSE<REF(CLOSE,1),0,VOL/CAPITAL);
骤雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
W:=COST(10)*0;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED;
DEA:=EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA)*231,STICK,COLORRED,LINETHICK1;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLOR00FFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.8,0 ),COLORFFEE44;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFF55BB;
DRAWTEXT(CROSS(绝佳买点,1.20000) ,-32,'疯牛'),COLORYELLOW,LINETHICK2 ;
DRAWTEXT(CROSS(绝佳买点,4.50000) ,63,'倾家荡产买'),COLOR00FFFF,LINETHICK2;
{DRAWTEXT(CROSS(绝佳买点,7.00000) ,88,'疯牛3'),COLORCYAN,LINETHICK4;}
DRAWTEXT(CROSS(绝佳买点,3.60000) ,28,'疯牛2'),COLORFF00FF,LINETHICK4;
{DRAWTEXT(CROSS(绝佳买点,2.40000) ,-55,'疯牛1'),COLORFFFFCC,LINETHICK3 ; };

通达信倾家荡产买卖指标公式

 

相关文章