在线检测未来函数

通达信云端多空主图指标公式

来源:Internet,编辑:股旁网,2012-10-19

MA6:=MA(C,6);
MA18:=MA(C,18);
买进价:=((C-REF(MA6,1))/6+MA6)*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,11);
红K买进:=IF(买进条件,L,H),COLORRED;
STICKLINE(买进条件,H,L,0,0),COLORRED;
STICKLINE(买进条件,O,C,4,0),COLORRED;
加码价:=((C-REF(MA18,1))/18+MA18)*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
紫K加码:=IF(加码条件,L,H),COLORFF0080;
STICKLINE(加码条件,H,L,0,0),COLORFF0080;
STICKLINE(加码条件,O,C,4,0),COLORFF0080;
DRAWTEXT_FIX(1,0.88,5,0,'~☆~云在云端作品~☆~'),COLORRED;
{拐点}
YGB1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
YGB2:=REF(YGB1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB3:=REF(YGB2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB4:=REF(YGB3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB5:=REF(YGB4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB6:=REF(YGB5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB7:=REF(YGB6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB8:=REF(YGB7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB9:=REF(YGB8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGBA:=REF(YGB9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGBB:=REF(YGBA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGBC:=REF(YGBB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGBD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
YGBE:=REF(YGBD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGBF:=REF(YGBE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB10:=REF(YGBF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB11:=REF(YGB10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB12:=REF(YGB11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB13:=REF(YGB12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB14:=REF(YGB13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB15:=REF(YGB14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB16:=REF(YGB15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB17:=REF(YGB16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
YGB18:=REF(YGB17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
YGB19:=REF(YGBD OR YGBE OR YGBF OR YGB10 OR YGB11 OR YGB12 OR YGB13 OR YGB14 OR YGB15 OR YGB16 OR YGB17 OR YGB18,1) AND YGB1;
YGB1A:=REF(YGB1 OR YGB2 OR YGB3 OR YGB4 OR YGB5 OR YGB6 OR YGB7 OR YGB8 OR YGB9 OR YGBA OR YGBB OR YGBC,1) AND YGBD;
STICKLINE(YGB1A,O,O+(C-O)/2,1,0),COLORMAGENTA;
STICKLINE(YGB19,O,O+(O-C)/-2,1,0),COLORYELLOW;
{ Gupang.com 股-旁-网_通达信股票指标公式}
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'*警'),COLORGREEN;
MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'*拉'),COLORYELLOW;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXT_FIX(1,0,0.10,0,'【量能饱和度】')COLORRED;
DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(SAT)),COLORYELLOW;
多头:(SUM(((2*CLOSE+OPEN+HIGH+LOW)/5)*(VOL),8))/(SUM(VOL,8)),COLORYELLOW,LINETHICK1;
空头:LLV(多头,8),LINETHICK1,COLORMAGENTA,LINETHICK1;
A0:=C-C*0.2;
走势:EMA(A0,2)+C*0.2,LINETHICK1,COLORLIGRAY;{走势线隐藏把LINETHICK1换成LINETHICK0即可}
DRAWICON(REF(多头,1)=REF(空头,1) AND 多头>空头,LOW*0.98,11);
DRAWTEXT(REF(多头,1)=REF(空头,1) AND 多头>空头,LOW*0.97,'*预警'),COLORRED;

通达信云端多空主图指标公式

 

相关文章