在线检测未来函数

通达信MACD126指标公式

来源:Internet,编辑:股旁网,2012-10-19

SHORT:=12;LONG:=26;MID:=9;
M12:=EMA((((HIGH-REF(LOW,1))-(LOW-REF(HIGH,1)))/2)+C,SHORT);
M26:=EMA((((HIGH-REF(LOW,1))-(LOW-REF(HIGH,1)))/2)+C,LONG);
DIFF:(M12-M26)/2; DEA:EMA(DIFF,MID);
HISTOGRAM:(DIFF-DEA)*2,COLORSTICK;
{ GUPANG.COM 股-旁-网_通达信股票指标公式}
STICKLINE(HISTOGRAM<REF(HISTOGRAM,1)AND HISTOGRAM>0,0,HISTOGRAM,-2,0),COLORLIGREEN;
STICKLINE(HISTOGRAM<REF(HISTOGRAM,1)AND HISTOGRAM<0,0,HISTOGRAM,-2,0),COLORLICYAN;
STICKLINE(HISTOGRAM>REF(HISTOGRAM,1)AND HISTOGRAM,0,HISTOGRAM,-2,0),COLORLIRED;
STICKLINE(HISTOGRAM>REF(HISTOGRAM,1)AND HISTOGRAM>0,0,HISTOGRAM,-3,0),COLORLIMAGENTA;
DRAWBAND(DIFF,RGB(250,250,250),DIFF,RGB(250,250,250));
DRAWBAND(DEA,RGB(250,250,0),DEA,RGB(250,250,0));

通达信MACD126指标公式

 

相关文章