在线检测未来函数

大智慧神波指标公式

来源:Internet,编辑:股旁网,2012-10-17

input:N(5,1,111),N1(10,1,111),P(3,0.1,30),M(21,0,100);
a1:=(IF((DATE <= 1091025),1,0)) * (IF((CURRENTDATE <= 1091025),1,0));
a2:=IF((CLOSE < 800),((AMOUNT / VOL) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
a3:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;
a4:=EMA((MA(a2,5)),10);
a5:=EMA((MA(a2,15)),10);
a6:=EMA((MA(a2,13)),21);
a7:=((a4 + a5) + a6) / 3;
a8:=(((REF(a7,1)) + a7) + (REF(a7,2))) / 3;
决策线:EMA((MA(CLOSE,5)),3),colorGreen;
PARTLINE(决策线,决策线 > (REF(决策线,3)),RGB(255,0,0)),linethick1,colorRed;
多空价:a8 * a1,linethick2,Color008E00;
{ Gupang.com 股-旁-网_大智慧股票指标公式}
a9:=((EMA((MA(a2,3)),3)) + (WMA(a2,5))) / 2;
a10:=REF(a9,1);
a11:=BARSCOUNT(CLOSE);
a12:=IF((a11 = 1),0,(((a9 - a10) / a10) * 100));
a13:=REF(CLOSE,1);
a14:=IF((a11 = 1),0,(((CLOSE - a13) / a13) * 100));
a15:=IF((a11 = 1),((CLOSE + OPEN) / 2),a10);
a16:=REF(a9,2);
a17:=((a9 + a10) + a16) / 3;
a18:=((ABS((a9 - a17)) + ABS((a10 - a17))) + ABS((a16 - a17))) / 3;
a19:=IF((a11 < 3),0,((a18 / a9) * 100));
a20:=IF((((a12 > 0.5) AND ((a19 > 0.215) OR (LOW > a15))) AND (CLOSE >= OPEN)),1,0);
a21:=IF((((a12 < (0 - 0.3)) AND ((a19 > 0.2) OR (HIGH < a15))) AND ((OPEN >= CLOSE) OR (a14 < -1))),1,0);
B:((COUNT(a20,BARSLAST(a21))) = 1) AND a20,linethick0;
D:((COUNT(a21,BARSLAST(a20))) = 1) AND a21,linethick0;
a22:=BARSLAST(B);
a23:=((SUM(D,a22)) = 0) * a22;
a24:=a23 > 0;
a25:=a23 = 0;
DRAWTEXT(B,(LOW * 0.98),'进'),linethick1,ALIGN1,colorred;
DRAWTEXT(D,(HIGH * 1.035),'出'),linethick1,ALIGN1,colorwhite;

大智慧神波指标公式

 

相关文章