在线检测未来函数

通达信变盘简单主图指标公式

来源:Internet,编辑:股旁网,2012-10-18

S:=2;N:=5;
STICKLINE(CLOSE>= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000066;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,2.6,0 ),COLOR000099;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,2,0 ),COLOR0000CC;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,1.2,0 ),COLOR0000FF;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,0.4,0 ),COLORCC66FF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.6,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.2,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.4,0 ),COLORCYAN;
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
STICKLINE(CROSS(MA(C,2),MA(C,7)),H,C,0.05,0),COLOR0000FF;
STICKLINE(CROSS(MA(C,2),MA(C,7)),C,O,3,0),COLORFF0099 ;
STICKLINE(CROSS(MA(C,2),MA(C,7)),O,L,0.05,0), COLOR0099FF;
XG1:=CROSS(MA(C,7),MA(C,2));
STICKLINE(XG1,H,L,3.5,0),LINETHICK1,COLORWHITE;
STICKLINE(XG1,H,L,0.2,0),COLORGREEN;
STICKLINE(XG1,O,C,3,0),LINETHICK1,COLORGREEN;
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORFF00FF;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORWHITE;
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,3.5,0),COLOR00CCFF;
P:=8;
KE:=V*(H-L)/REF(C,1);
KEP:=KE=HHV(KE,P);
KUD:=BARSLAST(KEP);
阻力1:REFDATE(REF(HHV(H,22),1),DATE),COLORGRAY;
底1:REFDATE(REF(LLV(L,22),1),DATE),COLORGRAY;
DMLJ:=HHV(H,120);
E:=(H+L+O+2*C)/5;
CRTP:=E+(H-L);
CRZL:=2*E-L;
CRZC:=2*E-H;
CRFZ:=E-(H-L);
CRXL:=(E+CRTP+CRZL+CRZC+CRFZ)/5;
高:=CONST(CRTP),COLORRED;
阻:=CONST(CRZL),COLORC7C9FF;
支:=CONST(CRZC),COLOR7C9CFF;
反:=CONST(CRFZ),COLORDD00DD;
心理:=CONST(CRXL);
高压:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,高,ISLASTBAR,高,1),COLOR0000FF;
阻力:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,阻,ISLASTBAR,阻,1),COLOR0099FF;
支撑:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,支,ISLASTBAR,支,1),COLORGREEN;
反转价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,反,ISLASTBAR,反,1),COLORDD00DD;
次日心理价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,心理,ISLASTBAR,心理,1),COLORFFFFFF;
DRAWTEXT(ISLASTBAR,反,' 反 转少量买'),LINETHICK1,COLORDD00DD;
DRAWTEXT(ISLASTBAR,支,' 支 撑'),LINETHICK1,COLOR00FF00;
DRAWTEXT(ISLASTBAR,阻,' 阻 力'),LINETHICK1,COLOR0099FF;
DRAWTEXT(ISLASTBAR,高,' 高 压'),LINETHICK1,COLOR0000FF;
T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
猎击线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLOR00FFFF,LINETHICK1;
DRAWTEXT(ISLASTBAR, T3HIGH, '网买入')LINETHICK1,COLOR00FFFF;
IF(S=1, CRTP,DRAWNULL),COLORRED;
IF(S=1, CRZL,DRAWNULL),COLORC7C9FF;
IF(S=1, CRZC,DRAWNULL),COLOR7C9CFF;
IF(S=1, CRFZ,DRAWNULL),COLORDD00DD;
IF(S=1, CRXL,DRAWNULL),COLORFFDDFF;
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
参考线试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
{ Gupang.com 股-旁-网_通达信股票指标公式}
DRAWTEXT(ISLASTBAR,参考线试买,'参考线试买'),COLORYELLOW,LINETHICK4;
网12:EXPMA(CLOSE,12),COLORGRAY,LINETHICK2;
网33:EXPMA(CLOSE,33),COLORFF00FF,LINETHICK4;
IF(网33<REF(网33,1),网33,DRAWNULL),COLOR00FF00,LINETHICK3;
LC:=REF((O+H+L+2*C)/5,1);
RSI:=SMA(MAX(C-LC,0),7,1)/SMA(ABS(C-LC),7,1)*10;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,23))/(0.015*AVEDEV(TYP,23));
买:=CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),COLORRED;
DRAWTEXT(CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),L,'◆◆黑马◆◆'),COLORWHITE;
DRAWICON(买,(LOW * 0.98),17);
卖:=CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),COLORGREEN;
DRAWTEXT(CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),H*1.04,'■■■逃跑■■■'),COLORGREEN;
DRAWICON(卖,(H*1.03),28);
A11:=(REF(EMA(CLOSE,5),1));
B1:=CROSS(EMA(CLOSE,5),EMA(SLOPE(CLOSE,21)*20+CLOSE,42));
DRAWTEXT(B1,LOW*0.995,'追'),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWTEXT(CROSS(J,D),LOW*0.98,'加'),COLOR00FFFF,LINETHICK2;
VAR29:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR2A:=SMA(VAR29,5,1);
VAR2B:=SMA(VAR2A,10,1);
VAR2C:=CROSS(VAR2B,VAR2A);
VAR2D:=VAR2B>80 OR VAR2A>80;
VAR2E:=VAR2C AND VAR2D;

通达信变盘简单主图指标公式

 

相关文章