在线检测未来函数

通达信谷峰综合顶底指标公式

来源:Internet,编辑:股旁网,2012-10-18

XA1:=MA(CLOSE,20);
XA2:=(CLOSE>MA(CLOSE,5));
XA3:=(MA(CLOSE,5)>MA(CLOSE,10));
XA4:=(CLOSE>MA(CLOSE,10));
XA5:=(MA(CLOSE,5)>MA(CLOSE,20));
XA6:=(CLOSE>MA(CLOSE,20));
XA7:=REF(XA1,1);
XA8:=(XA1>XA7);
AVX:=(((((IF(XA2,10,(0 - 10)) + IF(XA3,10,(0 - 10))) + IF(XA4,10,(0 -10))) +
IF(XA5,10,(0 - 10))) + IF(XA6,10,(0 - 10))) + IF(XA8,10,(0 -10)))+50;
DRAWBAND(AVX,RGB(170,70,0),50,RGB(0,100,110));
谷峰线:AVX,COLOR00FFFF,LINETHICK1;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD:=2*(DIFF-DEA);
A1:=EMA(DIFF,5)*100;
A2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*100;
A3:=IF(A2>0,A2,50),POINTDOT,COLORRED;
A4:=IF(A2<0,A2,50),POINTDOT,COLORGREEN;
L2:=5; L3:=10;
QVAR1:=MA((VOL-REF(VOL,1))/REF(VOL,1),L2);
QVAR2:=(CLOSE-MA(CLOSE,L3))/MA(CLOSE,L3)*100;
MY:=1.5*QVAR2*(1+QVAR1)+50,COLOR00FFFF,LINETHICK3;
QVAR3:=MA(MY,5),COLORFF00FF,LINETHICK2;
DRAWBAND(MY,RGB(250,0,250),QVAR3,RGB(0,200,200));
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
综合乖离:MA(BIAS,3),COLORFFFF00,LINETHICK0;
BIAS底C:IF(综合乖离<-6,60,50),COLORFFFF00,LINETHICK2;
DRAWBAND(BIAS底C,RGB(250,0,0),50,RGB(0,0,0));
N:=3;
VAR01:=MA(HHV(HIGH,485),17);
VAR02:=MA(HHV(HIGH,222),17);
VAR03:=MA(HHV(HIGH,96),17);
VAR04:=MA(LLV(LOW,485),17);
VAR05:=MA(LLV(LOW,222),17);
VAR06:=MA(LLV(LOW,96),17);
VAR07:=MA((VAR04*0.96+VAR05*0.96+VAR06*0.96+VAR01*0.558+VAR02*0.558+VAR03*0.558)/6,17);
VAR08:=MA((VAR04*1.25+VAR05*1.23+VAR06*1.2+VAR01*0.55+VAR02*0.55+VAR03*0.65)/6,17);
VAR09:=MA((VAR04*1.3+VAR05*1.3+VAR06*1.3+VAR01*0.68+VAR02*0.68+VAR03*0.68)/6,17);
VAR10:=MA((VAR07*3+VAR08*2+VAR09)/6*1.738,17);
VAR11:=IF(DATE<=1050531,VAR10,VAR10*DAY);
VAR12:=LOW;
VAR13:=REF(LOW,1);
VAR14:=SMA(ABS(VAR12-VAR13),3,1)/SMA(MAX(VAR12-VAR13,0),N,1)*100;
VAR15:=MA(IF(CLOSE*1.35<=VAR11,VAR14*10,VAR14/10),N);
VAR16:=LLV(LOW,30);
VAR17:=HHV(VAR15,30);
VAR18:=1990831;
VAR19:=IF(DATE<=VAR18,MA(IF(LOW<=VAR16,(VAR15+VAR17*2)/2,0),N),100000000);
VAR20:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*100;
VAR21:=SMA(VAR20,3,1);
VAR22:=SMA(VAR21,3,1);
VAR23:=3*VAR21-2*VAR22;
VAR24:=IF(VAR23>=100,100,IF(VAR23<=0,0,VAR23));
VAR25:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
VAR26:=100+(-ABS(VAR25));
VAR27:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR28:=SMA(SMA(VAR27,9,4),9,4)/7.77777;
VAR29:=EMA(VAR28,5);
VAR30:=3*VAR28-2*VAR29;
VAR31:=CROSS(VAR30,VAR28) AND VAR28<2.7 AND C>O;
VAR32:=(CLOSE-LLV(LOW,17))/(HHV(HIGH,17)-LLV(LOW,17))*100;
VAR33:=(CLOSE-LLV(LOW,50))/(HHV(HIGH,50)-LLV(LOW,50))*100;
VAR34:=SMA(SMA(VAR32,3,1),3,1)+3*STD(CLOSE,10);
VAR35:=SMA(VAR33,3,1);
VAR36:=100-((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17))));
VAR37:=100-(MA(((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17)))),4));
VAR38:=MA(VAR37,1);
VAR39:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部:IF(VAR19>10000 AND VAR19>20000,-5,-15),COLORMAGENTA,LINETHICK1;
DRAWBAND(底部,RGB(0,250,250),-15,RGB(0,0,0));
超低:IF(VAR19>30000 AND VAR19>30000,-10,-15),COLORYELLOW,LINETHICK1;
DRAWBAND(超低,RGB(160,0,230),-15,RGB(0,0,0));
卖出警报:IF((VAR24=0),105,115),COLORGREEN,LINETHICK2;
DRAWBAND(115,RGB(200,230,0),卖出警报,RGB(0,0,0));
超短:=IF((VAR36<VAR38),VAR38,VAR36),COLORFFFFFF,LINETHICK2;
走势:=(VAR38),COLORFFFF00,LINETHICK3;
DRAWBAND(超短,RGB(250,170,0),走势,RGB(0,0,0));
建仓:=IF(VAR39<5,-5,-15),COLORFFFF00,LINETHICK2;
STICKLINE(1,10,10,2,0),COLORFF00FF;
STICKLINE(1,20,20,2,0),COLORFFFF00;
STICKLINE(1,80,80,2,0),COLORFFFFFF;
STICKLINE(1,90,90,2,0),COLOR00FFFF;
AA:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
{ Gupang.com 股-旁-网_通达信股票指标公式}
BB:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;
短底:STICKLINE(CROSS(BB,9),-15,-5,2,0),COLOR0000FF;
STICKLINE(CROSS(BB,9),-5,5,2,0),COLOR00FFFF;
STICKLINE(CROSS(BB,9),5,15,2,0),COLORFF00FF;
DRAWTEXT(CROSS(BB,9),8,'短底'),COLOR00FFFF;
STICKLINE(1,-18,-23,4,1),COLOR686868;
STICKLINE(1,-25,-30,4,1),COLOR686868;
AAA:MY,COLOR00FFFF,LINETHICK1;
BBB:QVAR3,COLORFFFFFF,LINETHICK1;
STICKLINE(AAA>=BBB,-18,-23,4,0),COLORFF00FF;
STICKLINE(超短>走势,-25,-30,4,0),COLOR00CCFF;
AAB:= AVX>=90;
BBBB:= AVX>=70 AND AVX<90;
DDB:= AVX>=50 AND AVX<70;
EEB:=AVX<50 AND AVX>=30;
FFB:=AVX<30;
STICKLINE(AAB,-32,-37,4,0),COLOR0000DD;
STICKLINE(BBBB,-32,-37,4,0),COLORFF00FF;
STICKLINE(DDB,-32,-37,4,0),COLOR00FFFF;
STICKLINE(EEB,-32,-37,4,0),COLORFFFF00;
STICKLINE(FFB,-32,-37,4,1),COLOR686868;
DRAWTEXT_FIX(1,0.3,0.045,0,'【上部彩条-钱龙短线】【中部彩条-锯齿波】【下部彩条-谷峰线】'),COLORFFFF00;

通达信谷峰综合顶底指标公式

 

相关文章