在线检测未来函数

通达信精品合一主图指标公式

来源:Internet,编辑:股旁网,2012-10-18

STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR656500;
STICKLINE(C<O,C,O,2.5,0),COLOR757500;
STICKLINE(C<O,C,O,2,0),COLOR858500;
STICKLINE(C<O,C,O,1.5,0),COLOR959500;
STICKLINE(C<O,C,O,1,0),COLORA5A500;
STICKLINE(C<O,C,O,0.5,0),COLORB5B500;
STICKLINE(C<O,H,L,0,0),COLORC5C500;
AA:=MA(CLOSE,18)+ABS(MA(CLOSE,18)-REF(MA(CLOSE,18),1)),COLORGREEN,LINETHICK2;
BB:MA(CLOSE,18)+MA(CLOSE,18)-REF(MA(CLOSE,18),1),COLORGREEN,LINETHICK2;
CC:IF(MA(CLOSE,18)<BB,BB,MA(CLOSE,18)),COLORRED,LINETHICK2;
AAM:=MA(CLOSE,2);
AM4:=MA(CLOSE,4),COLORFFFFF0;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORGREEN;
AAA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AAA*102/100,COLORFF00FF;
通道2:=AAA*(200-102)/100,COLORFF00FF;
XG:=IF(CROSS(C,MA(CLOSE,18)),1,0),COLOR00FFFF,LINETHICK3;
分位:=(O+C)/2;
昨位:=REF(分位,1);
STICKLINE(ISLASTBAR,昨位,昨位,50,0),COLOR00FF00;
DRAWNUMBER(ISLASTBAR,昨位,昨位);
DRAWTEXT(ISLASTBAR,昨位,'FF');
龙:=MA(CLOSE,33),COLOR00FF00,LINETHICK2;
C1:=REF(C,1);
ZT:=(C-C1)/C1>=0.1-0.01/C1 AND (C=H);
STICKLINE(ZT,C,O,3,0),COLOR00FFFF;
STICKLINE(ZT,C,L,0,0),COLOR00FFFF;
STICKLINE(ZT,C-(C-O)/2,C-(C-O)/2,100,0),COLOR00FFFF;
{2.跌停公式:}
DT:=(C1-C)/C1>=0.1-0.01/C1 AND (C=L);
STICKLINE(DT,C,O,3,0),COLORFC0200;
STICKLINE(DT,O,L,0,0),COLORFC0200;
STICKLINE(DT,C-(C-O)/2,C-(C-O)/2,100,0),COLORFC0200;
MA1:=MA(CLOSE,5);
拐点:=MA1>REF(MA1,1);
XGG:=拐点{ AND NOT(REF(拐点,1)) AND REF(MA1,1)< REF(MA1,2) AND REF(MA1,2)< REF(MA1,3)};
{ Gupang.com 股-旁-网_通达信股票指标公式}
Z:=IF(CURRBARSCOUNT=1,C,DRAWNULL);
收盘线:IF(CURRBARSCOUNT<3600,REFDATE(Z,DATE),DRAWNULL),COLORC0C0C0,DOTLINE;
DRAWICON(XG,{MA1*0.98}收盘线*0.8,9);
DRAWICON(FILTER(买=1,5),收盘线*0.8,1),COLORGREEN;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
{Z:=IF(CURRBARSCOUNT=1,C,DRAWNULL);}
Z线:IF(CURRBARSCOUNT<3600,REFDATE(Z,DATE),DRAWNULL),COLORC0C0C0,DOTLINE;
A77:=(3*C+L+O+H)/6;
操作:=MA(A77,5),COLORBLUE,LINETHICK2;
VAR1:LLV(A77,21),COLORCCFF89,LINETHICK1;
VAR2:HHV(A77,21),COLORRED,LINETHICK1;
高卖:=IF((CROSS(VAR2*0.999,A77)),3,0),COLOR00FFFF,LINETHICK3;
卖点:STICKLINE(高卖=3,VAR2*1.05,VAR2*1.15,0,0),COLORFF00FF;
低买:=IF((CROSS(A77,VAR1*1.001)),-3,0),COLOR00FFFF,LINETHICK3;
买点:STICKLINE(低买=-3,VAR1*0.95,VAR1*0.85,0,0),COLORCCFF89;
重心:=(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=EMA((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=EMA(0.618*REF(SJ,1)+0.382*SJ,2),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,VAR2*1.05,'←高抛'),COLOR0077FF;
DRAWICON(CROSS(SJ,ZJ) AND SJ<30,收盘线*0.84,38);
明天逢低买:=IF(CROSS(SJ,ZJ) AND SJ<30,10,0),COLOR00FFFF,LINETHICK3;
收盘线*0.75,COLOR000000;
DRAWICON(XG,收盘线*0.83,36);

通达信精品合一主图指标公式

 

相关文章