在线检测未来函数

通达信双节撷英指标公式

来源:Internet,编辑:股旁网,2012-10-20

趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06,;
量异动:=K1>REF(V1,1)*1.6&&ZZ,;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
共振:FILTER(M1 AND M2,3),COLORRED;
DRAWTEXT(共振,1,'共振'),COLORRED;
VAR2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR3:=(CLOSE-VAR2)/VAR2*100;
VAR4:=REF(VAR3,1)<-40 AND VAR3>REF(VAR3,1) AND REF(VAR3,1)<REF(VAR3,2) AND VAR3-REF(VAR3,1)>2.5;
VAR5:=(CLOSE-OPEN)/OPEN*100;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:=COUNT(VAR7<20,20)>=1;
VAR9:=VAR5>9 AND VAR8;
VARA:=100*WINNER(OPEN);
VARB:=100*WINNER(CLOSE);
VARC:=VARB-VARA;
VARD:=VARC>=30;
VARE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VARF:=REF(CLOSE,1);
VAR10:=SMA(MAX(CLOSE-VARF,0),5,1)/SMA(ABS(CLOSE-VARF),5,1)*100;
VAR11:=COUNT(VAR10<20,20)>=1;
VAR12:=VARE AND VAR11;
VAR13:=MA(CLOSE,4);
VAR14:=MA(CLOSE,10);
VAR15:=MA(CLOSE,20);
VAR16:=MA(CLOSE,25);
VAR17:=COUNT(CROSS(VAR14,VAR15),2)=1;
VAR18:=COUNT(CROSS(VAR13,VAR16),2)=1;
VAR19:=VAR17 AND VAR18;
VAR1A:=VAR12 AND VARD AND VAR19;
VAR1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
VAR1C:=CLOSE<VAR1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
选股:FILTER(VAR4 OR VAR9 OR VAR1A OR VAR1C,7),COLORYELLOW;
DRAWTEXT(选股,1,'选股'),COLORYELLOW;
{ Gupang.com 股-旁-网_通达信股票指标公式}
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
X1:=EMA(DIFF,5)*5;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
低吸:CROSS(X2,X1) AND X2>0,COLOR2828FF;
DRAWTEXT(低吸,0.5,'低吸'),COLOR2828FF;
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100;
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=((ADX + REF(ADX,5)) / 2) + RSI5;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
注意:CROSS((AV+NEWVOL),0),COLORWHITE;
DRAWTEXT(注意,0.6,'注意'),COLORWHITE;
涨幅%:=(C-REF(C,1))/REF(C,1)*100;
开盘封涨停:=O/REF(C,1)<1.098;
B8:=MA(C,5)>MA(C,10) AND MA(C,5)>MA(C,60) AND MA(C,60)>REF(MA(C,60),1);
VAR326:=IF(C>REF(C,1),1,0);
VAR327:=IF(C/REF(C,1)>1.05 AND HIGH/C<1.010 AND VAR326>0,1,0);
强势:FILTER(VAR327>0,5) AND B8 AND 涨幅%>6 AND 开盘封涨停,COLORFF00FF;
DRAWTEXT(强势,0.7,'强势'),COLORFF00FF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
阴买:C<REF(C,1) AND C<O*0.98 AND REF(J,1)<0 AND REF(K,1)<19 AND REF(K,1)<REF(D,1) AND L<HHV(H,10)*0.83 AND CAPITAL<=5000000,COLORFFFF00;
DRAWTEXT(阴买,0.4,'阴买'),COLORFFFF00;
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
减仓:CROSS(82,RSI),COLORGREEN;
DRAWTEXT(减仓,1,'减仓'),COLORFF9966,LINETHICK2;

通达信双节撷英指标公式

 

相关文章