在线检测未来函数

通达信斐波那契财务K线主图指标公式

来源:Internet,编辑:股旁网,2012-10-21

MA5:MA(C,5),COLORWHITE;
MA13:MA(C,13),COLORYELLOW;
MA21:MA(C,21),COLORMAGENTA;
MA34:MA(C,34),COLORGREEN;
MA55:MA(C,55),COLORE96F65;
MA89:MA(C,89),DOTLINE,COLOR0080FF;
MA144:MA(C,144),DOTLINE,COLORRED;
MA233:MA(C,233),DOTLINE,COLORBB48AF;
{高抛低吸}
重:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=WMA((重-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L-0.1,'←低吸'),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR0077FF;
{板块}
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('【行业】',HYBLOCK),STRCAT('【地域】',DYBLOCK)),STRCAT('【概念】',GNBLOCK)));
{业绩综合}
市盈率:=STRCAT('【市盈率】',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT('【市销率】',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT('【市净率】',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT('【净资收益率】',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT('【毛利率】',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT('【净利润率】',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT('【主营利润率】',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
未分利润:=STRCAT(STRCAT('【未分利润】',CON2STR(FINANCE(32)/1,2)),'元/股');
公积金:=STRCAT(STRCAT('【公积金】',CON2STR(FINANCE(18)/1,2)),'元/股');
当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市销率,市净率),净资收益率),毛利率),净利润率),主营利润率),未分利润),公积金));
{财务分折}
现金流:=STRCAT(STRCAT('【现金流】',CON2STR(FINANCE(25)/100000000,2)),'亿');
流动比率:=STRCAT('【流动比率】',CON2STR(FINANCE(11)/FINANCE(15),2));
速动比率:=STRCAT('【速动比率】',CON2STR((FINANCE(11)-FINANCE(27))/FINANCE(15),2));
XA1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
XA2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
XA3:=FINANCE(23)/FINANCE(10)*3.3;
XA4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
XA5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=XA1+XA2+XA3+XA4+XA5;
{ Gupang.com 股-旁-网_通达信股票指标公式}
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('【财务预警】',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,2))));
优质资产率:=STRCAT('【优质资产率】',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT('【现金负债比】',CON2STR(FINANCE(25)/FINANCE(15),2));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
流动债:=STRCAT(STRCAT('【流动债】',CON2STR(FINANCE(15)/100000000,2)),'亿');
长期债:=STRCAT(STRCAT('【长期债】',CON2STR(FINANCE(16)/100000000,2)),'亿');
财务分析:=STRCAT('【财务分析】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(现金流,流动比率),速动比率),现金负债比),优质资产率),财务预警),流动债),长期债));
{盘面分析}
平均成本:=STRCAT('【平均成本】',CON2STR(COST(50),2));
主力成本:=STRCAT('【主力成本】',CON2STR(COST(4),2));
重心:=STRCAT('【重心】',CON2STR((H+L+C)/3,2));
压力Ⅰ:=STRCAT('【压力Ⅰ】',CON2STR(2*(H+L+C)/3-LOW,2));
支撑Ⅰ:=STRCAT('【支撑Ⅰ】',CON2STR(2*(H+L+C)/3-HIGH,2));
压力Ⅱ:=STRCAT('【压力Ⅱ】',CON2STR((H+L+C)/3+(REF(HIGH,1)-REF(LOW,1)),2));
支撑Ⅱ:=STRCAT('【支撑Ⅱ】',CON2STR((H+L+C)/3-(REF(HIGH,1)-REF(LOW,1)),2));
套牢盘%:=STRCAT('【套牢盘%】',CON2STR((1-WINNER(C))*100,2));
获利盘%:=STRCAT('【获利盘%】',CON2STR(100*WINNER(C),2));
筹码分析:=STRCAT('【筹码分析】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(平均成本,主力成本),重心),压力Ⅰ),支撑Ⅰ),压力Ⅱ),支撑Ⅱ),套牢盘%),获利盘%));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,所属板块),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,财务分析),COLORFFFFBF;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.18,0,当前业绩),COLORFFFFBF;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.24,0,筹码分析),COLORFF99FF;

通达信通达信斐波那契财务K线主图指标公式

 

相关文章