在线检测未来函数

通达信六分区三线合一主图指标公式

来源:Internet,编辑:股旁网,2012-10-30

N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL);
低:IF(CURRBARSCOUNT<=N/30,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/30,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/30,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
压力:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
低涨:IF(CURRBARSCOUNT<=N/30,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
DRAWBAND(高,RGB(200,200,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(0,190,0),警示,RGB(0,0,0));
DRAWBAND(警示,RGB(220,120,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(120,0,120),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(120, 0,0),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(80,80,80),低,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=N/30,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N/30,支撑,支撑,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,强势,强势,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,突破,突破,4,0),COLORABABAB;
STICKLINE(CURRBARSCOUNT<=N/30,警示,警示,4,0),COLOR00FFFF;
STICKLINE(CURRBARSCOUNT<=N/30,压力,压力,4,0),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,压力,'0.809'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,警示,'0.618'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,突破,'0.500'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,强势,'0.382'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'0.191'),COLOR00FFFF;
AMV0:=VOL*(O+C+H+L)/4;
ZS:WMA(AMV0,21)/WMA(VOL,21);
IL:6*HHV(ZS,2)-5*ZS;
DRAWBAND(IL,RGB(0,150,170),ZS,RGB(0,0,0));
ZC:2*ZS-IL;
DRAWBAND(ZS,RGB(160,100,0),ZC,RGB(0,0,0));
STICKLINE(CLOSE>=ZS AND C>=O,OPEN,CLOSE,2,0),COLOR0000FF;
STICKLINE(CLOSE>=ZS AND C>=O,LOW,H,0,0),COLORRED;
STICKLINE(CLOSE>=ZS AND C<O,OPEN,CLOSE,2,0),COLOR00FFFF;
STICKLINE(CLOSE>=ZS AND C<O,LOW,H,0,0),COLOR00FFFF;
STICKLINE(CLOSE<ZS AND C>=O,OPEN,CLOSE,2,0),COLORFF00FF;
STICKLINE(CLOSE<ZS AND C>=O,LOW,H,0,0),COLORFF00FF;
STICKLINE(CLOSE<ZS AND C<O,OPEN,CLOSE,2,0),COLORFFFF00;
STICKLINE(CLOSE<ZS AND C<O,LOW,H,0,0),COLORFFFF00;
RSIA1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100,COLORFFFF00;
ZB1:=RSIA1<20;
买入:DRAWICON(CROSS(RSIA1,20),L*0.98,13);
ZB2:=(ZB1=0 AND RSIA1<=80);
卖出:DRAWICON(ZB2=1 AND REF(ZB2,1)=0 AND 买入=0,H*1.002,14);
N2:=5;
A1:=REF(H,N2)=HHV(H,2*N2+1);
B1:=FILTER(A1,N2);
C1:=BACKSET(B1,N2+1);
HD:= FILTER(C1,N2);
RH:=BACKSET(CURRBARSCOUNT=2,BARSLAST(HD)+1);
SH:=RH>REF(RH,1);
H1:=REF(H ,BARSLAST(SH));
STICKLINE(H1,H1,H1,5,0),LINETHICK2,COLOR00FFFF;
DRAWTEXT(ISLASTBAR,H1*1.005,'近期高点'),COLORFFFF00;
TTP:=(CURRBARSCOUNT=5-4);
DRAWNUMBER(TTP AND H1,H1,H1),COLORFFFF00;
A2:=REF(L,N2)=LLV(L,2*N2+1);
B2:=FILTER(A2,N2);
C2:=BACKSET(B2,N2+1);
LD:=FILTER(C2,N2);
RL:=BACKSET(CURRBARSCOUNT=2,BARSLAST(LD)+1);
SL:=RL>REF(RL,1);
L1:=REF(L ,BARSLAST(SL));
STICKLINE(L1,L1,L1,5,0),COLORFFFF00,LINETHICK5;
DRAWTEXT(ISLASTBAR,L1*1.005,'近期低点'),COLORFFFF00;
DRAWNUMBER(TTP AND L1,L1,L1),COLOR00FFFF;
DRAWTEXT_FIX(1,0.05,0.0,0,'【彩色K线】★★红色--三线合一阳线★★黄色--三线合一阴线
★★粉色--三线发散阳线★★青色--三线发散阴线★★ '),COLORFFFF00;

通达信六分区三线合一主图指标公式

 

相关文章