在线检测未来函数

把买入指标加进同时满足kdj金叉时发出

来源:Internet,编辑:股旁网,2012-10-18

编写要求:

WR1:=110*(HHV(HIGH,20)-EMA(C,5))/(HHV(HIGH,20)-LLV(LOW,20)); WR2:=110*(HHV(HIGH,5)-EMA(C,1))/(HHV(HIGH,5)-LLV(LOW,5)); G:=BARSLAST(CROSS(WR1,WR2))/2+49; XG1:=WR2>G; XG2:=G>WR2; 选股:=CROSS(XG2,XG1); WR1A:=110*(HHV(HIGH,10)-EMA(C,1))/(HHV(HIGH,10)-LLV(LOW,10)); WR2A:=110*(HHV(HIGH,2)-EMA(C,1))/(HHV(HIGH,2)-LLV(LOW,2)); GA:=BARSLAST(CROSS(WR1A,WR2A))/2+49; XG1A:=WR2A>GA; XG2A:=GA>WR2A; 选股A:=CROSS(XG2A,XG1A); AA:=MA((2*CLOSE+HIGH+LOW)/4,5); 通1:=AA*102/100; 通2:=AA*(200-102)/100; CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); DD:=DMA(CLOSE,CC); 上:=(1+7/100)*DD; 下:=(1-7/100)*DD; 中:=(上+下)/2; 选股 AND 选股A AND CROSS(C,中);

股旁网解答:

 WR1:=110*(HHV(HIGH,20)-EMA(C,5))/(HHV(HIGH,20)-LLV(LOW,20));

WR2:=110*(HHV(HIGH,5)-EMA(C,1))/(HHV(HIGH,5)-LLV(LOW,5));
G:=BARSLAST(CROSS(WR1,WR2))/2+49;
XG1:=WR2>G;
XG2:=G>WR2;
选股:=CROSS(XG2,XG1);
WR1A:=110*(HHV(HIGH,10)-EMA(C,1))/(HHV(HIGH,10)-LLV(LOW,10));
WR2A:=110*(HHV(HIGH,2)-EMA(C,1))/(HHV(HIGH,2)-LLV(LOW,2));
GA:=BARSLAST(CROSS(WR1A,WR2A))/2+49;
XG1A:=WR2A>GA;
XG2A:=GA>WR2A;
选股A:=CROSS(XG2A,XG1A);
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通1:=AA*102/100;
通2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:=(1+7/100)*DD;
下:=(1-7/100)*DD;
中:=(上+下)/2;
选股 AND 选股A AND CROSS(C,中) AND CROSS(KDJ.K,KDJ.D);

相关文章