在线检测未来函数

把江恩轮指标改为选股公式

来源:Internet,编辑:股旁网,2012-10-23

编写要求:

请老师帮忙把江恩轮指标改为选股公式。 感谢老师,非常感谢!请帮做个选股公式。(通达信软件) 江恩轮指标 VA:=BARSCOUNT(CLOSE)*3.142/180; A1:SIN(VA*1)*10; A2:SIN(VA*2)*10; A3:SIN(VA*3)*10; A4:SIN(VA*5)*10; A5:SIN(VA*6)*10; A6:SIN(VA*7)*10; A7:SIN(VA*8)*10; A8:SIN(VA*9)*10; A9:SIN(VA*4)*10;

股旁网解答:

 有类似的副图源码

VA:=BARSCOUNT(CLOSE)*3.142/180;
AA2: SIN(VA*8)*100,LINETHICK2;
AA3: COS(VA*8)*100,LINETHICK2;
X1: 0;
A1:SIN(VA*1)*100;
A2:SIN(VA*2)*100;
A3:SIN(VA*3)*100;
A4:SIN(VA*5)*100;
A5:SIN(VA*6)*100;
A6:SIN(VA*7)*100;
A7:SIN(VA*8)*100;
A8:SIN(VA*9)*100;
A9:SIN(VA*4)*100;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,3,0);
低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,3,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,10,0);
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-140,4);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'买点'),COLORFFFFFF;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,3,1),COLORRED;
谨慎观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,10,0);
果断持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,3,1),COLORFFFF00;
XG:CROSS(AA2,20);
DRAWICON(XG,0,1);
选股:
VA:=BARSCOUNT(CLOSE)*3.142/180;
AA2:=SIN(VA*8)*100;
XG:CROSS(AA2,20);
 

相关文章