在线检测未来函数

把殷保华的公式改为通达信的

来源:Internet,编辑:股旁网,2012-10-25

编写要求:

{公称名称: 保华均线} MA25:EMA(CLOSE,25); 牛熊分水岭:EMA(CLOSE,905); STICKLINE((MA25 > 牛熊分水岭),MA25,牛熊分水岭,1,0),colorFF; STICKLINE((MA25 < 牛熊分水岭),MA25,牛熊分水岭,1,0),colorFF00; DRAWICON(CROSS(MA25,牛熊分水岭),(牛熊分水岭 * 0.98),6); {公称名称: 保华提醒} VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04))); VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2)); VAR3:=REF(CLOSE,1); VAR4:=((SMA(MAX((CLOSE - VAR3),0),6,1) / SMA(ABS((CLOSE - VAR3)),6,1)) * 100); 买入:(VAR1 AND VAR2),STICK,colorFF; 卖出:CROSS(80,VAR4),STICK,colorFF00; {公称名称: 江恩八线} 一号线:EMA(CLOSE,144); 工作线:EMA(CLOSE,14),colorFF; 二号线:EMA(CLOSE,25); 三号线:EMA(CLOSE,318); 生命线:EMA(CLOSE,453),LINETHICK2,colorFF; 五号线:EMA(CLOSE,550); 六号线:EMA(CLOSE,610); 七号线:EMA(CLOSE,730); 八号线:EMA(CLOSE,888); 九号线:EMA(CLOSE,99),colorFF00; {公称名称: 四号箱体} HEPG:(EMA(CLOSE,450) * 2.14),colorFFFFFF; MA03:(EMA(CLOSE,450) * 2.01),colorFF00FF; MA02:(EMA(CLOSE,450) * 1.88),colorFF00; MA01:(EMA(CLOSE,450) * 1.75),colorFFFFFF; MA1:(EMA(CLOSE,450) * 1.66),colorFF0000; MA2:(EMA(CLOSE,450) * 1.5),colorFF00FF; MA3:(EMA(CLOSE,450) * 1.37),colorFFFF; MA4:(EMA(CLOSE,450) * 1.33),colorFF00FF; MA5:(EMA(CLOSE,450) * 1.25),colorFF00; MA6:(EMA(CLOSE,450) * 1.14),colorFFFFFF; MA7:(EMA(CLOSE,450) * 0.99),colorFFFFFF; MA8:(EMA(CLOSE,450) * 0.84),colorFFFFFF; 工作线:EMA(CLOSE,14),colorFFFFFF; 生命线:EMA(CLOSE,47),colorFFFF; {公称名称: 准备买入} n:=5; var1:4*SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1),3.2,1),COLORYELLOW,linethick0; var2:8,colorgreen,linethick0; 上升在即: IF(CROSS(var1,var2),80,0),stick,COLOR0000cc,linethick2; 专吸庄血: IF(var1<=8,25,0),stick,COLORwhite,linethick2; DRAWTEXT(CROSS(var1,var2),80,'准备买入'),COLOR00ffff; Varo5:=LLV(LOW,27); Varo6:=HHV(HIGH,34); Varo7:=EMA((CLOSE-Varo5)/(Varo6-Varo5)*4,4)*25; 建仓区: IF((Varo7<10),80,100) ,color00ccff,linethick1; 0,linethick2 ,colorffcc00; {公称名称: 买卖奇准} 你:=MA(CLOSE,1); 老:=(((LOW + HIGH) + CLOSE) / 3); 板:=MA(老,5); 好:=HHV(板,10); 老板:=MA(老,5); 买卖:=LLV(老板,10); 急买奇准:IF(LLV((你 < 买卖),5),50,0),colorFF; 急卖奇准:IF(HHV((你 < 好),5),100,50),colorFF0000; 短买奇准:IF(LLV((你 < 买卖),10),50,0),colorFFFFFF; 短卖奇准:IF(HHV((你 < 好),10),100,50),colorFF00; 殷宝华变色MA:主图 同花顺,大智慧,分析家,通用 ma5:ema(c,5),colorwhite; 工作线:ema(c,14),colorf00ff0,linethick1; 二号线:ema(c,25),color00ff00,linethick1; 九号线:eMA(CLOSE,99),linethick1; MA120:eMA(CLOSE,120),linethick1; 生命线:eMA(CLOSE,453),linethick1,colorred; DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)); DEA:=EMA(DIFF,9); MACD:=0.90*(DIFF-DEA); tj:=(diff>=dea); tj1:=(diff>=0); stickline(tj,h,l,0.3,0),COLORyellow; stickline(tj,o,c,3,0),COLORyellow; stickline(tj1 and tj,h,l,0.3,0),colorf00ff0; stickline(tj1 and tj,o,c,3,1),colorf00ff0; stickline(diffstickline(diffVar1:=(CLOSE*2+HIGH+LOW)/4; SK:= EMA(Var1,13)-EMA(Var1,73); SD:= EMA(SK,2); drawtext((cross(sk,sd) and sk<-0.04 and(c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and(v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短线'),colorgreen; stickline((cross(sk,sd) and sk<-0.04 and(c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and(v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),colorred; stickline((cross(sk,sd) and sk<-0.04 and(c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and(v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,10,1),linethick3,colorred;

股旁网解答:

 {公称名称: 保华均线}
MA25:EMA(CLOSE,25);
牛熊分水岭:EMA(CLOSE,905);
STICKLINE((MA25 > 牛熊分水岭),MA25,牛熊分水岭,1,0),COLOR0000FF;
STICKLINE((MA25 < 牛熊分水岭),MA25,牛熊分水岭,1,0),COLOR00FF00;
DRAWICON(CROSS(MA25,牛熊分水岭),(牛熊分水岭 * 0.98),6);

{公称名称: 保华提醒}
VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR3:=REF(CLOSE,1);
VAR4:=((SMA(MAX((CLOSE - VAR3),0),6,1) / SMA(ABS((CLOSE - VAR3)),6,1)) * 100);
买入:(VAR1 AND VAR2),STICK,COLOR0000FF;
卖出:CROSS(80,VAR4),STICK,COLOR00FF00;

{公称名称: 江恩八线}
一号线:EMA(CLOSE,144);
工作线:EMA(CLOSE,14),COLOR00FF00;
二号线:EMA(CLOSE,25);
三号线:EMA(CLOSE,318);
生命线:EMA(CLOSE,453),LINETHICK2,COLOR0000FF;
五号线:EMA(CLOSE,550);
六号线:EMA(CLOSE,610);
七号线:EMA(CLOSE,730);
八号线:EMA(CLOSE,888);
九号线:EMA(CLOSE,99),COLOR00FFFF;

{公称名称: 四号箱体}
HEPG:(EMA(CLOSE,450) * 2.14),COLORFFFFFF;
MA03:(EMA(CLOSE,450) * 2.01),COLORFF00FF;
MA02:(EMA(CLOSE,450) * 1.88),COLORFF0088;
MA01:(EMA(CLOSE,450) * 1.75),COLORFFFFFF;
MA1:(EMA(CLOSE,450) * 1.66),COLORFF0000;
MA2:(EMA(CLOSE,450) * 1.5),COLORFF00FF;
MA3:(EMA(CLOSE,450) * 1.37),COLORFFFF00;
MA4:(EMA(CLOSE,450) * 1.33),COLORFF00FF;
MA5:(EMA(CLOSE,450) * 1.25),COLOR00FF00;
MA6:(EMA(CLOSE,450) * 1.14),COLORFFFFFF;
MA7:(EMA(CLOSE,450) * 0.99),COLORFFFFFF;
MA8:(EMA(CLOSE,450) * 0.84),COLORFFFFFF;
工作线:EMA(CLOSE,14),COLORFFFFFF;
生命线:EMA(CLOSE,47),COLORFFFF00;

 

{公称名称: 准备买入}
n:=5;
var1:4*SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1),3.2,1),COLORYELLOW,linethick0;
var2:8,colorgreen,linethick0;
上升在即: IF(CROSS(var1,var2),80,0),stick,COLOR0000cc,linethick2;
专吸庄血: IF(var1<=8,25,0),stick,COLORwhite,linethick2;
DRAWTEXT(CROSS(var1,var2),80,'准备买入'),COLOR00ffff;
Varo5:=LLV(LOW,27);
Varo6:=HHV(HIGH,34);
Varo7:=EMA((CLOSE-Varo5)/(Varo6-Varo5)*4,4)*25;
建仓区: IF((Varo7<10),80,100) ,color00ccff,linethick1;
0,linethick2 ,colorffcc00;

{公称名称: 买卖奇准}
你:=MA(CLOSE,1);
老:=(((LOW + HIGH) + CLOSE) / 3);
板:=MA(老,5);
好:=HHV(板,10);
老板:=MA(老,5);
买卖:=LLV(老板,10);
急买奇准:IF(LLV((你 < 买卖),5),50,0),COLOR0000FF;
急卖奇准:IF(HHV((你 < 好),5),100,50),COLORFF0000;
短买奇准:IF(LLV((你 < 买卖),10),50,0),COLORFFFFFF;
短卖奇准:IF(HHV((你 < 好),10),100,50),COLOR00FF00;

 

殷宝华变色MA:主图
同花顺,大智慧,分析家,通用
MA5:EMA(C,5),COLORWHITE;
工作线:EMA(C,14),COLORF00FF0,LINETHICK1;
二号线:EMA(C,25),COLOR00FF00,LINETHICK1;
九号线:EMA(CLOSE,99),LINETHICK1;
MA120:EMA(CLOSE,120),LINETHICK1;
生命线:EMA(CLOSE,453),LINETHICK1,COLORRED;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=0.90*(DIFF-DEA);
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
VAR1:=(CLOSE*2+HIGH+LOW)/4;
STICKLINE(TJ,H,L,0.3,0),COLORYELLOW;
STICKLINE(TJ,O,C,3,0),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0.3,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,3,1),COLORF00FF0;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND(C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND(V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLORGREEN;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND(C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND(V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),COLORRED;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND(C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND(V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,10,1),LINETHICK3,COLORRED;

相关文章