在线检测未来函数

点金测底公式

来源:Internet,编辑:股旁网,2012-10-27

编写要求:

公式如下: RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:SMA(RSV,3,1),COLORWHITE; D:SMA(K,3,1),COLORYELLOW; J:3*K-2*D,COLORMAGENTA; TYP:=(HIGH+LOW+CLOSE)/3; J负:IF(J<0,50,0),COLORRED,LINETHICK2; 零轴:0,LINETHICK1,COLORWHITE; 超买:100,LINETHICK1,COLORGREEN; CCI14:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORLIBLUE; CCI14到位:IF(CCI14<-200,44,0),COLORWHITE,LINETHICK2; BOLL:=MA(CLOSE,26); UPPER:=BOLL+2*STD(CLOSE,26); LOWER:=BOLL-2*STD(CLOSE,26); CC:=C<=LOWER; BOLL到位:STICKLINE(CC,40,30,2,0); 要求是当CCI大于-200,股价到达BOLL下轨,KDJ的J值为负数时,出现图中的提示,CCI参数14,BOLL参数26,KDJ参数9.3.3,请高手帮忙,谢谢,要是能做成图片中的样子,就更好了,呵呵!

股旁网解答:

 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
TYP:=(HIGH+LOW+CLOSE)/3;
J负:IF(J<0,50,0),COLORRED,LINETHICK2;
零轴:0,LINETHICK1,COLORWHITE;
超买:100,LINETHICK1,COLORGREEN;
CCI14:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORLIBLUE;
CCI14到位:IF(CCI14<-200,44,0),COLORWHITE,LINETHICK2;
BOLL:=MA(CLOSE,26);
UPPER:=BOLL+2*STD(CLOSE,26);
LOWER:=BOLL-2*STD(CLOSE,26);
CC:=C<=LOWER;
BOLL到位:CC;
PPP:J负 AND CCI14到位 AND BOLL到位;
STICKLINE(PPP,0,30,40,1),COLORYELLOW;
STICKLINE(PPP,16,29,38,0),COLORRED;
STICKLINE(PPP,1,14,38,0),COLORRED;
STICKLINE(PPP,15,15,40,1),COLORYELLOW;
STICKLINE(PPP,30,50,10,0),COLORYELLOW;
STICKLINE(PPP,53,55,10,1),COLORRED;
STICKLINE(PPP,57,59,10,1),COLORRED;
STICKLINE(PPP,61,63,10,1),COLORRED;
STICKLINE(PPP,65,67,10,1),COLORRED;
STICKLINE(PPP,69,75,12,0),COLORFFCCCC;
DRAWTEXT(PPP,85,'底'),COLORYELLOW;

相关文章