载入中...
在线检测未来函数
载入中...

把这个“分时突破”大智慧指标改成通达信指标

来源:Internet,编辑:股旁网,2012-10-30

编写要求:

input:N(0,0,250),N1(0,0,100),N2(0,0,100),N3(0,0,100); 时: MA(CLOSE,10); 分: (EMA(CLOSE,N1)*7+EMA(CLOSE,N2)*3)/10,Colorff6633; VarA:=REF(CLOSE,1); VarE:=SMA(MAX(CLOSE-VarA,0),6,1)/SMA(ABS(CLOSE-VarA),6,1)*100; PARTLINE(时,时>REF(时,1),RGB(255,0,0), 时700101 AND CROSS(84,VarE),HIGH,'☆卖出'); VarF:=(2*CLOSE+HIGH+LOW)/4; Var10:=LLV(LOW,34); Var11:=HHV(HIGH,34); Var12:=EMA((VarF-Var10)/(Var11-Var10)*100,6); Var13:=EMA(0.667*REF(Var12,1)+0.333*Var12,4); Var14:=LLV(LOW,120); Var15:=HHV(HIGH,120); Var16:=Var15-Var14; DRAWTEXT(IF(COUNT(CLOSE0.3 AND COUNT (Var12>Var13,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,'★进场'); GDSJ:=HHVBARS(C,N); REF(C,GDSJ),COLOR00FF00,POINTDOT; 突破:CROSS(C,REF(REF(C,GDSJ),1)) AND REF(GDSJ>=5,1),POINTDOT,LINETHICK0; STICKLINE(突破,C*0.99,C,5,0),COLOR00FF00; DRAWTEXT(突破,C*0.99,'突破'),COLOR00FFFF;

股旁网解答:

 {参数N(0,0,250),N1(0,0,100),N2(0,0,100),N3(0,0,100);}

N:=0;N1:=0;N2:=0;N3:=0;
时: MA(CLOSE,10),COLOR00FF00,LINETHICK2;
IF(时>REF(时,1),时,DRAWNULL),COLOR0000FF,LINETHICK2;
分: (EMA(CLOSE,N1)*7+EMA(CLOSE,N2)*3)/10,COLORFF6633;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(84,VARE),HIGH,'☆卖出'); 
VARF:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
VAR14:=LLV(LOW,120);
VAR15:=HHV(HIGH,120);
VAR16:=VAR15-VAR14;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VAR12>VAR13,3) 
AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,'★进场');
GDSJ:=HHVBARS(C,N);
REF(C,GDSJ),COLOR00FF00,POINTDOT;
突破:CROSS(C,REF(REF(C,GDSJ),1)) AND REF(GDSJ>=5,1),POINTDOT,NODRAW;
STICKLINE(突破,C*0.99,C,5,0),COLOR00FF00;
DRAWTEXT(突破,C*0.99,'突破'),COLOR00FFFF;
 

相关文章