在线检测未来函数

通达信实战AK-47指标公式

来源:Internet,编辑:股旁网,2012-11-02

支撑价:LLV(LOW,19),LINETHICK3,COLORWHITE;
阻力价:HHV(HIGH,19),LINETHICK3,COLORRED;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR2:=EMA(VAR1,9);
VAR3:=(CLOSE*2.5/100+CLOSE);
VAR4:EMA(C,3),LINETHICK3;
VAR5:=LLV(HIGH,240);
VAR6:=100*(CLOSE-VAR5)/VAR5;
VAR7:=REF(LLV(CLOSE,480),1);
VAR8:=REF(HHV(CLOSE,480),1);
VAR9:=100*(CLOSE-VAR7)/(VAR8-VAR7);
VARA:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
VARB:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VARC:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VARD:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VARE:=VARC>98.5 OR VARD>98.5;
VARF:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VAR13:=VARA=0 AND VARC=0 AND VAR6<0;
VAR14:=VARA=100 AND VARC=100;
VAR15:=VARB=0 OR VARD=0 AND VAR9<0;
VAR16:=VARB=100 AND VARD=100;
VAR17:=VAR6<0 AND VAR9<0;
VAR18:=VAR13 AND VAR15;
VAR19:=VAR14 AND VAR16;
VAR1B:=SMA(MAX(CLOSE-REF(CLOSE,1),0),49,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR1C:=SMA(MAX(CLOSE-REF(CLOSE,1),0),14,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),14,1)*100;
VAR1D:=BARSCOUNT(CLOSE);
VAR1E:=VAR1B<20 AND VAR1C<23 AND VAR1D>35;
VAR1F:=VAR1E AND COUNT(VAR1E,1)=1;
VAR20:=REF(CLOSE,1);
VAR21:=SMA(MAX(CLOSE-VAR20,0),34,1)/SMA(ABS(CLOSE-VAR20),7,1)*100;
VAR22:=SMA(MAX(CLOSE-VAR20,0),13,1)/SMA(ABS(CLOSE-VAR20),13,1)*100;
VAR23:=BARSCOUNT(CLOSE);
VAR24:=VAR21<20 AND VAR22<23 AND VAR23>35;
VAR25:=VARA=0 AND VARF<1.2 AND VAR17;
VAR27:=VAR18 AND VARF<1.2 AND VAR17;
VAR29:=SUM(HIGH-OPEN,77)/SUM(OPEN-LOW,77)*100;
VAR2A:=SUM(MAX(0,HIGH-REF(CLOSE,1)),77)/SUM(MAX(0,REF(CLOSE,1)-LOW),77)*100;
VAR2B:=CROSS(VAR29,69) AND CROSS(VAR2A,80)<150;
VAR2C:=VAR24 AND VAR1F AND COUNT(VAR24,30)=1;
买点:=VAR25 AND VAR2B;
绝对卖点:=(VAR19 OR VARA)AND VARF>23 OR VARE ;
VAR2D:=VAR1F AND VAR2C AND VAR25;
股海万元户:=(CLOSE/REF(CLOSE,1)>1.04 AND (CLOSE>10.8 AND CLOSE<10.83 OR CLOSE>6.86 AND CLOSE<6.88 OR CLOSE>13.82 AND CLOSE<13.84 OR CLOSE>7.28 AND CLOSE<7.3 OR CLOSE>12.4 AND CLOSE<12.42 OR CLOSE>22.33 AND CLOSE<22.35 OR CLOSE>4.68 AND CLOSE<4.7 OR CLOSE>26.29 AND CLOSE<26.31 OR CLOSE>7.65 AND CLOSE<7.67 OR CLOSE>13.4 AND CLOSE<13.42 OR CLOSE>7.58 AND CLOSE<7.6 OR CLOSE>20.43 AND CLOSE<20.45 OR CLOSE>19.57 AND CLOSE<19.59 OR CLOSE>6.26 AND CLOSE<6.28 OR CLOSE>7.14 AND CLOSE<7.16 OR CLOSE>6.61 AND CLOSE<6.63 OR CLOSE>11.9 AND VOL<11.92 OR CLOSE>6.7 AND CLOSE<6.72 OR CLOSE>8.19 AND CLOSE<8.21));
DRAWTEXT(FILTER(绝对卖点>0,3),H,'别贪'), COLOR00FF00;
DRAWTEXT(股海万元户>0,L,'☆追涨'),COLORYELLOW ;
DRAWICON(买点>0,L,4);
DRAWTEXT(买点>0,L,'扫描神针'),COLORF00FF0;
DRAWTEXT(VARF<0.7 AND VAR27 AND VAR25>0,L,'万元'),COLORYELLOW;
STICKLINE(VAR2D>0,O,C,10,0), COLORYELLOW;
DRAWTEXT(VAR2D>0,L,'大方神针'),COLORRED;
DRAWICON(COUNT(REF(VAR4,1)<REF(VAR4,2),5)=5 AND VAR4>REF(VAR4,1),L*0.98,4);
DRAWICON(FILTER(COUNT(VAR6<0,5)AND CROSS(VAR6,0)AND VARF>REF(VARF,1)AND C>O,3),L,1);
DRAWICON(FILTER(REF(VAR4,1)>REF(VAR4,2)AND VAR4<REF(VAR4,1)AND VARF>17 AND VAR1>VAR2,5),H,2);
DRAWICON(阻力价>REF(阻力价,1)AND CROSS(阻力价,VAR3)AND C<O,H*1.02,5);
★洗钱★:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * 1.2 * CLOSE;
★洗钱★A:=SMA(★洗钱★,13,1);
【洗钱】目的:=SMA(★洗钱★A,5.5,1.5);
K1:=BACKSET(【洗钱】目的>REF(【洗钱】目的,1),2);
Y:IF(K1,【洗钱】目的,DRAWNULL),POINTDOT,COLORRED,LINETHICK4;
★洗钱★B:=3 * ★洗钱★A - 2 * 【洗钱】目的;
{DRAWICON(CROSS(【洗钱】目的,★洗钱★B),【洗钱】目的,10);}
量:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * 1.2 * CLOSE;
量1:=EMA(量,3);
量2:=EMA(量,5);
量3:=EMA(量,7);
STICKLINE(量1 >= 量2,量3,量1,3,0),COLOR0000AA;
STICKLINE(量1 >= 量2,量3,量1,2,0),COLOR0000CC;
STICKLINE(量1 >= 量2,量3,量1,1,0),COLOR0000EE;
STICKLINE(量1 <= 量2,量3,量1,3,0),COLORFF0000;
STICKLINE(量1 <= 量2,量3,量1,2,0),COLORFF5500;
STICKLINE(量1 <= 量2,量3,量1,1,0),COLORFF9900;
T1:=量2 >= 量3 AND 量1 < REF(量1,1);
T2:=量2 < 量3 AND 量1 > REF(量1,1);
{STICKLINE(T1,量1,量3,8,0),COLORFFBB11;}
STICKLINE(T1,量1,量3,3,0),COLORFFCC22;
STICKLINE(T1,量1,量3,2,0),COLORFFDD33;
{STICKLINE(T1,量1,量3,3,0),COLORFFEE44;
STICKLINE(T1,量1,量3,1,0),COLORFFFF55;
STICKLINE(T2,量1,量3,10,0),COLOR338FDD;}
STICKLINE(T2,量1,量3,2,0),COLORFF00FF;
{STICKLINE(T2,量1,量3,1,0),COLOR00DDFF;}
STICKLINE(T2,量1,量3,3,0),COLOR00AAFF;
{STICKLINE(T2,量1,量3,2.0,0),COLOR00CCFF;
STICKLINE(T2,量1,量3,1,0),COLOR00EEFF;}
银行收益:=IF(【洗钱】目的 > ★洗钱★B,【洗钱】目的,★洗钱★B),LINETHICK0,COLORFF00FF;
洗钱手段:=★洗钱★B,LINETHICK1,COLOR00FFFF;
X:IF(银行收益 <= REF(【洗钱】目的,1),银行收益, DRAWNULL),LINETHICK2,COLOR00FF00;
DRAWICON(CROSS(★洗钱★B,【洗钱】目的),★洗钱★B * 0.99,9);
JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
TD1:=QJ0*(MIN(OPEN,CLOSE)-LOW);
XD1:=QJ0*(JJ-MIN(CLOSE,OPEN));
XD2:=QJ0*(HIGH-MAX(OPEN,CLOSE));
TD2:=QJ0*(MAX(CLOSE,OPEN)-JJ);
日净入:((TD1+XD1)-(TD2+XD2))/10000,NODRAW,COLORYELLOW;
周净入:SUM(日净入,5),NODRAW;
月净入:SUM(日净入,22),NODRAW;
涨:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌:INDEXDEC,NODRAW,COLORGREEN;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;

通达信实战AK-47指标公式

 

相关文章