在线检测未来函数

通达信大房子不限购指标公式

来源:Internet,编辑:股旁网,2012-11-02

色彩峰:=(C>0);
STICKLINE(色彩峰>0,0,色彩峰*1.05,10,0),COLORFF0000;
STICKLINE(色彩峰>0,0,色彩峰*0.9,10,0),COLORFF1111;
STICKLINE(色彩峰>0,0,色彩峰*0.85,10,0),COLORFF2222;
STICKLINE(色彩峰>0,0,色彩峰*0.8,10,0),COLORFF3333;
STICKLINE(色彩峰>0,0,色彩峰*0.75,10,0),COLORFF4444;
STICKLINE(色彩峰>0,0,色彩峰*0.7,10,0),COLORFF5555;
STICKLINE(色彩峰>0,0,色彩峰*0.65,10,0),COLORFF6666;
STICKLINE(色彩峰>0,0,色彩峰*0.6,10,0),COLORFF7777;
STICKLINE(色彩峰>0,0,色彩峰*0.55,10,0),COLORFF8888;
STICKLINE(色彩峰>0,0,色彩峰*0.5,10,0),COLORFF9999;
STICKLINE(色彩峰>0,0,色彩峰*0.45,10,0),COLORFFAAAA;
STICKLINE(色彩峰>0,0,色彩峰*0.4,10,0),COLORFFBBBB;
STICKLINE(色彩峰>0,0,色彩峰*0.35,10,0),COLORFFCCCC;
STICKLINE(色彩峰>0,0,色彩峰*0.3,10,0),COLORFFDDDD;
STICKLINE(色彩峰>0,0,色彩峰*0.25,10,0),COLORFFEEEE;
STICKLINE(色彩峰>0,0,色彩峰*-1.5,10,0),COLORFFFFFF;
D1:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,3)+EMA((OPEN+HIGH+LOW+CLOSE)/4,6)+EMA((OPEN+HIGH+LOW+CLOSE)/4,9))/3;
D2:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,5)+EMA((OPEN+HIGH+LOW+CLOSE)/4,10)+EMA((OPEN+HIGH+LOW+CLOSE)/4,20))/3;
D3:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,7)+EMA((OPEN+HIGH+LOW+CLOSE)/4,14)+EMA((OPEN+HIGH+LOW+CLOSE)/4,28))/3;
D4:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,9)+EMA((OPEN+HIGH+LOW+CLOSE)/4,18)+EMA((OPEN+HIGH+LOW+CLOSE)/4,36))/3;
D5:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,11)+EMA((OPEN+HIGH+LOW+CLOSE)/4,22)+EMA((OPEN+HIGH+LOW+CLOSE)/4,44))/3;
D6:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,13)+EMA((OPEN+HIGH+LOW+CLOSE)/4,26)+EMA((OPEN+HIGH+LOW+CLOSE)/4,52))/3;
D7:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,21)+EMA((OPEN+HIGH+LOW+CLOSE)/4,34)+EMA((OPEN+HIGH+LOW+CLOSE)/4,68))/3;
{PARTLINE(D1,D1>=REF(D1,1),RGB(255,255,255),D1<REF(D1,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D2,D2>=REF(D2,1),RGB(255,0,0),D2<REF(D2,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D3,D3>=REF(D3,1),RGB(255,0,0),D3<REF(D3,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D4,D4>=REF(D4,1),RGB(255,0,0),D4<REF(D4,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D5,D5>=REF(D5,1),RGB(255,0,0),D5<REF(D5,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D6,D6>=REF(D6,1),RGB(255,0,0),D6<REF(D6,1),RGB(0,0,255)),LINETHICK1;
PARTLINE(D7,D7>=REF(D7,1),RGB(255,250,0),D7<REF(D7,1),RGB(0,0,255)),LINETHICK1;}
STICKLINE(D7<REF(D7,1),0,7,3,1)POINTDOT,COLORBLUE,LINETHICK9;
STICKLINE(D6<REF(D6,1),0,6,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D5<REF(D5,1),0,5,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D4<REF(D4,1),0,4,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D3<REF(D3,1),0,3,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D2<REF(D2,1),0,2,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D1<REF(D1,1),0,1,3,1)POINTDOT,COLORLIBLUE,LINETHICK4;
STICKLINE(D7>REF(D7,1),0,7,3,1),COLORRED;
STICKLINE(D6>REF(D6,1),0,6,3,1),COLORFF00FF;
STICKLINE(D5>REF(D5,1),0,5,3,1),COLORBROWN;
STICKLINE(D4>REF(D4,1),0,4,3,1),COLORYELLOW;
STICKLINE(D3>REF(D3,1),0,3,3,1),COLORWHITE;
STICKLINE(D2>REF(D2,1),0,2,3,1),COLORCYAN;
STICKLINE(D1>REF(D1,1),0,1,3,1),COLORGREEN;
VAR1:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100;
VAR2:=SMA(VAR1,6,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=10-VAR2+2*VAR3;
VAR5:=(3*VAR2+2*VAR3)/4;
VAR6:=ABS(ABS(VAR5)-ABS(VAR4));
VAR7:=ABS(ABS(VAR5)-ABS(VAR6));
洗盘挖坑:=(VAR4-VAR7)*0.2,LINETHICK2,COLORYELLOW;
长强势区:=IF((EVERY(洗盘挖坑>=REF(洗盘挖坑,1),1)),5,0)COLOR0000FF,LINETHICK3;
小门:=IF((CROSS(4.99,长强势区)AND D6<REF(D6,1)AND D5<REF(D5,1)AND D4<REF(D4,1)AND D3<REF(D3,1)AND D2<REF(D2,1)),-1,0),COLORCYAN,LINETHICK2;
DRAWICON(小门=-2,0,1);
DRAWBAND(0,RGB(0,144,55),小门,RGB(0,144,55));
打桩:IF((CROSS(4.99,长强势区)AND D6<REF(D6,1)AND D5<REF(D5,1)AND D4<REF(D4,1)AND D3<REF(D3,1)AND D2<REF(D2,1)),-1,0),COLORCYAN,LINETHICK2;
D11:=REF(D1,2)>REF(D1,1) AND D1>REF(D1,1);
D22:=REF(D2,2)>REF(D2,1) AND D2>REF(D2,1);
D33:=REF(D3,2)>REF(D3,1) AND D3>REF(D3,1);
D44:=REF(D4,2)>REF(D4,1) AND D4>REF(D4,1);
D55:=REF(D5,2)>REF(D5,1) AND D5>REF(D5,1);
D66:=REF(D6,2)>REF(D6,1) AND D6>REF(D6,1);
D77:=REF(D7,2)>REF(D7,1) AND D7>REF(D7,1);
楼花:=(D11 AND D22 AND D33) AND D44 OR D55 OR D66 OR D77,LINETHICK2,COLORRED;
DRAWBAND(楼花,RGB(233,144,34),0,RGB(0,0,0));

通达信大房子不限购指标公式

 

相关文章