在线检测未来函数

大智慧神棍力量指标公式

来源:Internet,编辑:股旁网,2012-11-05

〖量〗:VOL,VOLSTICK,PRECIS0;
STICKLINE(V>=3*REF(V,1),V/3,V/3,8,0),COLORWHITE;
STICKLINE(V>=2*REF(V,1),V/2,V/2,8,0),COLORYELLOW;
WJ:=(HIGH+LOW+CLOSE)/3;
V1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
V2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
V3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
V4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
V5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买卖总差:SUM((V9+V8)-(V6+V7),60),COLORcyan,LINETHICK2,PRECIS0;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((买卖差 < 0),0,买卖差,5,0),COLOR33FF33;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);
鬼比:=(卖盘 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
DRAWTEXT(((DATE > 700101) AND CROSS(84,VARE)),HIGH,'■卖出'),COLORF2A3A4;
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,5,1),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,5,1),COLOR00FF00;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),COLOR00FFFF;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,4,0),COLORFF0000;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,4,0),COLORFFFFFF;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,4,0),COLORFF00FF;
STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0);
STICKLINE((买盘 > 0),买盘,0,2,0),COLOR0000FF;
上攻均量:=MA(买盘,JY1);
下攻均量:=MA(卖盘,JY1);
DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'▼出货');
DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'●低进');
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'◆强势');
hsl:=DYNAINFO(37);
DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (hsl > 1)),(VOL * 1.1),'●量变'),COLOR00FFFF;
MA1:MA(VOL,5),colorwhite,PRECIS0;
MA2:MA(VOL,10),coloryellow,PRECIS0;
lk:V>=2*REF(V,1),PRECIS0;
DRAWICON(lk,V/2,1);
立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);
春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
清明:=FILTER(MONTH=4 AND (DAY=4 OR DAY=6 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);
小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);
大署:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
DRAWTEXT(立春,HIGH*1.02,'立春寅'),COLORGREEN;
DRAWTEXT(雨水,HIGH*1.02,'雨水'),COLORGREEN;
DRAWTEXT(惊蛰,HIGH*1.02,'惊蛰卯'),COLORGREEN;
DRAWTEXT(春分,HIGH*1.02,'春分'),COLORGREEN;
DRAWTEXT(清明,HIGH*1.02,'清明辰'),COLORGREEN;
DRAWTEXT(谷雨,HIGH*1.02,'谷雨'),COLORGREEN;
DRAWTEXT(立夏,HIGH*1.02,'立夏巳'),COLORMAGENTA;
DRAWTEXT(小满,HIGH*1.02,'小满'),COLORMAGENTA;
DRAWTEXT(芒种,HIGH*1.02,'芒种午'),COLORMAGENTA;
DRAWTEXT(夏至,HIGH*1.02,'夏至'),COLORMAGENTA;
DRAWTEXT(小暑,HIGH*1.02,'小暑未'),COLORMAGENTA;
DRAWTEXT(大署,HIGH*1.02,'大署'),COLORMAGENTA;
DRAWTEXT(立秋,HIGH*1.02,'立秋申'),COLORYELLOW;
DRAWTEXT(处暑,HIGH*1.02,'处暑'),COLORYELLOW;
DRAWTEXT(白露,HIGH*1.02,'白露酉'),COLORYELLOW;
DRAWTEXT(秋分,HIGH*1.02,'秋分'),COLORYELLOW;
DRAWTEXT(寒露,HIGH*1.02,'寒露戌'),COLORYELLOW;
DRAWTEXT(霜降,HIGH*1.02,'霜降'),COLORYELLOW;
DRAWTEXT(立冬,HIGH*1.02,'立冬亥'),COLORWHITE;
DRAWTEXT(小雪,HIGH*1.02,'小雪'),COLORWHITE;
DRAWTEXT(大雪,HIGH*1.02,'大雪子'),COLORWHITE;
DRAWTEXT(冬至,HIGH*1.02,'冬至'),COLORWHITE;
DRAWTEXT(小寒,HIGH*1.02,'小寒丑'),COLORWHITE;
DRAWTEXT(大寒,HIGH*1.02,'大寒'),COLORWHITE;
drawtext(lday=1,-8,'朔'),COLORWHITE;
drawtext(lday=8,-8,'上弦') ,COLORWHITE;
drawtext(lday=15,-8,'望') ,COLORWHITE;
drawtext(lday=23,-8,'下弦') ,COLORWHITE;
追:ref(c,3)/ref(c,4)>1.0998 AND ref(H,2)/REF(C,3)>1.03 AND ref(h,2)/ref(c,2)>1.03 AND ref(l,1)<ref(l,2) AND c/ref(c,1)>1.0998;
VERTLINE( 追,3),COLORBLUE;

大智慧神棍力量指标公式

 

相关文章