在线检测未来函数

通达信底部MACD指标公式

来源:Internet,编辑:股旁网,2012-11-06

Var1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
Var2:=( MA((CLOSE-Var1)/Var1,1));
买点1: IF(CROSS(Var2,0) AND LOW/REF(HIGH,1)<1.012,20,0);
最佳点:IF(COUNT(Var2>REF(Var2,1),3)=3 AND COUNT(Var2<0,10)=10 AND REF(Var2,3)=LLV(Var2,10),60,0);
买点2: IF(REF(Var2,2)=LLV(Var2,20) AND REF(Var2,2)<0.071 AND REF(Var2,2)<REF(Var2,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),20,0);
MMa:=ema(Var2,12)*0.7;
MMb:=ema(Var2,3);
快到底:if(llv(MMb-MMa,12)>0,0,-30),LINETHICK2,color00ff00;
底初选股:if( CROSS(0, llv(MMb-MMa,12)),10,0),LINETHICK0;
DIFF: EMA(CLOSE,12) - EMA(CLOSE,26)*1;
DEA: EMA(DIFF,9),ColorFFFFFF,LINETHICK1;
MACD: 2*(DIFF-DEA);
if(diff<0,diff,0),colorred,linethick1;
if(diff<0,0,diff),colorred,linethick1;
if(diff<dea,diff,dea),COLOR00ff00,linethick1;
if(diff>dea,dea,dea),COLORwhite,linethick1;
抄底:if(快到底<0 and cross(macd,0),30,0);
DRAWICON( 抄底>0,35 ,1 );
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,5,0),colorgreen;
STICKLINE(MACD<ref(MACD,1)and MACD<0,0,MACD,5,0),colorFFCC33;
STICKLINE(MACD>ref(MACD,1)and MACD,0,MACD,5,0),COLORyellow;
STICKLINE(MACD>ref(MACD,1)and MACD>0,0,MACD,5,0),COLORff00ff;

通达信底部MACD指标公式

 

相关文章