在线检测未来函数

通达信元旦小贺主图指标公式

来源:Internet,编辑:股旁网,2012-11-09

JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA6:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VB1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VB2:=(REF(VB1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB3:=(REF(VB2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB4:=(REF(VB3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB5:=(REF(VB4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB6:=(REF(VB5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB7:=(REF(VB6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB8:=(REF(VB7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB9:=(REF(VB8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VBA:=(REF(VB9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VBB:=(REF(VBA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VBC:=(REF(VBB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VBD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VBE:=(REF(VBD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VBF:=(REF(VBE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB10:=(REF(VBF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB11:=(REF(VB10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB12:=(REF(VB11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB13:=(REF(VB12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB14:=(REF(VB13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB15:=(REF(VB14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB16:=(REF(VB15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB17:=(REF(VB16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VB18:=(REF(VB17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VB19:=((REF(VBD OR VBE OR VBF OR VB10 OR VB11 OR VB12 OR VB13 OR VB14 OR VB15 OR VB16 OR VB17 OR VB18,1)) AND VB1);
VB1A:=((REF(VB1 OR VB2 OR VB3 OR VB4 OR VB5 OR VB6 OR VB7 OR VB8 OR VB9 OR VBA OR VBB OR VBC,1)) AND VBD);
红色持股:=VB1 OR VB2 OR VB3 OR VB4 OR VB5 OR VB6 OR VB7 OR VB8 OR VB9 OR VBA OR VBB OR VBC,COLOR0000FF;
离场:=IF(红色持股,JRL,O);
明离场价:=离场,COLORFF99FF;
今离场价:=REF(离场,1),COLOR0000FF;
青色观望:=VBD OR VBE OR VBF OR VB10 OR VB11 OR VB12 OR VB13 OR VB14 OR VB15 OR VB16 OR VB17 OR VB18,COLORFFFF00;
进:=IF(青色观望,JRH,O);
明进场价:=进,COLOR33AACC;
今进场价:=REF(明进场价,1),COLORFF0000;
短买:=VB19,COLOR33AACC;
品红离场:=VB1A,COLORFF99FF;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF;
{ www.gupang.com 股旁网_通达信指标公式}
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
EMA18:=MA(C,18);
中线买入】:=COUNT(CLOSE<EMA18,5)=4 AND
CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=
REF(EMA18,1),COLORRED;
DRAWTEXT(中线【买入】,L,'中线多'),COLORYELLOW;
VAR12:=(SMA(ABS(LOW-REF(LOW,1)),13,1))/(SMA(MAX(LOW-REF(LOW,1),0),13,1))*100;
VAR18:=EMA(IF(LOW<=LLV(LOW,34),MA(VAR12,13),0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR110*10.9;
T:=FILTER(IF(VAR111<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20);
DRAWTEXT(T,LOW,'洗盘结束'),COLORFF00FF;
VAR21:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR22:=SMA(VAR21,3,1);
VAR23:=SMA(VAR22,3,1);
VAR25:=CROSS(SMA(VAR22,3,1),SMA(VAR23,3,1)) AND SMA(VAR22,3,1)<20;
DRAWTEXT(FILTER(VAR25,10)=1,LOW,'抄底'),COLORYELLOW;
VAR29:=CROSS(SMA(VAR23,3,1),VAR23) AND VAR23>80;
DRAWTEXT(FILTER(VAR29,5)=1,HIGH,'逃顶'),COLORGREEN;

通达信元旦小贺主图指标公式

 

相关文章