在线检测未来函数

通达信罗盘雷达主图指标公式

来源:Internet,编辑:股旁网,2012-11-09

双轨线上强势:0,COLORRED,NODRAW;
双轨线下弱势:0,NODRAW,COLORFF9900;
把握疯牛卖点:0,NODRAW,COLOR00FF00;
HH:=(H+C)/2;
LL:=(L+O)/2;
三日均高:=(H+REF(H,2)+REF(H,3))/3;
三日收盘:=(C+REF(C,2)+REF(C,3))/3;
强势线:EMA((三日均高+三日收盘)/2,7),COLORRED,LINETHICK2;
支撑线:EMA((LL+REF(LL,2)+REF(LL,3))/3,7),COLOR00FF00,LINETHICK2;
IF(强势线>REF(强势线,1),强势线,DRAWNULL),LINETHICK2,COLORRED;
IF(强势线<REF(强势线,1),强势线,DRAWNULL),COLORFF9900,LINETHICK3;
IF(支撑线>REF(支撑线,1)*0.997,支撑线,DRAWNULL),LINETHICK4,COLORRED;
IF(支撑线<REF(支撑线,1),支撑线,DRAWNULL),COLORFF9900,LINETHICK3;
量比:=DYNAINFO(17),NODRAW;
涨幅:=(CLOSE/DYNAINFO(3))>=1.005 AND (CLOSE/DYNAINFO(3))<=1.04;
涨幅1:=(CLOSE/DYNAINFO(3))>=1.005 AND (CLOSE/DYNAINFO(3))>=1.05;
收盘涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
A1:=NAMELIKE('ST');
A2:=NAMELIKE('*');
A3:=NAMELIKE('S');
去除ST:=(A1+A2+A3)=0;
{ www.gupang.com 股旁网_通达信指标公式}
冲高减仓:=C>=HHV(H,60) AND 涨幅1 AND 量比<2 AND CLOSE/DYNAINFO(3)<9 AND 去除ST ,NODRAW;
VAR3:=REF(CLOSE,1);
VAR4:=(SMA(MAX(CLOSE-VAR3,0),6,1))/(SMA(ABS(CLOSE-VAR3),6,1))*100;
追涨:=CROSS(85,VAR4) AND 涨幅;
高抛:=CROSS(VAR4,80) AND 涨幅1 AND 量比<2;
DRAWTEXT(追涨,L*0.98,'强势股跟突破'),COLORYELLOW;
DRAWTEXT(REF(高抛,1)=1 AND C<O,H*1.035,'高抛'),COLOR00FF00;
DRAWTEXT(高抛 AND C<O,H*1.02,'高卖'),COLOR00FF00;
DRAWTEXT(COUNT(冲高减仓,3)>=1 AND 收盘涨幅<2 AND C>强势线*1.12,H*1.01,'★卖'),COLORFF6C22;
DRAWICON(追涨,强势线,1);
DRAWICON(REF(高抛,1)=1 AND C<O,H*1.01,2);
上穿双轨:=(CROSS(C,强势线) AND CROSS(C,支撑线)) OR (支撑线>REF(支撑线,1) AND L<支撑线 AND C>强势线) OR REF(CROSS(C,支撑线),1)=1 AND CROSS(C,强势线);
双穿卖出:=(CROSS(强势线,C) AND CROSS(支撑线,C)) OR ( (C<支撑线 AND H>强势线) OR (REF(H,1)>强势线 AND CROSS(支撑线,C)));
STICKLINE(上穿双轨 ,OPEN,CLOSE,3.3,0),COLOR0055FF;
STICKLINE(上穿双轨,OPEN,CLOSE,3.3,0),COLOR0077FF;
STICKLINE(上穿双轨 ,OPEN,CLOSE,3,0),COLOR0099FF;
STICKLINE(上穿双轨,OPEN,CLOSE,2.2,0),COLOR00BBFF;
STICKLINE(上穿双轨,OPEN,CLOSE,1.5,0),COLOR00DDFF;
STICKLINE(上穿双轨,OPEN,CLOSE,0.4,0),COLOR00FFFF;
DRAWTEXT(上穿双轨,L*0.965,'雷达'),COLORWHITE;
DRAWICON(上穿双轨,L*0.98,1);
{STICKLINE(双穿卖出,OPEN,CLOSE,3.3,0),COLOR00FF00;};
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1) AND 支撑线>REF(支撑线,1) AND C>强势线 AND C<O,HIGH*1.025,'顶卖'),COLORGREEN;

通达信罗盘雷达主图指标公式

 

相关文章