在线检测未来函数

飞狐成交量+主力吸筹洗盘主图指标公式

来源:Internet,编辑:股旁网,2012-11-07

hh:=SYSPARAM(4);
ll:=SYSPARAM(5);
x:=ll-(hh-ll+MINDIFF)/3;
y:=HHV(VOL,SYSPARAM(3)-SYSPARAM(2)+1);
yvb:=y[SYSPARAM(3)]/(ll-x+MINDIFF);
z:=VOL/yvb+x;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,8,0),Color110086;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,7.5,0),Color12008a;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,7,0),Color000099;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,6.5,0),ColorA3;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,6,0),Color0000AA;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,5.5,0),ColorB7;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,5,0),Color0000BB;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,4.5,0),ColorCD;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,4,0),Color0000CC;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,3.5,0),ColorE9;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,3,0),Color0000DD;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,2.5,0),Color714E9;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,2,0),Color0000EE;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,1.5,0),Color70EF3;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,1,0),Color1625FF;
STICKLINE(CLOSE>REF(CLOSE,1),x,z,0.1,0),Color4a77Ff;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,8,0),color008800;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,7,0),color009900;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,6,0),color00AA00;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,5,0),color00BB00;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,4,0),color00CC00;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,3,0),color00DD00;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,2,0),color00EE00;
STICKLINE(CLOSE<=REF(CLOSE,1),x,z,1,0),color00FF00;
五日量:MA(z,5);
十日量:MA(z,10);
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORFF9C00,LINETHICK0;
主力洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLOR9afd,LINETHICK0;
ay:=HHV(VAR5,SYSPARAM(3)-SYSPARAM(2)+1);//图上可见的指标最大值
amin:=LLV(VAR5,SYSPARAM(3)-SYSPARAM(2)+1);//图上可见的指标最小值
ayvb:=ay[SYSPARAM(3)]/(ll-x+MINDIFF)*3;
az:=VAR5/ayvb+x;
{VAR5z:=VAR5/ayvb+x;ayvb:=(ay[SYSPARAM(3)]/(ll-x+MINDIFF))*5; }
{az:=(VAR5z/(VAR5z+z))/ayvb+x;}
{kkkk:=(x-VAR5)*0.005+x;}
{kkkk:=(z-x)*0.5+x;}
{kkkk:=x-(x-VAR5)*0.005;}
STICKLINE(VAR5>REF(VAR5,1),x,az,8,0 ),COLOR3af9;
STICKLINE(VAR5>REF(VAR5,1),x,az,7,0),COLOR5afb;
STICKLINE(VAR5>REF(VAR5,1),x,az,6,0 ),COLOR7afc;
STICKLINE(VAR5>REF(VAR5,1),x,az,5,0),COLOR9afd;
STICKLINE(VAR5>REF(VAR5,1),x,az,4,0),COLORaafe;
STICKLINE(VAR5>REF(VAR5,1),x,az,3,0 ),COLOR3bbff;
STICKLINE(VAR5>REF(VAR5,1),x,az,2,0 ),COLOR9ccff;
STICKLINE(VAR5>REF(VAR5,1),x,az,1,0),COLOR15ddff;
STICKLINE(VAR5<REF(VAR5,1),x,az,8,0),COLORFF5B00;
STICKLINE(VAR5<REF(VAR5,1),x,az,7,0),COLORFF6c00;
STICKLINE(VAR5<REF(VAR5,1),x,az,6,0),COLORFF7B00;
STICKLINE(VAR5<REF(VAR5,1),x,az,5,0),COLORFF9C00;
STICKLINE(VAR5<REF(VAR5,1),x,az,4,0),COLORFFBE00;
STICKLINE(VAR5<REF(VAR5,1),x,az,3,0),COLORFFee00;
STICKLINE(VAR5<REF(VAR5,1),x,az,2,0),COLORFFff30;
STICKLINE(VAR5<REF(VAR5,1),x,az,1,0),COLORffff90;
VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
Var10:=(HIGH+LOW+CLOSE)/3;
Var11:=(Var10-MA(Var10,14))/(0.015*AVEDEV(Var10,14));
Var12:=(Var10-MA(Var10,70))/(0.015*AVEDEV(Var10,70));
Var13:=IF(Var11>=150 AND Var11<200 AND Var12>=150 AND Var12<200,10,0);
Var14:=IF(Var11<=-150 AND Var11>-200 AND Var12<=-150 AND Var12>-200,-10,Var13);
Var15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
Var16:=100-ABS(Var15);
Var17:=IF(Var16<90,Var16,100);
Var1A:=IF(VarE>0,VarE,0);
Var1B:=IF(Var12>=200 AND Var11>=150,15,IF(Var12<=-200 AND Var11<=-150,-15,Var14))+60;
Var1C:=Var1A>48 AND Var1B>60 AND Var17<100;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,8,0),COLOR888888;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,7,0),COLOR999999;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,6,0),COLORaaaaaa;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,5,0),COLORbbbbbb;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,4,0),COLORcccccc;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,3,0),COLORdddddd;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,2,0),COLOReeeeee;
STICKLINE(Var1C AND COUNT(Var1C,30)=1,x,x+(z-x)*2/3,1,0),COLORffffff;
{STICKLINE(Var1C AND COUNT(Var1C,30)=1 and c>o,o,c+(o-c)*2/3,8,0),COLORMAGENTA;}
{DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,l*0.98,'大\n笔\n出\n货'),linethick1,COLORffcc66;}
{AA:=IF(CURRENTDATE=DATE,STKINDI('','机构.机构',0,0),EXTDATA(9));//
BB:=IF(CURRENTDATE=DATE,STKINDI('','券商.券商',0,0),EXTDATA(10));//
DD:=IF(CURRENTDATE=DATE,STKINDI('','大户.大户',0,0),EXTDATA(11));//
EE:=IF(CURRENTDATE=DATE,STKINDI('','中户.中户',0,0),EXTDATA(12));//
FF:=IF(CURRENTDATE=DATE,STKINDI('','散户.散户',0,0),EXTDATA(13));//
P:=SYSPARAM(1);
主力:=(AA+BB+DD)*100*CLOSE/10000;
中散:=(EE+FF)*100*CLOSE/10000;
资金:=(AA+BB+DD+EE+FF)*100*CLOSE/10000;
五日:=SUM(主力,5);
十日:=SUM(主力,10);
十五日:=SUM(主力,15);
GG:=(AA+BB+DD);
WR:=SUM(GG,5);
SR:=SUM(GG,10);
SW:=SUM(GG,15);
机:=SUM(AA,90);
机1:=SUM(BB,90);
机2:=SUM(DD,90);
P3:=(机+机1+机2)*100/10000;
DRAWTEXTEX(CLOSE,1,10,820,'机构净买:'+NUMTOSTR(AA[p],0)+' 手'),ColorFFB060;
DRAWTEXTEX(CLOSE,1,10,860,'券商净买:'+NUMTOSTR(BB[p],0)+' 手'),ColorFFB060;
DRAWTEXTEX(CLOSE,1,180,820,'大户净买:'+NUMTOSTR(DD[p],0)+' 手'),Color00FF00;
DRAWTEXTEX(CLOSE,1,180,860,'中户净买:'+NUMTOSTR(EE[p],0)+' 手'),Color00FF00;
DRAWTEXTEX(CLOSE,1,340,820,'散户净买:'+NUMTOSTR(FF[p],0)+' 手'),ColorFFB060;
DRAWTEXTEX(CLOSE,1,340,860,'中散资金:'+NUMTOSTR(中散[p],2)+' 万元'),ColorFFB060;}
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076fF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color079BF3;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
{牵牛索}
{线性回归买卖线}
input:n(21,1,100),m(42,1,250),t(2,1,24);
买线:=EMA(CLOSE,t+1),colorred,linethick1;
卖线:EMA(SLOPE(CLOSE,n+1)*20+CLOSE,M),COLORCYAN,linethick3;
{PARTLINE(卖线>ref(dma(卖线,2),1),卖线),coloryellow,linethick2;}
牵牛索:PARTLINE(卖线<买线,卖线),coloryellow,linethick3;//AND 卖线>REF(卖线,2)
DRAWICON(卖线>EMA(卖线,5) and FILTERX(卖线>EMA(卖线,5),1) and CLOSE<REF(CLOSE,2)*0.95,卖线,10);
DRAWTEXT(卖线>EMA(卖线,5) and FILTERX(卖线>EMA(卖线,5),1) and CLOSE<REF(CLOSE,2)*0.95,卖线,'晚归啦'),colorff;
DRAWTEXTEX(CLOSE,1,10,0,'代码:'+STKLABEL+' 名称:'+STKNAME),Color0000ff;
{DRAWTEXTEX(c,1,10,420,'总股本:'+FINANCE( 1)+'万股' +' 流通A股:'+CAPITAL+'手'),COLORffffff;}
{抄底}
Var2:=IF(MONTH<12,1,1);
Var3:=(2*CLOSE+HIGH+LOW)/4;
Var4:=LLV(LOW,34);
Var5:=HHV(HIGH,34);
主力:=EMA((Var3-Var4)/(Var5-Var4)*100,13)*Var2,linethick4,colorred;
散户:=EMA(0.667*REF(主力,1)+0.333*主力,2),LINETHICK0,colorff9933;
小心被套:=IF(CROSS(主力,75) AND 散户<主力,75,62),STICK,LINETHICK2,colorgreen;
{62,stick,LINETHICK0,color000000;}
冲顶:=IF(CROSS(主力,65) AND 散户<主力,61,49),STICK,LINETHICK2,colorf00ff0;
{49,stick,LINETHICK0,color000000;}
上扬:=IF(CROSS(主力,30) AND 散户<主力,48,35),STICK,LINETHICK2,coloryellow;
{35,stick,LINETHICK0,color000000;}
{强弱分界线: 50, pointdot, LINETHICK2, COLORFFFF00;}
DRAWTEXT(CROSS(主力,散户) AND 主力<22,CLOSE*0.990,'赶\n牛'),LINETHICK2,COLOR0099ff;
DRAWICON(CROSS(主力,散户) AND 主力<22,CLOSE,14);
DRAWTEXT(CROSS(主力,30) AND 散户<主力,CLOSE*0.99,'上\n坡 '),LINETHICK5,color00ccff;
DRAWICON(CROSS(主力,30) AND 散户<主力,CLOSE,14);
DRAWTEXT(CROSS(主力,65) AND 散户<主力,CLOSE*0.99,'冲\n顶 '),LINETHICK2,COLOR9933ff;
DRAWICON(CROSS(主力,65) AND 散户<主力,CLOSE,14);
DRAWTEXT(CROSS(主力,75) AND 散户<主力,CLOSE*0.99,'小\n心'),LINETHICK2,color009900;
DRAWICON(CROSS(主力,75) AND 散户<主力,CLOSE,14);
DRAWTEXT(CROSS(散户,主力) AND 散户>75,CLOSE*0.99,'山\n顶'), COLORYELLOW;
DRAWICON(CROSS(散户,主力) AND 散户>75,CLOSE,14);
买入脉冲:=IF(CROSS(主力,散户) AND 主力<35,1,0),LINETHICK4,COLORGREEN;
卖出脉冲:=IF(CROSS(散户,主力) AND 散户>75,1,0),LINETHICK4,COLORRED;
{画图标(买入脉冲,收盘价,10);
画图标(卖出脉冲,收盘价,11);}
{引用鹏博F10}
wa:=F10FIND('最新业绩预披露时间:',1000);
IF wa<0 THEN EXIT;//没找到退出
u1:=F10TEXT(wa,52);
DRAWTEXTEX(CLOSE,1,10,130,u1),ColoraaFF;
wc:=F10FIND('业绩预告:',wa);
IF wc<0 THEN EXIT;//没找到退出
u2:=F10TEXT(F10FIND('业绩预告:',wc),53);
DRAWTEXTEX(CLOSE,1,10,300,u2),ColoraaFF;
wd:=F10FIND('业绩快报:',wa);
IF wd<0 THEN EXIT;//没找到退出
u3:=F10TEXT(F10FIND('业绩快报:',wd),135);
DRAWTEXTEX(CLOSE,1,10,440,u3),ColoraaFF;
{凤翔蓝筹排序}{排序指标}{说明:取每股收益和市盈率的倒数的加权平均值作为蓝筹系数,越大越好。可用于分行业。
凤翔/2005-08-26}
正收益率:=IF(FINANCE(33)>0.01 and FINANCE(34)>0,FINANCE(33)*6,0);
正市盈率:=IF(FINANCE(33)>0.01 and FINANCE(34)>0,FINANCE(34)*4,0);
蓝筹系数:(正收益率+1/正市盈率)/10*100,LINETHICK0;
DRAWTEXTEX(CLOSE>0,1,10,560,'蓝筹系数(越大越好): '+NUMTOSTR(蓝筹系数,3)),ColoraaFF;
DRAWTEXT(CLOSE>0 and BARPOS=SYSPARAM(3),CLOSE,'最新价: \n'+NUMTOSTR(CLOSE,3)),PXUP50,ColoraaFF00;
DRAWTEXTEX(CLOSE,1,700,0,'※长阳真人※'),ColoraaFF00;
VAR1:=(SMA(AMOUNT,19,3) / 60000);
VAR2:=(MA(REF(CLOSE,1),5) / 60000);
VAR3:=(((VAR1 * CLOSE) / VAR2) / 5700000);
VAR4:=VAR3;
VAR5:=REF(VAR4,1);
VAR6:=REF(VAR4,2);
VAR7:=REF(VAR4,3);
VAR8:=REF(VAR4,4);
VAR9:=REF(VAR4,5);
VARA:=REF(VAR4,6);
VARB:=REF(VAR4,7);
VARC:=REF(VAR4,8);
VARD:=REF(VAR4,9);
VARE:=REF(VAR4,10);
VARF:=REF(VAR4,11);
VAR10:=REF(VAR4,12);
VAR11:=REF(VAR4,13);
VAR12:=REF(VAR4,14);
VAR13:=REF(VAR4,15);
VAR14:=REF(VAR4,16);
VAR15:=REF(VAR4,17);
VAR16:=REF(VAR4,18);
VAR17:=REF(VAR4,19);
VAR18:=REF(VAR4,20);
VAR19:=REF(VAR4,21);
VAR1A:=REF(VAR4,22);
VAR1B:=REF(VAR4,23);
VAR1C:=REF(VAR4,24);
VAR1D:=REF(VAR4,25);
VAR1E:=REF(VAR4,26);
VAR1F:=REF(VAR4,27);
VAR20:=REF(VAR4,28);
VAR21:=REF(VAR4,29);
VAR22:=REF(VAR4,30);
VAR23:=REF(VAR4,31);
VAR24:=REF(VAR4,32);
VAR25:=REF(VAR4,33);
VAR26:=REF(VAR4,34);
VAR27:=REF(VAR4,35);
VAR28:=REF(VAR4,36);
VAR29:=REF(VAR4,37);
VAR2A:=REF(VAR4,38);
VAR2B:=REF(VAR4,39);
VAR2C:=REF(VAR4,40);
VAR2D:=REF(VAR4,41);
VAR2E:=REF(VAR4,42);
VAR2F:=REF(VAR4,43);
VAR30:=REF(VAR4,44);
VAR31:=REF(VAR4,45);
VAR32:=REF(VAR4,46);
VAR33:=REF(VAR4,47);
VAR34:=REF(VAR4,48);
VAR35:=REF(VAR4,49);
VAR36:=REF(VAR4,50);
VAR37:=IF(((VAR4 > VAR5) AND (VAR5 >= VAR6)),1,IF(((VAR4 < VAR5) AND (VAR5 <= VAR6)),(0 - 1),IF(((VAR4 > VAR6) AND (VAR6 > VAR5)),2,IF(((VAR4 < VAR6) AND (VAR6 < VAR5)),(0 - 2),0))));
VAR38:=IF(((VAR5 > VAR6) AND (VAR5 > VAR7)),1,IF(((VAR5 < VAR6) AND (VAR5 < VAR7)),(0 - 1),IF(((VAR6 > VAR7) AND (VAR6 > VAR8)),2,IF(((VAR6 < VAR7) AND (VAR6 < VAR8)),(0 - 2),IF(((VAR7 > VAR8) AND (VAR7 > VAR9)),3,IF(((VAR7 < VAR8) AND (VAR7 < VAR9)),(0 - 3),IF(((VAR8 > VAR9) AND (VAR8 > VARA)),4,IF(((VAR8 < VAR9) AND (VAR8 < VARA)),(0 - 4),IF(((VAR9 > VARA) AND (VAR9 > VARB)),5,IF(((VAR9 < VARA) AND (VAR9 < VARB)),(0 - 5),IF(((VARA > VARB) AND (VARA > VARC)),6,IF(((VARA < VARB) AND (VARA < VARC)),(0 - 6),IF(((VARB > VARC) AND (VARB > VARD)),7,IF(((VARB < VARC) AND (VARB < VARD)),(0 - 7),IF(((VARC > VARD) AND (VARC > VARE)),8,IF(((VARC < VARD) AND (VARC < VARE)),(0 - 8),IF(((VARD > VARE) AND (VARD > VARF)),9,IF(((VARD < VARE) AND (VARD < VARF)),(0 - 9),IF(((VARE > VARF) AND (VARE > VAR10)),10,IF(((VARE < VARF) AND (VARE < VAR10)),(0 - 10),IF(((VARF > VAR10) AND (VARF > VAR11)),11,IF(((VARF < VAR10) AND (VARF < VAR11)),(0 - 11),IF(((VAR10 > VAR11) AND (VAR10 > VAR12)),12,IF(((VAR10 < VAR11) AND (VAR10 < VAR12)),(0 - 12),IF(((VAR11 > VAR12) AND (VAR11 > VAR13)),13,IF(((VAR11 < VAR12) AND (VAR11 < VAR13)),(0 - 13),IF(((VAR12 > VAR13) AND (VAR12 > VAR14)),14,IF(((VAR12 < VAR13) AND (VAR12 < VAR14)),(0 - 14),IF(((VAR13 > VAR14) AND (VAR13 > VAR15)),15,IF(((VAR13 < VAR14) AND (VAR13 < VAR15)),(0 - 15),IF(((VAR14 > VAR15) AND (VAR14 > VAR16)),16,IF(((VAR14 < VAR15) AND (VAR14 < VAR16)),(0 - 16),IF(((VAR15 > VAR16) AND (VAR15 > VAR17)),17,IF(((VAR15 < VAR16) AND (VAR15 < VAR17)),(0 - 17),IF(((VAR16 > VAR17) AND (VAR16 > VAR18)),18,IF(((VAR16 < VAR17) AND (VAR16 < VAR18)),(0 - 18),IF(((VAR17 > VAR18) AND (VAR17 > VAR19)),19,IF(((VAR17 < VAR18) AND (VAR17 < VAR19)),(0 - 19),IF(((VAR18 > VAR19) AND (VAR18 > VAR1A)),20,IF(((VAR18 < VAR19) AND (VAR18 < VAR1A)),(0 - 20),IF(((VAR19 > VAR1A) AND (VAR19 > VAR1B)),21,IF(((VAR19 < VAR1A) AND (VAR19 < VAR1B)),(0 - 21),IF(((VAR1A > VAR1B) AND (VAR1A > VAR1C)),22,IF(((VAR1A < VAR1B) AND (VAR1A < VAR1C)),(0 - 22),IF(((VAR1B > VAR1C) AND (VAR1B > VAR1D)),23,IF(((VAR1B < VAR1C) AND (VAR1B < VAR1D)),(0 - 23),IF(((VAR1C > VAR1D) AND (VAR1C > VAR1E)),24,IF(((VAR1C < VAR1D) AND (VAR1C < VAR1E)),(0 - 24),IF(((VAR1D > VAR1E) AND (VAR1D > VAR1F)),25,IF(((VAR1D < VAR1E) AND (VAR1D < VAR1F)),(0 - 25),IF(((VAR1E > VAR1F) AND (VAR1E > VAR20)),26,IF(((VAR1E < VAR1F) AND (VAR1E < VAR20)),(0 - 26),IF(((VAR1F > VAR20) AND (VAR1F > VAR21)),27,IF(((VAR1F < VAR20) AND (VAR1F < VAR21)),(0 - 27),IF(((VAR20 > VAR21) AND (VAR20 > VAR22)),28,IF(((VAR20 < VAR21) AND (VAR20 < VAR22)),(0 - 28),IF(((VAR21 > VAR22) AND (VAR21 > VAR23)),29,IF(((VAR21 < VAR22) AND (VAR21 < VAR23)),(0 - 29),IF(((VAR22 > VAR23) AND (VAR22 > VAR24)),30,IF(((VAR22 < VAR23) AND (VAR22 < VAR24)),(0 - 30),IF(((VAR23 > VAR24) AND (VAR23 > VAR25)),31,IF(((VAR23 < VAR24) AND (VAR23 < VAR25)),(0 - 31),IF(((VAR24 > VAR25) AND (VAR24 > VAR26)),32,IF(((VAR24 < VAR25) AND (VAR24 < VAR26)),(0 - 32),IF(((VAR25 > VAR26) AND (VAR25 > VAR27)),33,IF(((VAR25 < VAR26) AND (VAR25 < VAR27)),(0 - 33),IF(((VAR26 > VAR27) AND (VAR26 > VAR28)),34,IF(((VAR26 < VAR27) AND (VAR26 < VAR28)),(0 - 34),IF(((VAR27 > VAR28) AND (VAR27 > VAR29)),35,IF(((VAR27 < VAR28) AND (VAR27 < VAR29)),(0 - 35),IF(((VAR28 > VAR29) AND (VAR28 > VAR2A)),36,IF(((VAR28 < VAR29) AND (VAR28 < VAR2A)),(0 - 36),IF(((VAR29 > VAR2A) AND (VAR29 > VAR2B)),37,IF(((VAR29 < VAR2A) AND (VAR29 < VAR2B)),(0 - 37),IF(((VAR2A > VAR2B) AND (VAR2A > VAR2C)),38,IF(((VAR2A < VAR2B) AND (VAR2A < VAR2C)),(0 - 38),IF(((VAR2B > VAR2C) AND (VAR2B > VAR2D)),39,IF(((VAR2B < VAR2C) AND (VAR2B < VAR2D)),(0 - 39),IF(((VAR2C > VAR2D) AND (VAR2C > VAR2E)),40,IF(((VAR2C < VAR2D) AND (VAR2C < VAR2E)),(0 - 40),IF(((VAR2D > VAR2E) AND (VAR2D > VAR2F)),41,IF(((VAR2D < VAR2E) AND (VAR2D < VAR2F)),(0 - 41),IF(((VAR2E > VAR2F) AND (VAR2E > VAR30)),42,IF(((VAR2E < VAR2F) AND (VAR2E < VAR30)),(0 - 42),IF(((VAR2F > VAR30) AND (VAR2F > VAR31)),43,IF(((VAR2F < VAR30) AND (VAR2F < VAR31)),(0 - 43),IF(((VAR30 > VAR31) AND (VAR30 > VAR32)),44,IF(((VAR30 < VAR31) AND (VAR30 < VAR32)),(0 - 44),IF(((VAR31 > VAR32) AND (VAR31 > VAR33)),45,IF(((VAR31 < VAR32) AND (VAR31 < VAR33)),(0 - 45),IF(((VAR32 > VAR33) AND (VAR32 > VAR34)),46,IF(((VAR32 < VAR33) AND (VAR32 < VAR34)),(0 - 46),IF(((VAR33 > VAR34) AND (VAR33 > VAR35)),47,IF(((VAR33 < VAR34) AND (VAR33 < VAR35)),(0 - 47),IF(((VAR34 > VAR35) AND (VAR34 > VAR36)),48,IF(((VAR34 < VAR35) AND (VAR34 < VAR36)),(0 - 48),0))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))));
VAR39:=(REF(VAR3,1) / 5700000);
VAR3A:=(((VAR3 - REF(VAR3,1)) / REF(VAR3,1)) * 100);
VAR3B:=(((VAR1 * OPEN) / VAR2) / 5700000);
最高:=(((VAR1 * HIGH) / VAR2) / 5700000);
最低:=(((VAR1 * LOW) / VAR2) / 5700000);
{蓄势:STICKLINE((((VAR37 = 1) OR (VAR37 = 2)) AND (VAR38 < 0)),o,c,7,0),color888888;}
蓄势:=IF(((VAR37 = 1) OR (VAR37 = 2)) AND (VAR38 < 0),1,0);
蓄势带量上涨:STICKLINE((VAR37 = 2)and 蓄势,OPEN,CLOSE,7,0),colorFFFF;
开:=WINNER(OPEN)*100,POINTDOT,COLORBLUE;
收:=WINNER(CLOSE)*100,POINTDOT,COLORMAGENTA;
无量长阳:=收-开>15 AND VOL/CAPITAL<0.02,LINETHICK0;
DRAWICON(无量长阳,HIGH,6);
DRAWTEXT(无量长阳,CLOSE,'无\n量\n长\n阳'),COLORWHITE;

飞狐成交量+主力吸筹洗盘主图指标公式

 

相关文章