在线检测未来函数

通达信回归预测指标公式

来源:Internet,编辑:股旁网,2012-11-11

BBI:=(HHV(C,3)+LLV(C,3)+HHV(H,3)+LLV(L,3))/4;
AD1:=FORCAST(WMA(BBI,3),3);
AD2:=FORCAST(WMA(BBI,5),3);
AD3:=FORCAST(WMA(BBI,8),3);
AD4:=FORCAST(WMA(BBI,11),3);
AC5:=FORCAST(WMA(BBI,13),3);
AC6:=FORCAST(WMA(BBI,15),3);
AC7:=FORCAST(WMA(BBI,18),3);
AC8:=FORCAST(WMA(BBI,21),3);
ADC:=((AD1+AD2+AD3+AD4)-(AC5+AC6+AC7+AC8))*10;
B虚:FORCAST(ADC,3),COLOR00FFFF,LINETHICK0;
IF(B虚>REF(B虚,1),B虚,DRAWNULL),COLORRED,DOTLINE;
IF(B虚<REF(B虚,1),B虚,DRAWNULL),COLOR00FF00,DOTLINE;
B实:WMA(ADC,3),COLOR00FF00,LINETHICK0;
{www.gupang.com 股旁网_通达信指标公式}
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),3,0),COLOR000099;
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),2,0),COLOR0000AA;
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),1.5,0),COLOR0000BB;
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),1,0),COLOR0000CC;
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),0.5,0),COLOR0000DD;
STICKLINE(B实>=REF(B实,1),B实,REF(B实,1),0,0),COLOR0000FF;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),3,0),COLOR006600;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),2,0),COLOR008800;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),1.5,0),COLOR00AA00;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),1,0),COLOR00BB00;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),0.5,0),COLOR00CC00;
STICKLINE(B实<REF(B实,1),B实,REF(B实,1),0,0),COLOR00DD00;
B1:FORCAST(WMA(ADC,3),3),POINTDOT,COLORFF3300,LINETHICK1;
B3:FORCAST(WMA(ADC,5),3),POINTDOT,COLORFF4400,LINETHICK2;
B5:FORCAST(WMA(ADC,8),3),POINTDOT,COLORFF5500,LINETHICK2;
B7:FORCAST(WMA(ADC,11),3),POINTDOT,COLORFF6600,LINETHICK3;
B9:FORCAST(WMA(ADC,13),3),POINTDOT,COLORFF7700,LINETHICK3;
B11:FORCAST(WMA(ADC,15),3),POINTDOT,COLORFF8800,LINETHICK4;
B13:FORCAST(WMA(ADC,18),3),POINTDOT,COLORFF9900,LINETHICK4;
B15:FORCAST(WMA(ADC,21),3),COLOR00FFFF,LINETHICK0;
IF(B15>REF(B15,1),B15,DRAWNULL),COLORRED,LINETHICK1;
IF(B15<REF(B15,1),B15,DRAWNULL),COLOR00FF00,LINETHICK1;

通达信回归预测指标公式

 

相关文章