在线检测未来函数

选股公式中去除ST和停牌股的方法

来源:Internet,编辑:股旁网,2012-11-12

今天想在选股公式中去除ST和停牌股,搜索了网络和论坛,发现主要有两种方法,但不是很理想。
第一种:
去除ST和停牌:=EXIST(C/REF(C,1)>1.06,60) AND DYNAINFO(7)>0;
这种方法不仅会有ST漏网,同时也屏蔽了一些符合选股条件的正常股票

第二种是:
A1:=RANGE((H/L-1)*100,13,22);
A2:=RANGE(ABS((C/REF(C,1)-1)*100),6,11);
A3:=RANGE(ABS((L/REF(C,1)-1)*100),6,11);
A4:=RANGE(ABS((H/REF(C,1)-1)*100),6,11);
去除ST:=EXIST((A1||A2||A3||A4)>0,18);
这种方法有点繁琐,但同样会有ST漏网。

经过摸索,找到一种更好的方法,供大家参考验证:
去除ST和停牌:=NOT(NAMELIKE('S') OR NAMELIKE('*S')) AND VOL>1;
主要借助了Namelike函数和对成交量的判断,简单且有效。

相关文章