在线检测未来函数

通达信海龟通道和波动率主图指标公式

来源:Internet,编辑:股旁网,2012-11-14

UPQK:=LOW-REF(HIGH,1);
STICKLINE(CLOSE>REF(CLOSE,1) AND UPQK>0,REF(HIGH,1),LOW,15,1),COLORYELLOW;
DOWNQK:=REF(LOW,1)-HIGH;
STICKLINE(CLOSE<REF(CLOSE,1) AND DOWNQK>0,REF(LOW,1),HIGH,15,1),COLORGREEN;
MA10:MA(CLOSE,170),COLOR0000FF;
MA20:MA(CLOSE,350),COLORFF0080;
DRAWKLINE(H,O,L,C);
N:=20;T:=20;
M1:=MA(C,N);
HPB:=REF(HHV(H,N),1);
LPB:=REF(LLV(L,T),1);
{多头交易}
BUYIN:=H>HPB ;
BUYEXIT:=L<LPB;
SINGAL:=IF(BUYIN,1,IF(BUYEXIT,-1,0));
CURRSIGN:=REF(SINGAL,BARSLAST(SINGAL));
UPTREND:=CURRSIGN= 1;
DWTREND:=CURRSIGN=-1;
{跟踪止损}
空平:=IF(DWTREND,HPB,M1),LINETHICK2;
多止:=IF(UPTREND,LPB,M1),LINETHICK2;
信号持续:=IF(DWTREND,BARSLAST(UPTREND),BARSLAST(DWTREND)),LINETHICK0;
DRAWICON(BARSLAST(DWTREND)=1,多止,4);
DRAWICON(BARSLAST(UPTREND)=1,空平,5);
{DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0))}
VAR1:=AMOUNT/VOL/100;
指导: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA
(CLOSE,24))/4,2),COLORWHITE;
界: MA(CLOSE,27),COLORYELLOW;
红轨道:MA(MA(CLOSE,3),1),LINETHICK1,COLOR0000FF;
绿轨道:MA(MA(CLOSE,3),3),LINETHICK1,COLOR00FF00;
{波动}
TRTR:= MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR := MA(TR,10);
STICKLINE((TR>ATR*1.5) AND (C <O),O,C,4,0),COLOR00FF00;
STICKLINE((TR>ATR*1.5) AND (C >O),O,C,4,0),COLORMAGENTA;

通达信海龟通道和波动率主图指标公式

 

相关文章