在线检测未来函数

飞狐力道指标公式

来源:Internet,编辑:股旁网,2012-11-15

X1:=(CLOSE+LOW+HIGH)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWGBK(X2>=X3,COLORRGB(150,0,0),COLORRGB(100,50,0),1);
DRAWGBK(X2<X3,COLORRGB(0,150,0),COLORRGB(0,80,0),1);
VAR2:=EMA(EMA(X1,1),13);
VAR3:=EMA(VAR2,21);
PARTLINE(VAR3,VAR3),LINETHICK2,colorFFFF;
PARTLINE(VAR2<VAR3,VAR3),LINETHICK2,colorFF0000;
STICKLINE(VAR2>=VAR3,VAR2,VAR3,8,0),colorFFFF;
STICKLINE(VAR2<VAR3,VAR2,VAR3,8,0),color9B6469;
XCLOSE:=EMA((OPEN+HIGH+LOW+CLOSE)/4,3);
XOPEN:=EMA((REF(OPEN,1)+REF(XCLOSE,1))/2,3);
TEMPG:=MAX(HIGH,XOPEN);
XHIGH:=EMA(MAX(TEMPG,XCLOSE),3);
TEMP:=MIN(LOW,XOPEN);
XLOW:=EMA(MIN(TEMP,XCLOSE),3);
O1:=IF(XOPEN<XCLOSE,XOPEN,XCLOSE);
C1:=IF(XOPEN<XCLOSE,XCLOSE,XOPEN);
STICKLINE(XOPEN>=XCLOSE,XHIGH,XLOW,0.1,0),colorFF0000;
STICKLINE(XOPEN>=XCLOSE,C1,O1,6,0),colorFF0000;
STICKLINE(XOPEN<XCLOSE,XHIGH,XLOW,0.1,0),colorFF;
STICKLINE(XOPEN<XCLOSE,C1,O1,6,0),colorFF;
AC:=CLOSE;
轉強:=WMA(HIGH,6);
轉弱:=WMA(LOW,6);
B:=CLOSE*0;
FOR I=13+1 TO DATACOUNT DO BEGIN
IF AC[I]>轉強[I-1] THEN
B[I]:=1;ELSE
IF AC[I]<轉弱[I-1] THEN
B[I]:=-1;ELSE
B[I]:=B[I-1];
END;
轉折線:IF(B=-1,MA(HIGH,6),MA(LOW,6)),LINETHICK2,colorFFFFFF;
趨勢:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
OP:=MA(X1,5);
REFOP:=REF(OP,1);
YDD:='==yungkuang==';
DRAWTEXT(SYSPARAM(2)=BARSCOUNT(CLOSE),CLOSE,YDD),ALIGN5,colorFF00;
EXPLAIN(CLOSE,'【多空力道觀點】'),colorFF;
EXPLAIN(OP>轉折線,'多空方向:多頭'),colorFF00FF;
EXPLAIN(OP<轉折線,'多空方向:空頭'),colorFF00FF;
EXPLAIN(OP>REF(OP,1),'短操作線:向上'),colorFFFF;
EXPLAIN(OP=REF(OP,1),'短操作線:持平'),color808080;
EXPLAIN(OP<REF(OP,1),'短操作線:向下'),colorFF0000;
EXPLAIN(X2>X3,'多空力道:向上'),colorFF;
EXPLAIN(X2<X3,'多空力道:向下'),colorFFFF00;
EXPLAIN(X2=X3,'多空力道:持平'),color808080;
EXPLAIN(趨勢>REF(趨勢,1),'主趨勢線:向上'),colorFF;
EXPLAIN(趨勢<REF(趨勢,1),'主趨勢線:向下'),colorFF0000;
EXPLAIN(趨勢=REF(趨勢,1),'主趨勢線:持平'),color808080;
EXPLAIN(CLOSE,'==================='),colorFF0000;
EXPLAIN(CLOSE,'【均線觀點】'),colorFF;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
EXPLAIN(MA5>REF(MA5,1)*1.01,'5日均線:強勁向上'),colorFFFF;
EXPLAIN(MA5>REF(MA5,1),'5日均線:向上'),colorFF;
EXPLAIN(MA5=REF(MA5,1),'5日均線:持平'),colorFF0000;
EXPLAIN(MA5<REF(MA5,1)*0.985,'5日均線:快速向下'),colorFFFFFF;
EXPLAIN(MA5<REF(MA5,1),'5日均線:向下'),colorFFFF00;
EXPLAIN(MA10>REF(MA10,1),'10日均線:向上'),colorFF;
EXPLAIN(MA10<REF(MA10,1),'10日均線:向下'),colorFFFF00;
EXPLAIN(MA10=REF(MA10,1),'10日均線:持平'),colorFF0000;
EXPLAIN(MA20>REF(MA20,1),'20日均線:向上'),colorFF;
EXPLAIN(MA20<REF(MA20,1),'20日均線:向下'),colorFFFF00;
EXPLAIN(MA20=REF(MA20,1),'20日均線:持平'),colorFF0000;
EXPLAIN(MA60>REF(MA60,1),'60日均線:向上'),colorFF;
EXPLAIN(MA60<REF(MA60,1),'60日均線:向下'),colorFFFF00;
EXPLAIN(MA60=REF(MA60,1),'60日均線:持平'),colorFF0000;
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(CLOSE<XB AND C1>=XB1);
M11:=REF(M,1);
N9:=BARSLAST(CLOSE>ET AND C1<=ET1);
N1:=REF(N9,1);
M21:=BARSLAST(M-N9>0 AND M11<=N1)+1;
N2:=BARSLAST(N9-M>0 AND N1<=M11)+1;
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF(M-N9>0 AND M11<=N1,1,IF(N9-M>0 AND N1<=M11,0,2));
H1:=IF(M-N9>0,CLOSE,ET2);
H2:=IF(A=1,CLOSE,C2);
H3:=IF(M-N9<0,CLOSE,XB2);
H4:=IF(A=1,CLOSE,XB2);
H5:=IF(M-N9>0 OR A=1,CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=H5>H6;
H9:=H4=REF(H4,1) AND REF(H4,1)<REF(H4,2) AND H5>REF(H5,2);
H10:=H2=REF(H2,1) AND H4=REF(H4,1) AND H5=REF(H5,2);
W:=H8 OR H9 OR H10;
T9:=H5<H6 AND H5<REF(H5,2);
T10:=H4=REF(H4,1) AND H5<REF(H5,2);
T11:=H3>REF(H3,1) AND H5<REF(H5,1);
T12:=H5=REF(H5,1) AND H3=H4;
T13:=H2=REF(H2,1) AND H2=H5;
TW:=T9 OR T10 OR T11 OR T12 OR T13;
BBP:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
EXPLAIN(CLOSE,'==================='),colorFF0000;
EXPLAIN(CLOSE,'【支撐壓力狀況】'),colorFF;
EXPLAINEX(ISLASTBAR AND W,'最高壓力:',H5*1.025,2,0),colorFF9900;
EXPLAINEX(ISLASTBAR AND W,'最低支撐:',H5*0.99,2,0),color99FF;
EXPLAINEX(ISLASTBAR AND TW,'最高壓力:',(H5+H4)/1.96,2,0),colorFF9900;
EXPLAINEX(ISLASTBAR AND TW,'最低支撐:',(H5+H3)/2.05,2,0),color99FF;
EXPLAINEX(ISLASTBAR AND W,'高點壓力:',H5*1.02,2,0),colorFF9900;
EXPLAINEX(ISLASTBAR AND W,'低點支撐:',H5*1,2,0),color99FF;
EXPLAINEX(ISLASTBAR AND TW,'高點壓力:',(H5+H4)/1.99,2,0),colorFF9900;
EXPLAINEX(ISLASTBAR AND TW,'低點支撐:',(H5+H3)/2.03,2,0),color99FF;
EXPLAIN(CLOSE,'==================='),colorFF0000;

飞狐力道指标公式

 

相关文章