在线检测未来函数

同花顺多空主图指标公式

来源:Internet,编辑:股旁网,2012-11-15

趋势:MA(LOW,20)*1.2,color0080ff,linethick2;
次上趋势:MA(LOW,20)*1.1,coloryellow;
次下趋势:MA(HIGH,20)*0.9,colorwhite;
下趋势:MA(HIGH,20)*0.8,colorgreen,linethick2;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZ,:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1)));
STICKLINE(趋势强度=0,H,L,6,1),colorblue;
STICKLINE(趋势强度=1,H,L,6,1),colorgreen;
STICKLINE(趋势强度=2,H,L,6,1),colorgray;
STICKLINE(趋势强度=3,H,L,6,1),coloryellow;
STICKLINE(趋势强度=4,H,L,6,1),colormagenta;
STICKLINE(趋势强度=0,C,O,5,0),colorblue;
STICKLINE(趋势强度=1,C,O,5,0),colorgreen;
STICKLINE(趋势强度=2,C,O,5,0),colorgray;
STICKLINE(趋势强度=3,C,O,5,0),coloryellow;
STICKLINE(趋势强度=4,C,O,5,0),colormagentabyx:=MA(CLOSE,7),colorwhite;
PARTLINE(byx,byx>REF(byx,1),RGB(255,0,0),byx<REF(byx,1),RGB(0,240,240)),linethick1;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,colorred;
马线:MA(牛线,5),colorgreen;
FILLRGN(牛线,马线,(马线<牛线),color0033FF);
FILLRGN(牛线,马线,(马线>牛线),colorgreen);
中线:MA(C,55),POINTDOT,colorred;
STICKLINE((CLOSE >中线),中线,中线,1,0),LINETHICK6,COLOR0000FF;
STICKLINE((中线 > CLOSE),中线,中线,1,0),LINETHICK6,COLORFFFF00;
牛熊分界线: MA(CLOSE,120),linethick1,color0099ff;
HH:=HHV(HIGH,3);LL:=LLV(LOW,3);
CH1:=(HH > REF(HH,1)AND C>REF(C,1));
CH2:=(LL < REF(LL,1)AND C<REF(C,1));
K3:=BARSLAST(CH1);K4:=BARSLAST(CH2);
K5:=(K3<K4 OR CH1) AND NOT(CH2);
K6:=(K3>K4 OR CH2) AND NOT(CH1);
ZC:=IF(HH>REF(HH,1) AND C>REF(C,1),LL,REF(LL,BARSLAST(HH>REF(HH,1)AND C>REF(C,1))));
YL:=IF(LL<REF(LL,1) AND C<REF(C,1),HH,REF(HH,BARSLAST(LL<REF(LL,1) AND C<REF(C,1))));
多空线:IF(K5,ZC,YL),colorwhite,LINETHICK2;
买线:=EMA(CLOSE,2);
卖线:=EMA((SLOPE(CLOSE,21))*(20)+CLOSE,42);
STICKLINE((买线>卖线),CLOSE,OPEN,0,0) ,COLOR00FFFF;
STICKLINE((买线>卖线),CLOSE,OPEN,10,0) ,COLOR0088FF;
STICKLINE((买线>卖线),CLOSE,OPEN,8,0) ,COLOR0099FF;
STICKLINE((买线>卖线),CLOSE,OPEN,6,0) ,COLOR00AAFF;
STICKLINE((买线>卖线),CLOSE,OPEN,5,0) ,COLOR00BBFF;
STICKLINE((买线>卖线),CLOSE,OPEN,4,0) ,COLOR00CCFF;
STICKLINE((买线>卖线),CLOSE,OPEN,3,0) ,COLOR00DDFF;
STICKLINE((买线>卖线),CLOSE,OPEN,2,0) ,COLOR00EEFF;
STICKLINE((买线>卖线),CLOSE,OPEN,1,0) ,COLOR00FFFF;
STICKLINE((买线<卖线),CLOSE,OPEN,0,0), color00FF00;
STICKLINE((买线<卖线),CLOSE,OPEN,8,1), colorFF250C;
STICKLINE((买线<卖线),CLOSE,OPEN,7,1), colorFF255C;
STICKLINE((买线<卖线),CLOSE,OPEN,6,1), colorFF147C;
STICKLINE((买线<卖线),CLOSE,OPEN,5,1), colorFF5B84;
STICKLINE((买线<卖线),CLOSE,OPEN,4,1), colorFF747C;
STICKLINE((买线<卖线),CLOSE,OPEN,3,1), colorFF887C;
STICKLINE((买线<卖线),CLOSE,OPEN,2,1), colorFFAC10;
STICKLINE((买线<卖线),CLOSE,OPEN,1,1), colorFFD110;
红底:=(SMA(HIGH,19,3) * 1);
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 红底)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,10,0),colorred;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
抄底:=IF(REF(COUNT(K<REF(K,1),5)>=5,1) AND COUNT(K<30,5)>=2 AND COUNT(J<0,3)>0 AND CROSS(J,0),30,0);
DRAWTEXT(抄底,L*0.99,'▲底!'),COLOR0000FF;
逃命:=(SMA(HIGH,21,2) * 1.05);
DRAWTEXT(FILTER(((HIGH > 逃命) AND (CLOSE < 逃命)),5),(HIGH + 0.50),'逃命');
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT((H-C)/REF(C,1)>0.03 AND H=HHV(H,21),H*1.04,'止赢'),colorwhite;

同花顺多空主图指标公式

 

相关文章