在线检测未来函数

大智慧选股买卖指标公式

来源:Internet,编辑:股旁网,2012-11-15

Var1:=DATE>901224 AND DATE<2098106;
Var2:=DATE>2098104;
Var3:=LLV(HIGH,240)*Var1;
Var4:=100*(CLOSE-Var3)/Var3*Var1;
Var5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100*Var1;
Var6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100*Var1;
Var7:=0;
Var8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
Var9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VarA:=BARSCOUNT(CLOSE);
VarB:=Var8<20 AND Var9<23 AND VarA>35;
VarC:=VarB AND COUNT(VarB,1)=1;
VarD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VarE:=EMA(VarD,5)*Var1;
VarF:=TROUGHBARS(3,6,1)<4 AND CROSS(VarD,VarE)*Var1;
Var10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0)*Var1;
Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3)*Var1;
Var12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3)*Var1;
Var13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3)*Var1;
Var14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3)*Var1;
Var15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3)*Var1;
Var16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3)*Var1;
Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3)*Var1;
Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3)*Var1;
Var1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var1E:=EMA(Var1D*0.97,3);
Var1F:=(HIGH+LOW+CLOSE)/3;
Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
Var21:=CROSS(Var1E,LOW)*Var1;
大方选股买点: Var10*Var1*Var1,colorred, linethick2;
组合买:(Var11+Var13+Var15+Var17)*Var1, colorgreen, linethick2;
组合卖:(Var12+Var14+Var16+Var18)*Var1,linethick2 , colorcyan;
Var22:=大方选股买点 AND VarF AND VarC AND Var21 AND Var4<0 AND Var5=0 AND Var6=0 AND Var20<(-110)*Var1;
DRAWTEXT(Var13,0.6,'●介入')*Var1,colormagenta , linethick4;
DRAWICON(组合买,组合买,1)*Var1;
DRAWICON(组合卖,组合卖,9)*Var1;
DRAWTEXT(Var22>0,3,'我个人介入点')*Var1 ;
DRAWICON(大方选股买点>0,4.2,1)*Var1;
DRAWTEXT(大方选股买点 AND VarF AND VarC,2.8,' 30%下单莫错过!')*Var1,color0099ff ,linethick3 ;
DRAWTEXT(Var18,3,'空仓')*Var1, linethick3, colorcyan;
DRAWTEXT(Var20<-110 AND 大方选股买点>0,2,'大方选股买点')*Var1,coloryellow ,linethick3 ;
DRAWTEXT(Var17,1.3,'发现黑马')*Var1,colorcyan ,linethick3 ;
DRAWTEXT(大方选股买点 AND Var20<-100 AND VarF AND VarC>0,4.1,'★大方组合5分钟线选股思路获利5%以上')*Var1, color0099ff,linethick3 ;

大智慧选股买卖指标公式

 

相关文章