在线检测未来函数

大智慧多空转折主图指标公式

来源:Internet,编辑:股旁网,2012-11-17

TYP :=(h+l+2*c)/4;
x:=wMA(TYP,3);
ii1:=DMA(X,BETA(35));
均线1:SLOPE(ii1-REF(ii1,5),3)+C,colorffff00,layer0,LINETHICK2;
H均线:=wMA(h,3);
L均线:=wMA(L,3);
转折线:IF(C>REF(H均线,1),L均线-(eMA(l,2)-WMA(l,2)),IF(C<REF(L均线,1),H均线+(eMA(h,2)-WMA(h,2)),L)),LINETHICK2,colorffffFF,LAYER2;
M8:=EMA(C,8);
M13:=EMA(C,13);
FILLRGN(M8,M13,M8>M13,RGB(255,155,0));
看多:C>转折线,linethick0,color0000ff;
看空:C<=转折线,linethick0,color00ff00;
看空期:=BARSLAST(看多);
看多期:=BARSLAST(看空);
预买:看多期=1,color00ffff,linethick0;
清仓:看空期=1,colorblue,linethick0;
STICKLINE(C>转折线,H,L,0,0),colorred;
STICKLINE(C>转折线,O,C,8,0),colorred;
STICKLINE(C>转折线 AND C<O,O,C,8,1),colorred;
STICKLINE(C<=转折线,H,L,0,0),color00ff00;
STICKLINE(C<=转折线,O,C,8,0),color00ff00;
STICKLINE(C<=转折线 AND C>O,O,C,8,1),color00ff00;
STICKLINE(预买,O,(C+O)/2,8,0),color00ffff;
STICKLINE(清仓,O,(C+O)/2,8,0),colorFF6600;

大智慧多空转折主图指标公式

 

相关文章