在线检测未来函数

通达信指数幂+BOLL+大盘对比+乖离指标公式

来源:Internet,编辑:股旁网,2012-11-18

N:=20;N1:=55;N2:=24;
DRAWTEXT_FIX(1,0.00,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.07,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,'所属行业:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.06,0,HYBLOCK)COLORFF00FF;
CC:=SQRT(EXP(C/100));
CH:=SQRT(EXP((C+H)/200));
OH:=SQRT(EXP((O+H)/200));
COL:=SQRT(EXP((C+O+L)/300));{指数幂}
STICKLINE(CC>=(REF(CC,1)+OH)/2,COL,CH,0.00001,0),COLORRED;
STICKLINE(CC<(REF(CC,1)+OH)/2,COL,CH,0.00001,0),COLORFF9900;
STICKLINE(CC>(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,2.5,0),COLORRED;
STICKLINE(CC>(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,0.6,0),COLORCC66FF;
STICKLINE(CC<(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,2.5,0),COLORFF6600;
STICKLINE(CC<(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,0.6,0),COLORFF9900;{幂K线}
M1:SMA(CC,N1,N2);{迷糊鱼2010编写}
M2:SMA(M1,N1,N2),DOTLINE;
M3:SMA(M2,N1,N2),COLORGREEN;
ZSB:=EMA((CC-REF(CC,1))/(REF(CC,1)*10)-(INDEXC-REF(INDEXC,1))/(REF(INDEXC,1)*10),5);
STICKLINE(ZSB>0,M1,M2,0.3,0.1),COLORYELLOW;
STICKLINE(ZSB<0,M1,M2,0.3,0.1),COLORGREEN;{大盘对比}
ZJ:=(CC*2+CH+COL)/4;
GL:=EMA(ZJ,13)-EMA(ZJ,21);
GM1:=EMA(GL,3);
GM2:=EMA(GL,10);
A1:=EMA(CC,7)-EMA(CC,21);
B1:=EMA((0.618*REF(A1,1)+0.382*A1),1);
STICKLINE(A1>B1,M2,M3,0.3,0.1),COLORRED;
STICKLINE(A1<B1,M2,M3,0.3,0.1),COLORCYAN;{乖离}
BOLL:MA(CC,N),DOTLINE,COLORWHITE;
UB:BOLL+2*STD(CC,N),DOTLINE,COLORLIRED;
LB:BOLL-2*STD(CC,N),DOTLINE,COLORLIBLUE;{BOLL用于区分顶底};
{买点}
A9:=EMA(C,2)-EMA(C,55);
A10:=EMA(A9,13);
A11:=2*(A9-A10);
ZL:=100*POW(A11,3)*0.1+100*POW(A11,1);
DRAWICON(CROSS(ZL,0),COL,31);

通达信指数幂+BOLL+大盘对比+乖离指标公式

 

相关文章