在线检测未来函数

通达信绝佳买卖指标公式

来源:Internet,编辑:股旁网,2012-11-20

VAR1:=(CLOSE+HIGH+LOW)/3;
VAR2:=EMA(VAR1,10);
VAR3:=REF(VAR2,1);
探底震仓:IF(VAR2,10,DRAWNULL),COLORYELLOW,LINETHICK5;
红买: IF(VAR2>VAR3,10,DRAWNULL), COLORRED,LINETHICK5;
蓝卖: IF(VAR2<VAR3,10,DRAWNULL),COLORBLUE,LINETHICK5;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*150;
上穿买:SMA(RSV,3,1),COLORGREEN;
IF(上穿买>REF(上穿买,1)*1.01,上穿买 ,DRAWNULL),COLORRED;
IF(上穿买<REF(上穿买,1),上穿买 ,DRAWNULL),COLORBLUE;
趋势线:SMA(上穿买,3,1),COLORYELLOW;
VAR03:=(3,15,1)<10;
VAR05:=IF(VAR03=1,2,0);
涨家数:INDEXADV,COLOR0080FF,NODRAW;
跌家数:INDEXDEC,COLORGREEN,NODRAW;
DRAWICON(CROSS(红买,蓝卖),红买,2);
DRAWICON(CROSS(蓝卖,红买),蓝卖-1,1);
DRAWTEXT_FIX(1,0,0,0,'★ A - 见红关注-逢低买入 ★ '),COLORRED;
DRAWTEXT_FIX(1,0.14,0,0,'★ B - 见绿警示-逢高减仓 ★ '),COLORGREEN;
DRAWTEXT_FIX(1,0.28,0,0,'★ C - 见蓝风险-高抛避险 ★ '),COLORCYAN;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299,NODRAW;
ZF:=(C-REF(C,1))/REF(C,1)*100;
AA:EMA(EMA((C-REF(C,1)),6),6)*100/EMA(EMA(ABS((C-REF(C,1))),6),6)COLORGREEN,LINETHICK2;
IF(AA>=REF(AA,1),AA,DRAWNULL), COLORRED,LINETHICK2;
DD:=LLV(AA,BARSLAST(AA<REF(AA,1))+1);
ZT:=BARSLAST(CROSS(AA,DD*0.66) AND AA<0 AND DD<-20);
收益:SUM(ZF,IF(ZT=0,1,ZT)),COLORRED,LINETHICK0;
MR:=CROSS(AA,DD*0.66) AND AA<0 AND DD<-20;
DRAWICON(MR,AA*0.8,25);
MC:=CROSS(DD,0) AND DD=AA;
DRAWICON(MC,AA*0.9,24);
DRAWTEXT(MC,AA*1.00,'快跑')COLORYELLOW;
DRAWTEXT(MR,AA,'买入')COLORRED;

通达信绝佳买卖指标公式

 

相关文章