在线检测未来函数

通达信短线买主图指标公式

来源:Internet,编辑:股旁网,2012-11-20

MA5:EMA(C,5);
MA13:EMA(C,13);
MA22:EMA(C,22);
MA60:EMA(C,60);
MA120:EMA(C,120);
A:=(C-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
B:=SMA(A,11,8);
F:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*10;
A1:=LLV(L,5);
A2:=HHV(H,22);
F1:= EMA((CLOSE-A1)/(A2-A1)*4,4);
F2:=REF(F1,1);
DRAWTEXT((B>=REF(B,1)AND (REF(DOWNNDAY(CLOSE,1),1) AND C>=REF(C,1)
AND F>=REF(F,1))AND F1>=F2 AND CLOSE/REF(CLOSE,1)<1.035
AND DYNAINFO(37)<0.03),LOW-0.5,'短买')COLORRED ;
TZHX:=HHV(MA((REF(L,1)+REF(H,1)+REF(C,1)+REF(O,1))/4,2),1),COLORFF9933;
TZLX:=IF((C>TZHX),TZHX,DRAWNULL),COLORYELLOW;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19 AND C>O,L,L*0.993,2.6,0),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A AND C<O,H*1.013,H,3,0),COLORFF1111;
{}
N3:=3; N6:=6;
HH:=HHV(HIGH,N3); LL:=LLV(LOW,N6);
HH1:=BARSLAST((HH>REF(HH,1)));
LL1:=BARSLAST((LL<REF(LL,1)));
STICKLINE((HH1<LL1) AND C>=TZHX,HIGH,LOW,0,0),COLORFF00FF;
STICKLINE((HH1<LL1) AND C>=TZHX,CLOSE,OPEN,1.2,0),COLORFF00FF;
STICKLINE((HH1>LL1) AND C>O AND C>=TZHX,HIGH,LOW,0,0),COLORDDDDFF;
STICKLINE((HH1>LL1) AND C>O AND C>=TZHX,CLOSE,OPEN,1.2,0),COLORDDDDFF;
AAA:=(CONST(HHV(H,90)));
A74:=MA(CLOSE,20);
A75:=(CLOSE>MA(CLOSE,5));
A76:=(MA(CLOSE,5)>MA(CLOSE,10));
A77:=(CLOSE> MA(CLOSE,10));
A78:=(MA(CLOSE,5)>MA(CLOSE,20));
A79:=(CLOSE>MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74>A710);
AVX:=(((((IF(A75,10,(0-10))+IF(A76,10,(0-10)))+IF(A77,10,(0-10)))
+ IF(A78,10,(0 - 10)))+IF(A79,10,(0-10)))+IF(A711,10,(0-10)));
DSLX:=(CLOSE/INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T12:=CONST(IF(C<200 AND ((((AVX>=1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T13:=CONST(IF(C<200 AND ((((AVX<1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C<200 AND ((((AVX<1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T15:=CONST(IF(C<200 AND ((((AVX <1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T16:=CONST(IF(C<200 AND ((((AVX <1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
DRAWTEXT(T1=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'1量能理想,明显走强,中线参与,仓位在2/3左右'),COLORYELLOW;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'2走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORYELLOW;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'3量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORYELLOW;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORYELLOW;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'形态变坏,重仓者减持大半,清仓者观望'),COLORYELLOW;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=28,AAA*0.98
,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORYELLOW;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'该股放量下跌,走势明显偏弱,离场观望'),COLORYELLOW;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'该股缩量下跌,走势偏弱,离场观望。'),COLORYELLOW;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'9该股形态良好,强势明显,量能充足,可以继续持有'),COLORYELLOW;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'10上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORYELLOW;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'11该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORYELLOW;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'该股走势趋弱,量能不足,减持大部分筹码'),COLORYELLOW;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORYELLOW;
DRAWTEXT(T14=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORYELLOW;
DRAWTEXT(T15=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'15有走强迹象,但量能不足,趋势不明,不适合操作'),COLORYELLOW;
DRAWTEXT(T16=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'该股走势太弱,没有参与价值。'),COLORYELLOW;
DRAWTEXT(T17=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'17大盘理想,有明显走强迹象,中线参与,仓位在2/3左右'),COLORYELLOW;
DRAWTEXT(T18=1 AND CURRBARSCOUNT=23,AAA-(AAA*0.03)
,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORYELLOW;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'19考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORRED;
DRAWTEXT(T20=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLOR11FF00;
DRAWTEXT(T21=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'大盘缩量调整,注意风险,短线清仓观望。'),COLOR11FF00;
DRAWTEXT(T22=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'22大盘走势良好,量能理想,可以继续持有强势股。'),COLOR11FF00;
DRAWTEXT(T23=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLOR11FF00;
DRAWTEXT(T24=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLOR11FF00;
DRAWTEXT(T25=1 AND CURRBARSCOUNT=28,AAA-(AAA*0.03)
,'大盘趋势向下,量能萎缩,不适合进场。'),COLOR11FF00;
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,3,-1),COLOR00FFFF;
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,3,-1),COLORGREEN;

通达信短线买主图指标公式

 

相关文章