在线检测未来函数

大智慧天王买卖指标公式

来源:Internet,编辑:股旁网,2012-11-21

DF火:= BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1));
DF山:= COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),12);
天王卖:REF(DF火,4)>0 and REF(DF火,3)>0 AND REF(DF火,2)>0 AND REF(DF火,1)>0 AND DF火=0 AND REF(DF火,1)>DF山,colorgreen,linethick2;
CMC0:=REF(C,2)*0.865;
CMC1:=REF(C,13)*0.772;
CMDSY:=100*vol/CApitAl;
天王买1:=(C-MIN(CMC0,CMC1))/C<0.085 AND SUM(CMDSY,5)/5<1.8;
bwVar1:=(C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27 AND COUNT((C-MA(C,48))/MA(C,48)*100<-30 AND (C-MA(C,70))/MA(C,70)*100<-27,2)=1 AND (O-REF(C,1))/REF(C,1)>-0.07 and COUNT(c=o,6)=0;
bwVar2:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100;
bwVar3:=REF(bwVar2,1)<-46 AND bwVar2>REF(bwVar2,1) AND REF(bwVar2,1)<REF(bwVar2,2) AND bwVar2-REF(bwVar2,1)>2.2;{-42,1.8}
天王买2:=(bwVar1 or bwVar3);
bwVar10:=SMA(SMA((INDEXC-LLV(INDEXL,275))/(HHV(INDEXH,275)-LLV(INDEXL,275))*100,50,1),40,1);
天王买3:=(C-MA(C,70))/MA(C,70)*100<-24 AND bwVar10<23 AND COUNT((C-MA(C,70))/MA(C,70)*100<-23,2)=1 AND (O>C OR O<C) AND O/REF(C,1)>0.96;{-23}
bwVar15:=DMA(EMA(C,5),SUM(V,8)/2.8/CAPITAL);
bwVar10:=REF((C-bwVar15)/bwVar15*100,1)<-40;
bwVar11:=(C-bwVar15)/bwVar15*100>REF((C-bwVar15)/bwVar15*100,1);
bwVar12:=REF((C-bwVar15)/bwVar15*100,1)<REF((C-bwVar15)/bwVar15*100,2);
bwVar13:=(C-bwVar15)/bwVar15*100-REF((C-bwVar15)/bwVar15*100,1)>1.8;
bwVar14:=H>L*1.053 AND COUNT(H>L*1.053,5)>2 AND (C/MA(C,30)*100<75 OR C/MA(C,50)*100<78);
天王买4:=bwVar10 AND bwVar11 AND bwVar12 AND bwVar13 OR bwVar14;{-34,1.76}
jdVar1:=(C-MA(C,48))/MA(C,48)*100<-28;
jdVar2:=SMA(MAX(C-REF(C,1),0),12,1)/SMA(ABS(C-REF(C,1)),12,1)*100>23;
天王买5:=jdVar1 AND jdVar2 AND VOL>MA(VOL,18) AND COUNT(c=o,6)=0;
xrVar2:=(C-MA(C,50))/MA(C,50)*100<-23;
xrVar3:=SMA(MAX(C-REF(C,1),0),3,1)/SMA(ABS(C-REF(C,1)),3,1)*100>16;
xrVar4:=CROSS(100*(HHV(H,27)-C)/(HHV(H,27)-LLV(L,27)),79);
xrVar5:=(O-REF(C,1))/REF(C,1)<0.05 AND V>MA(V,23);
天王买6:=xrVar2 AND xrVar3 AND xrVar4 AND (O>C OR O<C) AND xrVar5;
天王买: (天王买1+天王买2+天王买3+天王买4+天王买5+天王买6 )>=2,stick3d,colorred;

大智慧天王买卖指标公式

 

相关文章