在线检测未来函数

通达信高低有度主图指标公式

来源:Internet,编辑:股旁网,2012-11-21

LYA1:=IF(H>REF(HHV(H,3),1) AND C>REF(C,1),LLV(L,3),IF (L<REF(LLV(L,3),1) AND C<REF(C,1),
HHV(H,3),DRAWNULL));
LYA:=IF(LYA1=DRAWNULL,REF(LYA1,1),LYA1);
SNX2:=IF(LYA<H AND LYA>L,REF(LYA,1),LYA);
BB:=PLOYLINE(C>0,SNX2),COLORGREEN,LINETHICK1;
DRAWICON(CROSS(C,BB),(C+O)/2,1);
DRAWICON(CROSS(BB,C),(C+O)/2,2);
中: EMA(EMA(EMA(HIGH,7.23379625),7.23379625),1),COLORLIBLUE,LINETHICK1;
中斜:=(EMA(中,2)-REF(EMA(中,2),2))/REF(EMA(中,2),2)*100,NODRAW;
IF(中斜>=0,中,DRAWNULL),COLORRED,LINETHICK2;
下1: 中*0.9276620375,COLORYELLOW,LINETHICK1;
下2: 中*0.868055,COLORYELLOW,LINETHICK1; {0.9}
下3:中*0.8263889,COLORYELLOW,POINTDOT;
上1:中*1.0723379625,COLORYELLOW,LINETHICK1;
上2: 中*1.12170138,COLORYELLOW,LINETHICK1;
上3:中*1.1694444444,COLORYELLOW,POINTDOT;
MACD:="MACD.MACD#DAY"(12,26,9);
周MACD:="MACD.MACD#WEEK"(12,26,9);
IF(MACD>=0,下1,DRAWNULL),COLORRED,LINETHICK2;
IF(周MACD>=0,下2,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT((C-MA(C,13))/MA(C,13)*100<-20 AND C<下3,L,'建');
DRAWTEXT(FILTER(CROSS(MACD,0)OR CROSS(周MACD,0),3),L*0.99,'小加')COLORWHITE;
DRAWTEXT(COUNT(MACD>=0 AND 周MACD>=0 AND 中斜>=0,5)=1 AND MACD>=0 AND 周MACD>=0 AND 中斜>=0,L*0.96,'大加')COLORMAGENTA;
DRAWTEXT(FILTER(CROSS(0,MACD) OR CROSS(0,周MACD) OR CROSS(0,中斜),5),H*1.05,'减')COLORGREEN;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

通达信高低有度主图指标公式

 

相关文章