在线检测未来函数

通达信寻庄骑马指标公式

来源:Internet,编辑:股旁网,2012-11-22

均价:=(0.618*(0.809*C+0.191*o)+0.382*(if(H=C,C,H)+if(L=C,C,L))/2);
R:=(0.809*if(L=C,C,L)+0.191*均价);R1:=(0.809*if(H=C,C,H)+0.191*均价);kx:=(r+R1)/2;
hr:=(HHV(R1,34)*0.618+(HHV(R1,55)+HHV(R1,89))/2+HHV(R1,144)*0.382)/2;
Lr:=(LLV(R,34)*0.618+(LLV(R,55)+LLV(R,89))/2+LLV(R,144)*0.382)/2;
Zr:=(HHV(AMOUNT,34)*0.618+(HHV(AMOUNT,55)+HHV(AMOUNT,89))/2+HHV(AMOUNT,144)*0.382)/2;
量能:100*(HR-均价)/(HR-LR),LINETHICK,COLORGRAY;
STICKLINE(量能>=2,量能,0,3,1),COLORGRAY;
饱和度:(WMA(AMOUNT,2)/WMA(KX,2))/(ZR/HR)*100,LINETHICK,COLORRED;
STICKLINE(饱和度>量能,饱和度,0,2,0),COLORRED;
STICKLINE(饱和度<量能,饱和度,0,2,0),COLOR00bb00;
AK:=((均价-LR)/(HR-LR))*100-4.8;
kk:=SMA(ak,5,2),COLORFFC0FF;
骑马线:KK,COLORWHITE;
IF(骑马线>AK,骑马线,DRAWNULL),COLORGREEN;
上马:=(3*SMA((均价-LR)/(HR-LR)*100,3,1)-2*SMA((均价-LR)/(HR-LR)*100,3,1))-4.8;
马线:EMA(上马,3),LINETHICK2,COLORMAGENTA;
IF(上马<马线,马线,DRAWNULL),COLORAAAA00,LINETHICK2;
获利:=WINNER(均价);
kp:=(WMA(获利,34)*0.618+(WMA(获利,55)+WMA(获利,89))/2+WMA(获利,144)*0.382)/2;
控盘线:kp*100,COLORYELLOW,LINETHICK2;
STICKLINE(c>0,20,20,6,0),COLORMAGENTA;
STICKLINE(c>0,60,60,6,0),COLORMAGENTA;
0,COLORGREEN;40,COLORWHITE;80,COLORRED;

通达信寻庄骑马指标公式

 

相关文章