在线检测未来函数

通达信漂亮MACD指标公式

来源:Internet,编辑:股旁网,2012-11-22

上市日:FINANCE(42),,NODRAW,COLORRED;
DIFF:EMA(C,12)-EMA(C,26);
DEA :EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA);
AH:HHV(DIFF,55)COLOR008800;
AL:LLV(DIFF,55)COLOR009933;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR00AAFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.0,0 ),COLOR00CCFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.0,0 ),COLOR00EEFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5 ,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.5 ,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1 ,0 ),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.5 ,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.5 ,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.5,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1 ,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.5 ,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORFF7700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.5 ,0 ),COLORFF8811;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFAA22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.5 ,0 ),COLORFFBB33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1 ,0 ),COLORFFDD44;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.5 ,0 ),COLORFFFF55;
IF(DIFF>REF(DIFF,1),DIFF,DRAWNULL),COLORRED;
IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),COLORGREEN;
IF(DIFF>REF(DIFF,1)AND REF(DIFF,1)>0,DIFF,DRAWNULL),COLORWHITE;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORYELLOW;

通达信漂亮MACD指标公式

 

相关文章