在线检测未来函数

大智慧仁治MACD指标公式

来源:Internet,编辑:股旁网,2012-11-23

input:LONG(20,10,100),SHORT(8,5,40),M(9,2,60);
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),COLORblack;
DEA : EMA(DIFF,M),COLORblack;
MACD : 2*(DIFF-DEA), COLORBLACK;
a51:=MACD*20;
净流入1:SUM(a51,1),COLORblack;
净流入2:SUM(a51,2),COLORblack;
净流入3:SUM(a51,3),COLORblack;
净流入4:SUM(a51,4),COLORblack;
净流入5:SUM(a51,5),COLORblack;
净流入6:SUM(a51,6),COLORblack;
净流入7:SUM(a51,7),COLORblack;
净流入8:SUM(a51,8),COLORblack;
净流入9:SUM(a51,9),COLORblack;
净流入10:SUM(a51,10),COLORblack;
净流入11:SUM(a51,11),COLORblack;
净流入12:SUM(a51,12),COLORblack;
净流入13:SUM(a51,13),COLORblack;
净流入14:SUM(a51,14),COLORblack;
净流入15:SUM(a51,15),COLORblack;
净流入16:SUM(a51,16),COLORblack;
净流入17:SUM(a51,17),COLORblack;
净流入18:SUM(a51,18),COLORblack;
净流入19:SUM(a51,19),COLORblack;
a60:=净流入1>=ref(净流入1,1);
a61:=净流入2>=ref(净流入2,1);
a62:=净流入3>=ref(净流入3,1);
a63:=净流入4>=ref(净流入4,1);
a64:=净流入5>=ref(净流入5,1);
a65:=净流入6>=ref(净流入6,1);
a66:=净流入7>=ref(净流入7,1);
a67:=净流入8>=ref(净流入8,1);
a68:=净流入9>=ref(净流入9,1);
a69:=净流入10>=ref(净流入10,1);
a70:=净流入11>=ref(净流入11,1);
a71:=净流入12>=ref(净流入12,1);
a72:=净流入13>=ref(净流入13,1);
a73:=净流入14>=ref(净流入14,1);
a74:=净流入15>=ref(净流入15,1);
a75:=净流入16>=ref(净流入16,1);
a76:=净流入17>=ref(净流入17,1);
a77:=净流入18>=ref(净流入18,1);
a78:=净流入19>=ref(净流入19,1);
a80:=净流入1<=ref(净流入1,1);
a81:=净流入2<=ref(净流入2,1);
a82:=净流入3<=ref(净流入3,1);
a83:=净流入4<=ref(净流入4,1);
a84:=净流入5<=ref(净流入5,1);
a85:=净流入6<=ref(净流入6,1);
a86:=净流入7<=ref(净流入7,1);
a87:=净流入8<=ref(净流入8,1);
a88:=净流入9<=ref(净流入9,1);
a89:=净流入10<=ref(净流入10,1);
a90:=净流入11<=ref(净流入11,1);
a91:=净流入12<=ref(净流入12,1);
a92:=净流入13<=ref(净流入13,1);
a93:=净流入14<=ref(净流入14,1);
a94:=净流入15<=ref(净流入15,1);
a95:=净流入16<=ref(净流入16,1);
a96:=净流入17<=ref(净流入17,1);
a97:=净流入18<=ref(净流入18,1);
a98:=净流入19<=ref(净流入19,1);
a99:=a51>=ref(a51,1);
a100:=a51<=ref(a51,1);
partline(a51,a99,rgb(255,0,0),a100,rgb(0,0,255)),linethick1;
partline(净流入1,a60,rgb(255,0,0),a80,rgb(0,255,0)),linethick1;
partline(净流入5,a64,rgb(255,0,0),a84,rgb(0,255,0)),linethick1;
partline(净流入9,a68,rgb(255,0,0),a88,rgb(0,255,0)),linethick1;
partline(净流入13,a72,rgb(255,0,0),a92,rgb(0,255,0)),linethick1;
partline(净流入19,a78,rgb(255,0,0),a98,rgb(0,255,0)),linethick1;
DRAWTEXT(a60 AND a61 AND a62 AND a63 AND a64 AND a65 AND a66,净流入7,'←'),COLOR00FFFF,linethick1;
DRAWTEXT(a80 AND a81 AND a82 AND a83 AND a84 AND a85 AND a86,净流入7,'←'),COLOR33FF00,linethick1;
DRAWTEXT(a67 AND a68 AND a69 AND a70 AND a71 AND a72,净流入13,'←'),COLORFF00FF,linethick1;
DRAWTEXT(a87 AND a88 AND a89 AND a90 AND a91 AND a92,净流入13,'←'),COLOR33FF00,linethick1;
DRAWTEXT(a73 AND a74 AND a75 AND a76 AND a77 AND a78,净流入19,'←'),COLORFF0000,linethick1;
DRAWTEXT(a93 AND a94 AND a95 AND a96 AND a97 AND a98,净流入19,'←'),COLOR33FF00,linethick1;
选股1:(a60 AND a61 AND a62 AND a63 AND a64 AND a65 AND a66),colorwhite;
Var2:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
a101: SMA(Var2,6,1),colorblack;
介入:CROSS(净流入1,0) AND a101<40 and 选股1;
DRAWTEXT(介入,净流入19 ,'←注意'),COLORblue,linethick4;
DRAWTEXT(CROSS(0,净流入1) AND a101>60 and a80 AND a81 AND a82 AND a83 AND a84 AND a85 AND a86,净流入19,'←空仓'),COLORyellow,linethick4;

大智慧仁治MACD指标公式

 

相关文章

股票公式月点击榜

股票公式年点击榜

股票公式总点击榜