在线检测未来函数

飞狐主力资金走向指标公式

来源:Internet,编辑:股旁网,2012-11-25

VAR88:=IF(DATE<=1990730,1,0);
DRAWGBK(CLOSE>0,COLORRGB(180,180,180),COLORRGB(1,1,1),1);
VA1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1)*VAR88;
VA2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1)*VAR88;
VA3:=(VA1<REF(VA2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1))*VAR88;
DRAWTEXT(VA3 AND COUNT(VA3,30)=1,15,'有大资金进 关注'),PXUP2,colorFF00FF;
A:=(WINNER(CLOSE+CLOSE*15/100))*100*VAR88;
B:=(WINNER(CLOSE+CLOSE*0/100))*100*VAR88;
CC:=A-B;
D:=(WINNER(CLOSE-CLOSE*0.1/100)-(WINNER(CLOSE-CLOSE*15/100)))*100;
E:=CC<3 AND D<0.5 AND OPEN=LOW;
A1:=DYNAINFO(6)*VAR88;
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0)*VAR88;
A12:=(IF(FILTER(A10,3) OR E,10,0))*VAR88;
资金进场日:IF(A11>0,8,1),STICK,LINETHICK3,colorFFFF;
资金加仓日:IF(A12>0,15,1),STICK,LINETHICK4,colorFF00FF;
DRAWTEXT(A11,8,'资金进场');
DRAWTEXT(A12,17,'资金加仓');
VAR1:=(CLOSE*2+HIGH+LOW)/4*10*VAR88;
VAR2:=(EMA(VAR1,13)-EMA(VAR1,34))*VAR88;
VAR3:=EMA(VAR2,5)*VAR88;
VAR4:=2*(VAR2-VAR3)*5.5*VAR88;
主力:VAR4,LINETHICK2,colorFF;
VAR5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
VAR6:=EMA(3*VAR5-2*SMA(VAR5,18,1),5);
VAR7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
VARA:=EMA(VAR9,3);
VARB:=(VAR9-VARA)/2*VAR88;
大盘资金:VARB,LINETHICK2,colorFF00;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR10:=(HIGH+LOW+CLOSE)/3;
VAR11:=(VAR10-MA(VAR10,14))/(0.015*AVEDEV(VAR10,14));
VAR12:=(VAR10-MA(VAR10,70))/(0.015*AVEDEV(VAR10,70));
VAR13:=IF(VAR11>=150 AND VAR11<200 AND VAR12>=150 AND VAR12<200,10,0);
VAR14:=IF(VAR11<=-150 AND VAR11>-200 AND VAR12<=-150 AND VAR12>-200,-10,VAR13);
VAR15:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
VAR16:=100-ABS(VAR15);
VAR17:=(IF(VAR16<90,VAR16,100))*VAR88;
VAR1A:=(IF(VARE>0,VARE,0))*VAR88;
VAR1B:=IF(VAR12>=200 AND VAR11>=150,15,IF(VAR12<=-200 AND VAR11<=-150,-15,VAR14))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR17<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,'大笔出货.缩量(低位)则洗.'),PXUP2,colorFFCC66;
T1:(VA3 AND COUNT(VA3,30)=1)*28,colorFFFFFF;
主力建仓:(COUNT(A8,30)>=3 AND COUNT(A10,30)>=3)*38,colorFFFF;

飞狐主力资金走向指标公式

 

相关文章