在线检测未来函数

通达信金币主图指标公式

来源:Internet,编辑:股旁网,2012-12-03

MM:=13;N:=102;M:=7;N2:=14;
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
短顶:=AA*N/100,LINETHICK1;
短底:AA*(200-N)/100,LINETHICK1,COLORFF00FF;
DRAWTEXT(CURRBARSCOUNT=1,短底,'__短底'),COLORFF00FF;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
中顶:(1+M/100)*DD,LINETHICK1,COLORFF9150;
中底:(1-M/100)*DD,LINETHICK1,COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,中顶,'__中顶'),COLORFF9150;
DRAWTEXT(CURRBARSCOUNT=1,中底,'__中底'),COLORYELLOW;
VAR4X:=EXPMA(CLOSE,9);
长底:EXPMA(VAR4X*0.86,5),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,长底,'__长底'),COLORGREEN;
{DMI}
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N2);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N2);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N2);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
{CCI}
TYP:=(HIGH+LOW+CLOSE)/3;
CCIA:=(TYP-MA(TYP,N2))/(0.015*AVEDEV(TYP,N2));
{金币}
DRAWTEXT(CROSS(MDI,25),L,'★信号'),COLORYELLOW;
跌穿中轨:=O<短底 AND O<中底 AND O>长底;
跌穿长规:=O<长底;
红K线:=C>O;
带上下影线:=H>O AND H>C AND L<O AND L<C;
山包:=ADX>60;
低位拐弯:=CCIA<-10 AND CCIA-REF(CCIA,1)>1;
DRAWTEXT(跌穿中轨 AND 红K线 AND 低位拐弯,L,'___¥小金币'),COLORMAGENTA;
DRAWTEXT(跌穿长规 AND 红K线 AND 低位拐弯,L,'___$大金币'),COLORRED;

通达信金币主图指标公式

 

相关文章