在线检测未来函数

通达信STY决策指标公式

来源:Internet,编辑:股旁网,2012-12-06

“当下之所以上涨,是因为过去;当下之所以下跌,是因为现在。”【“上涨”包括一、二、三类买点,“下跌”,包括一、二、三类卖点。】

S1:=((2)*(CLOSE)+HIGH+LOW)/(4);
S2:=LLV(LOW,34);
S3:=HHV(HIGH,34);
B1:=EMA(((S1-S2)/(S3-S2))*(100),8);
DRAWICON(EMA(B1,5)>=B1,1,18);
W1:=MA(C,19);
W2:=HHV(W1,2);
W3:=W1-(W2-W1);
DRAWICON(C>=W3,3,21);
K1:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,30)-LLV(LOW,36))*0.6*CLOSE;
K2:=SMA(K1,6.3,1);
K3:=SMA(K2,3,1);
K4:=3*K2-2.1*K3;
K5:=3*K3-1* K2;
K6:=IF(K5>K4,K4,K5);
DRAWICON(K6>=REF(K6,1),5,22);
A:=FORCAST(EMA((3*CLOSE+2*OPEN+HIGH+LOW)/7,3),6);
DRAWICON(A>=REF(A,1),7,23);
AA:=EMA(CLOSE,9)-EMA(CLOSE,2*9+2),NODRAW;
MAXV:=CONST(HHV(VOL,96));
MAXD:=CONST(MAX(ABS(HHV(AA,96)),ABS(LLV(AA,96))));
BS:=MAXV/MAXD;
CC:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN*0.8/BS,DRAWNULL);
VOLUME:=VOL*0.8/BS,NODRAW;
R:=VOL/((H-L)*2-ABS(O-C));
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,VOLUME,R*(C-L)*0.8/BS);
DRAWICON(买>=REF(买,1),9,13);
YY:=(3*C+3*O+0.618*L+0.382*H)/4;
DRAWICON(YY>=REF(YY,1),11,14);
FC:=(4*C+0.618*L+0.382*H)/5;
LC:=REF(FC,1);
RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),8,1)*100;
RSI3:=SMA(MAX(C-LC,0),18,1)/SMA(ABS(C-LC),21,1)*100;
短期趋势:=MA(6.18*RSI2-3.82*SMA(MAX(C-LC,0),13,1)/SMA(ABS(C-LC),6,1)*100,3)/10;
DRAWICON(短期趋势>=REF(短期趋势,1),13,15);
大盘涨幅:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
个股涨幅:=(C-REF(C,1))/REF(C,1)*100;
AD:=大盘涨幅*11;
AG:=个股涨幅*9;
强弱趋向:=AG-AD;
DRAWICON(强弱趋向>=REF(强弱趋向,1),16.5,11);
XD:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
CD:=WMA(0.618*REF(XD,1)+0.382*XD,2);
DRAWICON(CROSS(XD,CD) AND XD<30,22,1);

通达信STY决策指标公式

 

相关文章