在线检测未来函数

通达信红绿K线主图指标公式

来源:Internet,编辑:股旁网,2012-12-06

DRAWTEXT_FIX(1,0.05,0.0,0,'【操作提示】★ ★ 红K强势做多持股 ★ ★ 绿K持币空仓休息 ★ ★ 黄K阶段性反弹手里有货T+0 ★ ★ 蓝K阶段性超跌准备抢反弹 ★ ★ '),COLORMAGENTA;
MA13:MA(C,13),COLORWHITE,LINETHICK3;
IF(MA13>REF(MA13,1),MA13,DRAWNULL),COLORRED,LINETHICK3;
IF(MA13<REF(MA13,1),MA13,DRAWNULL),COLORGREEN,LINETHICK3;
MA34:MA(CLOSE,34),LINETHICK2;
MA89:MA(CLOSE,89),LINETHICK2;
短线:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100;
中线:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100;
长线:=(C-LLV(L,89))/(HHV(H,89)-LLV(L,89))*100;
AAA:=长线>50;
BBB:=长线<=50;
CCC:=长线<=51 AND 短线>50 AND 中线>50;
DDD:=长线<=51 AND 短线>50 AND 中线<=50;
STICKLINE(AAA,H,L,0,0),COLOR106FFF;
STICKLINE(BBB,H,L,0,0),COLORGREEN;
STICKLINE(CCC,H,L,0,0),COLORYELLOW;
STICKLINE(DDD,H,L,0,0),COLORYELLOW;
STICKLINE(AAA,C,O,4,0),COLOR0000C8;
STICKLINE(AAA,C,O,3,0),COLOR0000D7;
STICKLINE(AAA,C,O,2,0),COLOR0000EA;
STICKLINE(AAA,C,O,1,0),COLOR0000FF;
STICKLINE(BBB,C,O,4,0),COLOR00B500;
STICKLINE(BBB,C,O,3,0),COLOR00C600;
STICKLINE(BBB,C,O,2,0),COLOR00D500;
STICKLINE(BBB,C,O,1,0),COLOR00E600;
STICKLINE(CCC,C,O,4,0),COLOR33CFDD;
STICKLINE(CCC,C,O,3,0),COLOR33DFDD;
STICKLINE(CCC,C,O,2,0),COLOR33EFDD;
STICKLINE(CCC,C,O,1,0),COLOR33FFDD;
STICKLINE(DDD,C,O,4,0),COLOR33CFDD;
STICKLINE(DDD,C,O,3,0),COLOR33DFDD;
STICKLINE(DDD,C,O,2,0),COLOR33EFDD;
STICKLINE(DDD,C,O,1,0),COLOR33FFDD;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
STICKLINE(RSI1<15,H,L,0,0)COLORFF9900;
STICKLINE(RSI1<15,C,O,4,0),COLORFF9900;
STICKLINE(RSI1<15,C,O,3,0),COLORFFAA00;
STICKLINE(RSI1<15,C,O,2,0),COLORFFBB00;
STICKLINE(RSI1<15,C,O,1,0),COLORFFCC00;

通达信红绿K线主图指标公式

 

相关文章