在线检测未来函数

通达信与君波段之王主图指标公式

来源:Internet,编辑:股旁网,2012-12-06

多方强度:EMA(CLOSE,3),COLOR00FFFF;
NOTEXT1:IF(多方强度<REF(多方强度,2),多方强度,DRAWNULL),COLORFFFFFF;
空方强度:EMA(CLOSE,8),COLORFF00FF;
NOTEXT2:IF(空方强度<REF(空方强度,2),空方强度,DRAWNULL),COLOR00FF00;
多空平衡:EMA(CLOSE,17),LINETHICK2,COLORRED;
NOTEXT3:IF(多空平衡<REF(多空平衡,2),多空平衡,DRAWNULL),LINETHICK2,COLORBLUE;
洗盘线:EMA(CLOSE,27),LINETHICK1,COLOR0080FF;
NOTEXT4:IF(洗盘线<REF(洗盘线,1),洗盘线,DRAWNULL),LINETHICK1,COLOR408080;
DRAWICON(CROSS(多方强度,空方强度),空方强度,13);
DRAWICON(CROSS(空方强度,多方强度),空方强度,14);
LC:=REF(CLOSE,1);
RSI:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.98,'见机★买'),COLOR0000FF;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'★卖'),COLORFF00FF;
量:=REF(CLOSE,REF(HHVBARS(VOL,21),0));
M1:=MA(CLOSE,1);
A:=VOL>1*REF(VOL,1) AND (CLOSE/REF(CLOSE,1)-1)*100>9.5 AND M1>=量;
DRAWICON(CROSS(A,1),LOW*0.98,5),COLORFFFFFF;
DRAWTEXT(A,LOW*0.93,'追涨停'),COLORFF00FF;
古道:=MA(CLOSE,5),LINETHICK1,COLOR00FFFF;
西风:=MA(CLOSE,10),LINETHICK1,COLORFF00FF;
瘦马:=MA(CLOSE,25),LINETHICK1,COLOR0000FF;
断肠:=MA(CLOSE,34),LINETHICK1,COLORFFFF00;
人在:=MA(CLOSE,62),LINETHICK1,COLORFF0000;
天涯:=MA(CLOSE,99),LINETHICK1,COLOR00FF00;
荣归故里:=MA(CLOSE,181),LINETHICK1,COLORFFFFFF;
VAR1:=(OPEN+LOW+HIGH+CLOSE)/(4);
STICKLINE(1,VAR1,VAR1,2,0),COLORFF00FF;
FA:=BARSLAST(CROSS(西风,古道)) AND CROSS(古道,西风);
FB:=FA AND (古道>断肠) AND (西风>断肠) AND (西风>REF(西风,1));
STICKLINE(FB,LOW,LOW-0.09,1,0),COLORFFFFFF;
DRAWTEXT(FB,LOW-0.13,'西风'),COLORFFFFFF;
FA1:=BARSLAST(CROSS(人在,瘦马)) AND CROSS(瘦马,人在);
FB1:=FA AND (瘦马>天涯) AND (人在>天涯) AND (瘦马>REF(瘦马,1));
STICKLINE(FB,LOW,LOW-0.09,4,0),COLORFFFFFF;
DRAWTEXT(FB,LOW-0.13,'西风'),COLOR00FF00;
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
K:=SMA(VARF,3,1);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79),HIGH+0.1,'风雨飘摇'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,'多空平衡线 | 最低点低吸'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,'红线:工作 | 蓝线:休息'),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,'红点:买入 | 绿点:清仓'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,'线上阴线买 | 买错也要买'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.24,0,'线下阳线卖 | 卖错也要卖'),COLORYELLOW;

通达信与君波段之王主图指标公式

 

相关文章