在线检测未来函数

通达信低位买股主图指标公式

来源:Internet,编辑:股旁网,2012-12-06

MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5) );
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=MA(MMV,1);
SA:=(MM*0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
牛熊分界线:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
IF(SSL<MM,牛熊分界线,DRAWNULL),LINETHICK2,COLORGREEN;
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
黄金线:=A,COLORYELLOW,LINETHICK1;
B:=REF(A,1);
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
{DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.98,'★抄底有未来,牛市准') ,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.03,'★卖有未来,熊市卖准,高卖低补!'),COLORGREEN;}
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 黄金线>REF(黄金线,1),VA1*0.985,'★追涨'),COLORYELLOW;
压力:MA(REF(HHV(上收,30),1),2),COLORABFF46,LINETHICK1;
支撑:MA(REF(LLV(上收,30),1),2),COLORMAGENTA,LINETHICK1;
{所以压力线是前期一个月甚至半年的最大阻力位。如果主力突然有一天突破了半年甚至以上的阻力位了,这就说明主力解放了前面很多被套投资者。这时个股可能还有涨幅!};
{老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.96,'老鼠仓'),COLOR4080FF;
{预测明天}
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
均线:=C,COLORGREEN;
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK1 ;
DRAWTEXT(AAAA,LOW*0.95,'下影买'),COLORRED;
BBAA:=CROSS(XXS1,C);
DRAWTEXT(CROSS(XXS1,C),HIGH*1.04,'开盘逃'),COLORGREEN;
DDDD:=CROSS(C,XXS1);
DRAWTEXT(DDDD,HIGH*1.03,'明日走'),COLORYELLOW;
{加仓一出,当日就会出高点,在高点不能加仓,要当日逢高全出,所以把加仓改成了慎追涨,安全第一!}
MA5:MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:MA(CLOSE,30),LINETHICK1;
五日乖离率:=(C-MA5)/MA5*100;
BB05:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
SSR:=(C-MA30)/MA30*100,NODRAW;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA5>REF(MA5,1) AND SSR>REF(SSR,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
DRAWTEXT(加仓 ,LOW*0.96,'◆慎追涨'),COLORYELLOW;
{彩色攻击线}
攻击线:MA(C,5),LINETHICK2,COLOR00CCFF;
MA05:=MA(C,5);
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORGREEN;
{精准买卖点主图}
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'★精准买'),COLORRED;
加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(加1,LOW,'★精准加'),COLORCC66FF;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★精准卖'),COLORGREEN;
{涨停标志线}
涨停:=IF((C-REF(C,1))/REF(C,1)>0.097,1,0);
STICKLINE(涨停,OPEN,CLOSE,0.5,0),COLORYELLOW;
{出水芙蓉倍量主图}
EMA20:EMA(C,20),COLORWHITE,NODRAW;
EMA40:EMA(C,40),COLORYELLOW,NODRAW;
EMA60:EMA(C,60),COLORFF00FF;
MA020:=EMA(CLOSE,20);
MA040:=EMA(CLOSE,40);
MA060:=EMA(CLOSE,60);
A1:=OPEN<MA020 OR OPEN<MA040 OR OPEN<MA060;
A2:=C>MAX(MA020,MAX(MA040,MA060));
A3:=V/MA(V,10)>1.2;
A4:=C/REF(C,1)>1.049;
A5:=VOL/REF(VOL,1)>=1.9;
出水芙蓉:=A1 AND A2 AND A3 AND A4 AND A5 AND O<MA060 AND C>MA060;
DRAWTEXT(出水芙蓉,H-0.20,'出水芙蓉');

通达信低位买股主图指标公式

 

相关文章