在线检测未来函数

大智慧标尺浪波段指标公式

来源:Internet,编辑:股旁网,2012-12-07

N1:=9;N:=3;
VAR1:=REF(CLOSE,1);
标尺: SMA(MAX(CLOSE-VAR1,0),5,1)/SMA(ABS(CLOSE-VAR1),5,1)*100;
VAR2:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1);
浪: VAR3,COLORBLUE;
波: VAR4, COLORRED;
段: VAR5 ,COLORYELLOW;
VAR6:=CROSS(VAR3,VAR4) AND VAR4<25;
STICKLINE(VAR6,0,VAR4+15,5,0), COLORGREEN;
VAR7:=CROSS(VAR4,VAR5) AND VAR4<25;
VAR8:=VAR7 AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
STICKLINE(VAR7,0,VAR4+55,5,0),COLORWHITE;
DRAWTEXT(VAR7 AND COUNT(VAR7,10)=1,VAR4+25,'抄底'),COLORYELLOW;
STICKLINE(VAR8,0,VAR4+15,5,0),COLORBLUE;
DRAWTEXT(VAR8 AND COUNT(VAR8,10)=1,VAR4-1,'放量'),COLORGREEN;
VAR9:=CROSS(VAR3,VAR4) AND VAR4>80 AND VAR4>VAR5;
STICKLINE(VAR9 AND COUNT(VAR9,5)=1,VAR4-5,100,5,0),COLORYELLOW;
VARA:=CROSS(VAR5,VAR4) AND REF(VAR4,1)>80;
STICKLINE(VARA,VAR4-15,100,15,0), COLORYELLOW;
DRAWTEXT(VARA AND COUNT(VARA,10)=1,VAR4-25,'逃顶'), COLORYELLOW;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VAR20,0,50,10,0),LINETHICK2,COLORBLUE;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,60,'百万导弹?'),LINETHICK7,COLORWHITE;

大智慧标尺浪波段指标公式

 

相关文章