在线检测未来函数

通达信牛图主图指标公式

来源:Internet,编辑:股旁网,2012-12-10

N:=3;
VAR91:=(C+H+O+L)/4;
A:=SMA(VAR91,5,1)-SMA(VAR91,55,1);
B:=SMA((A-SMA(A,5,1)),5,1);
STICKLINE(C,H,L,0,1),COLORGREEN;
STICKLINE(C>=O,O,C,4,1),COLORGREEN;
STICKLINE(C<O,O,C,4,0),COLORGREEN;
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),H,L,0,1),COLORRED;
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1) AND C>=O,O,C,4,1),COLORRED;
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1) AND C<O,O,C,4,0),COLORRED;
STICKLINE(CLOSE<MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),H,L,0,1),COLORWHITE;
STICKLINE(A<REF(A,3) AND B<REF(B,3),H,L,0,1),COLORFF7F00;
STICKLINE(A<REF(A,3) AND B<REF(B,3) AND C>=O,O,C,4,1),COLORFF7F00;
STICKLINE(A<REF(A,3) AND B<REF(B,3) AND C<O,O,C,4,0),COLORFF7F00;
STICKLINE(A>REF(A,1) AND B<REF(B,1),H,L,0,1),COLOR99CCFF;
STICKLINE(A>REF(A,1) AND B<REF(B,1) AND C>=O,O,C,4,1),COLOR99CCFF;
STICKLINE(A>REF(A,1) AND B<REF(B,1) AND C<O,O,C,4,0),COLOR99CCFF;
STICKLINE((A<REF(A,1) AND B>REF(B,1)),H,L,0,1),COLORFF00FF;
VAR1:=(C+H+O+L)/4;
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR1,13);
VAR71:=REF(CLOSE,1)-REF(ATR,1);
LSX:=HHV(VAR1,13),LINETHICK1,COLORLIBLUE;
智能交易:HHV(VAR1,13),LINETHICK1,COLORLIBLUE;
DRAWTEXT(ISLASTBAR,智能交易,智能交易),COLORLIBLUE;
LSX1:=IF(C>=LSX,LSX,DRAWNULL),COLORRED,LINETHICK2;
智能交易1:IF(C>=LSX,LSX,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,智能交易1,智能交易1),COLORRED;
趋势射线7: DRAWLINE(H=HHV(H,7),H,L=LLV(L,7),L,0),COLOR9AFF89;
射线7X: DRAWLINE(L=LLV(L,7),L,H=HHV(H,7),L,0),COLOR9AFF89;
趋势射线21: DRAWLINE(H=HHV(H,21),H,L=LLV(L,21),L,0),COLORC100FF;
射线21X: DRAWLINE(L=LLV(L,21),L,H=HHV(H,21),L,0),COLORC100FF;
趋势射线35: DRAWLINE(H=HHV(H,35),H,L=LLV(L,35),L,0),COLORC1005B;
射线35X: DRAWLINE(L=LLV(L,35),L,H=HHV(H,35),L,0),COLORC1005B;
趋势射线49: DRAWLINE(H=HHV(H,49),H,L=LLV(L,49),L,0),COLORYELLOW;
射线49X: DRAWLINE(L=LLV(L,49),L,H=HHV(H,49),L,0),COLORYELLOW;
P:=8;
A91:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A91,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
A2:=REF(H,P)=LLV(H,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S911:=R11>REF(R11,1);
DRAWLINE(D1,H,S911,H,1),COLOR00FF00,LINETHICK0;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORYELLOW,LINETHICK0;
DRAWICON(D1,H+0.1,21);
DRAWICON(D2,L-0.2,22);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
买点:STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,3,0),COLOR00FFFF;
A6:=BACKSET(ISLASTBAR,PEAKBARS(1,10,1)+1);
A7:=IF(A6>REF(A6,1),1,0);
A1:=REF(ZIG(2,10),1)=LLV(ZIG(2,10),3);
A82:=BACKSET(A7,BARSLAST(A1)+2);
A3:=IF(A82>REF(A82,1),1,0);
DRAWLINE(A3,LOW,A7,HIGH,0);
A8:=REF(LOW,BARSLAST(A3));
A9:=REF(HIGH,BARSLAST(A7));
A0:=A9-A8;
25%:A9-A0*0.25;
33%:A9-A0/3;
37%:A9-A0*0.375;
50%:A9-A0*0.5,LINETHICK2;
63%:A9-A0*0.625,LINETHICK2;
67%:A9-A0/3*2;
75%:A9-A0*0.75;
100%:A9-A0*1;
回调:A9-A0*0;
DRAWTEXT(A7,A9-A0*0.25,25%);
DRAWTEXT(A7,A9-A0/3,33%);
DRAWTEXT(A7,A9-A0*0.375,37%);
DRAWTEXT(A7,A9-A0*0.5,50%);
DRAWTEXT(A7,A9-A0*0.625,63%);
DRAWTEXT(A7,A9-A0/3*2,67%);
DRAWTEXT(A7,A9-A0*0.75,75%);
ZYXF:=TROUGHBARS(3,15,1)<4;
DRAWICON(FILTER(ZYXF=1,3),LOW*0.98,38);
最低跌停:=L<REF(C,1)*0.9004;
DRAWICON(最低跌停,HIGH*1.01,39);

通达信牛图主图指标公式

 

相关文章