在线检测未来函数

通达信短线主图指标公式

来源:Internet,编辑:股旁网,2012-12-10

F:EMA(C,5);
X:=EMA(C,34),COLORGRAY,LINETHICK1;
KS:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
RKS:=REF(KS,1);
MLS:=RKS/KS>1.23 AND RKS>10 AND C/REF(C,1)>1.02;
J:STICKLINE(KS>=10,H,L,0,1),COLORWHITE,LINETHICK2;
短:EMA(C,13),COLORRED,LINETHICK2;
线:EMA(KS*C/100+短,3), COLORFF9933,LINETHICK1;
反弹:STICKLINE(MLS=1,H,L,0,1),COLORFF00FF,LINETHICK2;
STICKLINE(短>线,短,线,1,1),COLORFF00FF;
DRAWKLINE(H,O,L,C);
STICKLINE(C>=O,C,O,3,0),COLORRED;
STICKLINE(C<O,C,O,3,0),COLORGRAY;
STICKLINE(KS>10,O,C,3,1),COLORWHITE,LINETHICK1;
STICKLINE(MLS,H,L,0,0),COLOR00FFFF,LINETHICK1;
STICKLINE(MLS,O,C,3,0),COLOR00FFFF,LINETHICK1;
VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力:= REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR00B4FF;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
ARSV:=SMA(下档线,3,1);
AK:=SMA(ARSV,3,1);
AD:=((3 * ARSV) - (2 * AK));
AJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
ARSV24:=SMA(AJ12,3,1);
AK24:=SMA(ARSV24,3,1);
AD24:=((3 * ARSV24) - (2 * AK24));
撑:=IF(CROSS(AD24,AD),HIGH,REF(HIGH,BARSLAST(CROSS(AD24,AD))));
撑压位:=IF(ISLASTBAR ,撑,DRAWNULL);
底底:=LLV(HIGH,30);
底:=IF(ISLASTBAR ,底底,DRAWNULL);
STICKLINE(ISLASTBAR ,撑压位,撑压位,100,1),LINETHICK1,COLORFFFFFF;
STICKLINE(ISLASTBAR ,底,底,80,1),COLOR00FF00,LINETHICK1;

通达信短线主图指标公式

 

相关文章