在线检测未来函数

通达信单纯MACD指标公式

来源:Internet,编辑:股旁网,2012-12-11

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK2,COLORWHITE;
D:SMA(K,3,1),LINETHICK2,COLOR00DDDD;
J:3*K-2*D,LINETHICK2,COLOR800080;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK0,COLOR0099FF;
DEA :EMA(DIF,9),LINETHICK0,COLORD89837;
MACD:2*(DIF-DEA),COLORFF9999,LINETHICK0;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB;
今撑:REF(支价,1),LINETHICK0,COLOR009900;
明压:阻价,LINETHICK0;
明撑:支价,LINETHICK0;
RSV1:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*101;
KK:=SMA(RSV1,3,1);
DD:=SMA(KK,3,1);
JJ:=3*KK-2*DD;
买卖:=IF(JJ>=100,100,IF(JJ<=0,0,JJ));
明天买:IF(买卖=100,0-10,0),COLOR00CCCC;
明天卖:IF(买卖=0,90,100),COLOR00FF00;
KX:=250;
KH:=HHV(K,KX);
DH:=HHV(D,KX);
JH:=HHV(J,KX);
KL:=LLV(K,KX);
DL:=LLV(D,KX);
JL:=LLV(J,KX);
HKMAX:=MAX(KH,MAX(DH,JH));
LKMIN:=MIN(KL,MIN(DL,JL));
KHLB:=(HKMAX+LKMIN)/2;
KHLC:=HKMAX-LKMIN;
MHF:=HHV(DIF,KX);
MHD:=HHV(DEA,KX);
MHM:=HHV(MACD,KX);
MLF:=LLV(DIF,KX);
MLD:=LLV(DEA,KX);
MLM:=LLV(MACD,KX);
HMAX:=MAX(MHF,MAX(MHD,MHM));
LMIN:=MIN(MLF,MIN(MLD,MLM));
FHLB:=(HMAX-LMIN)/100;
FHLC:=HMAX-LMIN;
SH:=(0-FHLB)*(KHLC/FHLC)+KHLB;
DIFA:=(DIF-FHLB)*(KHLC/FHLC)+KHLB;
DEAA:=(DEA-FHLB)*(KHLC/FHLC)+KHLB;
MACDA:=(MACD-FHLB)*(KHLC/FHLC)+KHLB;
CDA:=MACD<REF(MACD,1) AND MACD>0;
CDB:=MACD>=REF(MACD,1) AND MACD>0;
CDC:=MACD>REF(MACD,1) AND MACD<0;
CDD:=MACD<=REF(MACD,1) AND MACD<0;
STICKLINE(CDA,SH,MACDA,2,0),COLOR00AAFF;{黄色段}
STICKLINE(CDB,SH,MACDA,2,0),COLOR0000AA; {红色段}
STICKLINE(CDC,SH,MACDA,2,0),COLORAA00BB;{向上粉红}
TYP:=(HIGH+LOW+CLOSE)/3;
STICKLINE(DIF>REF(DIF,1),20,20,2,0),COLORRED;
STICKLINE(DIF<REF(DIF,1),20,20,2,0),COLORGREEN;
STICKLINE(K>=REF(K,1) OR K>D AND DIF>REF(DIF,1),80,80,2,1),COLORRED;
STICKLINE(K<REF(K,1),80,80,2,1),COLORGREEN;
MACD金叉:=CROSS(MACD,DIF) AND MACD>=(0-0.05) AND MACD<=0.02;
DRAWTEXT(MACD金叉,MACDA*0.82,'▲MACD金叉'),COLOR00FFFF;
XX:=EMA(MA(LOW,3)*0.96,30);
DIF金叉:=IF(CROSS(DIF,DEA) AND XX-REF(XX,1)>0 AND MACD>=REF(MACD,1) AND DIF<=0,1,0);
DRAWTEXT(DIF金叉=1,DIFA*1.68,'DIF金叉'),COLORCDFFBB;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
DRAWTEXT(低位金叉,DEAA*0.99,'▲DIF低位金叉'),COLOR0099DD;
DIFDEA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(DIFDEA=2,21)=1;
DRAWTEXT(二次金叉,DEAA*0.99-8,'▲DIF 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
DRAWTEXT(底背离,DEAA*0.99-16,'▲DIF底背离'),COLOR0099FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(FILTER(顶背离,5),DEAA*1.02,'▲DIF顶背离'),COLORDDAAAA;

通达信单纯MACD指标公式

 

相关文章